Enrollment of Samsung Android does not show IMEI or Sim serial numbers anymore in the device info

We are using mostly an on premise version of the MDM server, but the Sophos Central is showing the same problem. Don't get any answers from the support desk :-(

Normaly we are enrolling our Samsungs with KME, this is resulting in a device name like "Samsung KME 351231231231234" (the IMEI). But the last couple of months. All (and ONLY) the newer devices like A40, A41 A50, S series are getting devicenames like Samsung KME c9268dd6850d895f. According the Device properties this is the Android-ID and the Build Serial at the same time...
Also the IMEI nr or Simcard serial are knowhere to be found in the Device properties. 

I also tried the "add device wizard" (scan QR code etc) for an manual erollment of an A40 on my on premise AND in Sophos central server, to rule out if it was an Samsung Knox thing, with the same result. 

As an bonus: the Android_ID is not always the same for 1 device. I have seen a user who tried 5x an enrollment, resulting in 5 different names for 1 device!

 

It would feel logical to think about a Sophos<->Android 10 problem. But the Xcover4s with android 10 is not affected.

Anyone an idea? I feel like I have tried every angle by now. 

  • Hi  

    This is happening for only Samsung devices? I have checked for other android devices and it is showing me IMEI and serial number information under the device properties tab. Could you please PM me the case number you have already registered? 

    Shweta

    Community Support Engineer | Sophos Technical Support
    Support Videos | Product Documentation@SophosSupport | Sign up for SMS Alerts
    If a post solves your question use the 'Verify Answer' link.

     

  • Hello Shweta, Sophos just forwarded te case in a new call nr: 

    Your existing case 10009071 has been closed and a NEW case has been created.

    Your new case number is: 03081048

     

    We only use Apple and Samsung. The problem is only occuring with newer types of Samsung. When I (re-)enroll an A6 or A8 it's just fine. Doesn't matter if I use Samsung KME or manual with the QR code. 

    The information is not to be found onder dev. properties. That's the whole problem. I have no way of uniquely indentifing a device, since IMEI or Samsung Serial are not shown anywhere. And even the shown Wi-Fi Mac adres is usefull, because it is not the MAC of the device, but a router its connected with.example of Sophos server vs Cloud IMEI bug .xls

  • Hi  

    For the devices for which it is working fine, are those Android 10 devices or earlier? I am in a discussion with our global escalation team to confirm if this is the case only with Android 10 devices, shall update you with further information. 

    Shweta

    Community Support Engineer | Sophos Technical Support
    Support Videos | Product Documentation@SophosSupport | Sign up for SMS Alerts
    If a post solves your question use the 'Verify Answer' link.

     

  • It was my first thought also.
    But the Xcover 4s with Android 10 is doing fine. Biggest problem the XC4S on Android 10 have is not showing the Sim serial or IMSI. Seems also something that is only happening to all the Android 10 devices in Sophos

     

     

    Android 10 XC4s: wrong serial (should show IMEI) and no SIM info

    serial_number 7d50af041d4d9060

     

    Android 9 XC4s : correct serial and full SIM info

    serial_number 35552311...........
    SIM IMSI 204...080.........5
    SIM operator KPN (20408)
    SIM serial number 89...80..........4
  • Sad to say that Sophos SD has close the case for now:  "Unfortunately at this moment in time there are no plans to implement the IMEI numbers into the KME devices for Sophos mobile." 

    B*S* if you ask me, IMEI numbers have always worked and still do for older devices. IMEI is one of the most basic and most used ways a phone has to identify itself. As I see it they can't resolve or reproduce it and are calling it a non existing feature now. 

    Is there know one else with this issue? In my opinion it has nothing to do with Samsung KME, beacause of the fact it is also happening to non Knox devices who I enroll the "old fashion way" with a QR code.

  • I think I found my own solution, at least for the KME part. I have not tested how QR enrollment handles with Android Enterprise. 

    We where stille running on the old Android device administrator mode. “If it ain’t broken, don’t fix it you know..”. But now i’m testing with the Android Enterprise settings en KME enrollement and voila, See screendump same device in Device mode en Android Enterprise fully managed mode.