isdone.dll and unarc.dll errors

good morning,
I'm trying to install some very compressed game packages using different PCs (for example: Ace Combat 7 Skies Unknown v1.0.1 (Monkey Repack) [FitGirl Repack] and RESIDENT EVIL 2 Deluxe Edition + 9 DLCs [FitGirl Repack]).
If I use the sandboxie, a very common error appears regarding two isdone.dll and unarc.dll libraries that promptly disappears by installing the package outside the sandbox.
thank you

  • Hi Sal,

    If you are trying to install drivers/services inside Sandboxie, they will fail, as that is not supported.  

    If you are experiencing a different issue, please provide more information as per the guidelines:
    How to report problems with Sandboxie


    Community Support Engineer | Sophos Technical Support
    Knowledge Base  |  @SophosSupport  | Sign up for SMS Alerts
    If a post solves your question use the 'This helped me' link.


  • good morning,

    I believe that the setup file (it would seem to have been created with inno setup) only executes a decompression program (freearc) and copies the obtained files to an installation folder.

    I could send you (regardless of the size of the archives and if you want) the individual setup files (the size of a few MB in which you could certainly extract the installation instructions).

    In the meantime I have asked the package releasers for explanations why this kind of error occurs.

    Thank you, see you soon

  • the two PCs on which I tried to install the repacks are:
    Acer Predator Portable PC 16GB RAM GTX970M
    PC Assembled 3GB RAM GTS250
    Sandboxie 5.30, Windows 10 x64 bit 1809 on both (Pro version on the assembled and Home on the laptop)
    Windows Defender + Windows Firewall updated to the latest version
    the error message is:
    ISDone.dll: an error occured when unpacking! unarc.dll returned to error code -1 ERROR: archive data corrupted (decompression fails).
    if you want, I can attach screenshots.
    I confirm that without using sandboxie, the error does not appear
    see you later

  • Hi Sal,

    Please follow the guidelines I provided earlier so that I can review the situation.

    As a suggestion, you may want to try to decompress the files outside Sandboxie, and then copy them to your Sandboxed folder (Typically located under C:;\Sandbox...) 

    I'll leave this thread open so that other users can review and assist. 


    Community Support Engineer | Sophos Technical Support
    Knowledge Base  |  @SophosSupport  | Sign up for SMS Alerts
    If a post solves your question use the 'This helped me' link.


  • Hi, it is a common error you can come across when you install anything software or game on PC using Windows 10 or 8. The 'isdone.dll' error might be caused when the registry in your computer has been destroyed or damaged and the 'unarc.dll' file error can occur when a program is not able to locate and use this file. Both the error can be fixed easily and differently. Both isdone.dll and unarc.dll errors actually can be fixed to fix isdone.dll you need not run registry cleaner if still, it doesn't work try a step by step solution to fix isdone.dll.

    In order to fix unarc.dll, you need to download and re-install the ‘unarc.dll’ file in a specific folder of PC type 32 bits or 64 bits { Windows>> System32 } or { Windows>> WOWsys64}. Now restart the PC. If it still doesn't work then follow step by step solution to fix unarc.dll.




  • I solved this poblem by changing from within the Sandbox the "system variables" setting for TMP, TEMP folders to an empty folder outside of my system profile (this is for preventing any sandboxed processes from modyfying files in my real temporary folder), then enabling Full access to that specific folder in the Sandbox settings. In that case unpacking completes without any errors. After a successful installation the changed settings can be safely reverted.

    These errors are obviously caused by the more strict access rights and permissions policy introduced in Win 10. I never faced issues like that with  Win 7 or 8. Hopefully, I do not put my system at risk by making  an empty non-system folder accessible and perhaps there might be a more subtle and secure solution too.

  • Thanks,

    if I don't get it wrong (list the step-by-step instructions, for other users who have encountered the same problem):
    1) start the "cmd" program as administrator within the sandboxie (as administrator in order to also modify the system environment variables);
    1) I run the command "sysdm.cpl" inside the command shell (this command opens the system properties window);
    2) I go to advanced / environment variables;
    3) change the path of the user and system environment variables (ie TEMP and TMP) by associating a different folder (for example, for all, I associate the folder D: \ TEMP);
    4) go to the virtual area settings / access to resources / access to files / full access and add the folder "D: \ TEMP";
    While doing all this, the following error is always present:
    An error occured while unpacking - Unknown compression method!
    Unarc.dll returned an error code: -2
    ERROR - unsupported compression method
    Could this be a problem due to the amount of RAM managed by sandboxie?

    update on 15/12/2021:
    thanks, i misunderstood previously, it works. Slight smileSlight smileSlight smileSlight smileSlight smile
    More simply I have performed point 4 without performing the previous ones:
    4) go to the virtual area settings (of main sandboxie window) / access to resources / access to files / direct access
    and there I added the folder: (e.g.) c: \ users \ username \ appdata \ local \ temp
    for all programs
    (thanks also to the users of this thread: )