This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

unable to install endpoint on windows 10



This thread was automatically locked due to age.
  • Thank you for reaching community forum. Can you share with us the full cloud installer logs as the shared snapshot of the logs didn't show any error message? You can copy past the full logs here.

    Glenn ArchieSeñas (GlennSen)
    Global Community Support Engineer | Global Community and Digital Customer Support
    Connect, Engage, Earn Rewards - Join the Sophos Community
  • Hi Glenn, I'm seeing the same issue here. Please see the full installer log..SophosCloudInstaller_20220830_140356.zip

  • Hi Andrew, 


    As per the logs, I could see some certificate validation getting failed.

    2022-08-30T14:19:16.3553915Z INFO : ValidateFileCertificateCheck: Validate certificate against file on WINHTTP_CALLBACK_STATUS_SENDING_REQUEST
    2022-08-30T14:19:16.3553915Z INFO : Subject certificate failed validation against root CA: SophosCA1
    2022-08-30T14:19:16.3553915Z INFO : Subject certificate failed validation against root CA: SophosCA2
    2022-08-30T14:19:16.3553915Z INFO : Certificate check succeeded

    However, the ERROR in the logs indicates that the installation is timing out while trying to get endpoint policies on registration.

    "
    2022-08-30T14:19:16.3709884Z INFO : No policy assignment command; wait for policy to render
    2022-08-30T14:19:21.3862777Z ERROR : RegisterCommand::onRun standard exception: Failed to retrieve policy within 900 seconds
    2022-08-30T14:19:21.3862777Z INFO : Command 'Register' completed with failure with reboot code '0' and error message 'Could not register with Sophos Central'.
    2022-08-30T14:19:21.3862777Z ERROR : Installation failed.

    "

    It has been identified that the cause of this is due to the endpoint having previously been registered in Sophos Central.

    Please try the following workaround and do let me know how it goes. 

    1. Sign in to Sophos Central.
    2. Delete the device.
    3. Rename the hostname.
    4. Reinstall Sophos.
    5. Rename the hostname back to its original name and restart. 

    Ismail Jaweed Ahmed (Ismail) 
    Senior Professional Service Engineer

  •   As Glenn mentioned, it would be easy for us to investigate if you could share the cloud installer log

    Ismail Jaweed Ahmed (Ismail) 
    Senior Professional Service Engineer

  • Also if you could see the exact same errors in the logs, request you to follow the workaround mentioned above.

    Ismail Jaweed Ahmed (Ismail) 
    Senior Professional Service Engineer

  • Thank you All for sharing your inputs on this community Thread.  is right about this. There’s an Internal conversation about these errors that can be found on these lines below. Our dev team is aware of it, and a workaround is what has been shared in this community thread. 

    2022-08-30T14:19:16.3709884Z INFO : No policy assignment command; wait for policy to render
    2022-08-30T14:19:21.3862777Z ERROR : RegisterCommand::onRun standard exception: Failed to retrieve policy within 900 seconds
    2022-08-30T14:19:21.3862777Z INFO : Command 'Register' completed with failure with reboot code '0' and error message 'Could not register with Sophos Central'.
    2022-08-30T14:19:21.3862777Z ERROR : Installation failed. 


    Glenn ArchieSeñas (GlennSen)
    Global Community Support Engineer | Global Community and Digital Customer Support
    Connect, Engage, Earn Rewards - Join the Sophos Community
  • Thanks for all your help, I can confirm the workaround has solved the problem.

  • Glad it is resolved. It's a pleasure assisting you :)

    Have a good one.

    Ismail Jaweed Ahmed (Ismail) 
    Senior Professional Service Engineer