This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

RED 50 boot error

My RED 50 is suddenly no longer making a connection.
I can see on the modem that it is fetching an DHCP IP address, but the message "Network error" appears on the display.
I tried to reflash the RED, but unfortunately it doesn't work either.

MB351Z => usb start;usb storage;usb dev 0;fatload usb 0:1 0x2000000 boot_red50.bin;source 0x2000000
(Re)start USB...
USB: Register 10011 NbrPorts 1
scanning bus for devices... 3 USB Device(s) found
scanning bus for storage devices... Device NOT ready
Request Sense returned 06 3A 00
1 Storage Device(s) found
Device 0: Vendor: Kingston Rev: 5.02 Prod: DT Elite HS 2.0
Type: Removable Hard Disk
Capacity: not available

USB device 0:
Device 0: Vendor: Kingston Rev: 5.02 Prod: DT Elite HS 2.0
Type: Removable Hard Disk
Capacity: not available
... is now current device
** Can't read from device 0 **

** Unable to use usb 0:1 for fatload **
## Executing script at 02000000
Wrong image format for "source" command
MB351Z =>

USB stick is FAT32 formatted, the following files are present:
- boot_red50.bin
- openwrt-red50-red50.fdt
- openwrt-red50-squashfs
- openwrt-red50-uImage

MB351Z => print
bootcmd=fw_setenv bootargs root=/dev/mtdblock7 console=ttyS0,115200; nand read 0 xc00000 0x0 0x100000; nand read 0x1000000 0x100000 0x1000000; bootm 0x1000000 - 0xc00000
bootcmd_nandflash_test=nand_test 0 0x500000
bootcmd_norflash_test=flash_test 0xefe06000 0xefe4ffff
bootcmd_rtctest=rtc_test 20
bootloader_flash_update=protect off 0xeff00000 0xeff7ffff; erase 0xeff00000 0xef f7ffff; cp.b 0x100000 0xeff00000 0x80000; protect on 0xeff00000 0xeff7ffff; cmp. b 0x100000 0xeff00000 0x80000
lannerboot=setenv bootargs root=/dev/ram rw ramdisk_size=$ramdisksize rootdelay= 10 console=ttyS0,115200;usb start;fatload usb 0 $loadaddr $fdtkernel;fatload usb 0 $ramdiskaddr $ramdiskfile;fatload usb 0 $fdtaddr $fdtfile;bootm $loadaddr $ra mdiskaddr $fdtaddr;
usbext2boot=setenv bootargs root=/dev/ram rw console=$consoledev,$baudrate; usb start;ext2load usb 0 $loadaddr $fdtkernel;ext2load usb 0 $fdtaddr $fdtfile;ext2l oad usb 0 $ramdiskaddr $ramdiskfile;bootm $loadaddr $ramdiskaddr $fdtaddr
usbfatboot=setenv bootargs root=/dev/ram rw ramdisk_size=$ramdisksize console=$c onsoledev,$baudrate; usb start;fatload usb 0 $loadaddr $fdtkernel;fatload usb 0 $fdtaddr $fdtfile;fatload usb 0 $ramdiskaddr $ramdiskfile;bootm $loadaddr $ramdi skaddr $fdtaddr

Environment size: 1703/65531 bytes
MB351Z =>

I also tried without success: Change to mtdblock10 image

setenv bootcmd "setenv bootargs "root=/dev/mtdblock10 console=ttyS0,115200"; nand read 0xc00000 0x5100000 0x100000; nand read 0x1000000 0x5200000 0x1000000; bootm 0x1000000 - 0xc00000"

The log file on the firewall (SG230)

Live log: RED
2024:01:31-21:00:14 fw001 red_server[6600]: SELF: RED10rev1 fw version set to 14
2024:01:31-21:00:14 fw001 red_server[6600]: SELF: RED10rev2 local fw version set to 5317R2
2024:01:31-21:00:14 fw001 red_server[6600]: SELF: RED10rev2 fw version set to 2005R2
2024:01:31-21:00:14 fw001 red_server[6600]: SELF: RED15(w) fw version set to 1-546-fea488294-b1551d2
2024:01:31-21:00:14 fw001 red_server[6600]: SELF: RED20 fw version set to 1-1261-6de2a4c19-b1551d2
2024:01:31-21:00:14 fw001 red_server[6600]: SELF: RED50 fw version set to 1-546-fea488294-0000000
2024:01:31-21:00:14 fw001 red_server[6600]: SELF: RED60 fw version set to 1-1261-6de2a4c19-b1551d2
2024:01:31-21:00:14 fw001 red_server[6600]: SELF: IO::Socket::SSL Version: 1.953
2024:01:31-21:00:14 fw001 red_server[6600]: SELF: Startup - waiting 15 seconds ...
2024:01:31-21:00:14 fw001 red2ctl[6610]: Starting REDv2 control daemon
2024:01:31-21:00:29 fw001 red_server[6806]: UPLOAD: Uploader process starting
2024:01:31-21:00:29 fw001 red_server[6600]: SELF: (Re-)loading device configurations
2024:01:31-21:00:29 fw001 red_server[6600]: A340214561BE086: New device
2024:01:31-21:00:30 fw001 red_server[6600]: A340214561BE086: Staging config for upload
2024:01:31-21:00:30 fw001 red_server[6600]: SELF: (Re-)loading device configurations
2024:01:31-21:00:30 fw001 red_server[6806]: [A340214561BE086] Config has changed, re-read confd firmware versions
2024:01:31-21:00:31 fw001 red_server[6806]: [A340214561BE086] Uploaded config to registry service

Display on RED:
Connecting UTM
using WAN

Setting up
Network failed

--> Loop

LED's on RED
Power: Green


Link: Green

Activity: flashing orange
Error: -

What can I do and who can help me?

Thank you very much!

This thread was automatically locked due to age.
Parents Reply Children
  • I will probably organize a new one.

    Many thanks for your support

  • If your RED is able to use the display and display meaningful text, it's obviously working.

    No need to replace the firmware (it can fetch ist from the provisioning server) and definitely no need to replace the boot loader.

    The procedure you described above is for a case we had 4 years ago with a faulty firmware update, which lead to flash corruption (bad sectors not taken into account) and unbootable REDs.

    The picture Vivec gave you is from the technical training guide.

    In this Guide you see meaningful states are:

    As you can see, the Network setup is way before establishing a tunnel and probably an error of your side.

    Check if

    • DHCP Works and you get a valid IP (unless you configured a static IP)
    • ...and get a valid Gateway IP, which is pingable
    • have DNS and NTP
    • you can reach "" ( in EU, in US)
    • ...and you can use Ports 3400, 3410 using this hosts.

    Maybe your ISP has choosen to block some ports or not to provide a public IPv4 in favor to IPv6.

    Only other reason I could image is that the used WAN port is suddenly broken, but you have 2 to choose from :-)