This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

Slow speed on APX530 where lan is giving good speed

I am facing internet speed slowness issue from APX 530. We have increased the bandwidth from 500 Mbps to 1Gbps but the problem is same, we are still not getting adequate speed, as mentioned about the APX530 can provide speed upto 1750 Mbps, but if there is no one in the office then also we are getting max 150 - 200 Mbps max speed. Where over LAN we are getting 800-850 Mbps speed and we are using Sophos XG2100 Firewall and CS110 switches.

Please help me to understand the issue.



This thread was automatically locked due to age.
Parents Reply Children
  • Thanks Erick,

    • Does the AP have an updated Firmware : Yes its updated
    • Is this newly configured? : Using since Nov 2022
    • Have you tried to test with different devices? Is the slowness only on browsing, file transfer,etc : Everywhere, specially during Video calls
    • Have you tested on different configurations : Yes, even i am in touch with Sophos support team, but they are unable to find the root cause.
    • Change the Cable connected : Yes
    • Any Signal interference might cause the speed degradation? : My office is completely open, there are no partitions, glass walls, cabins etc. Max distance of an AP from users are 15-20 Feet.
    • Can you share with us the configuration on your Access Point(band, frequency, etc). : Please find the image below

    I have 9 APX 530 devices installed in the office, wherever i am it doesn't matter, but these APs are creating trouble for me.

    Network Structure

    Sophos Firewall XG2100 -> Sophos CS110FP Switch -> Sophos APX 530

    I am getting the signals even out of my office, around 50 Meters, but with same speed. Max Speed not i am getting is :

  • Hi Tejveer,

    Thank you for the information. I've also edited the screenshot to remove the serial number.

    Did the issue occur since Nov 2022? If no, were any changes made before the issue occurred?

    Also, were you assisted by a Sales partner upon implementation?

    Would it be possible to share the support case ID?

    Erick Jan
    Community Support Engineer | Sophos Technical Support
    Sophos Support Videos Product Documentation  |  @SophosSupport  | Sign up for SMS Alerts
    If a post solves your question use the 'Verify Answer' link.

  • You need to rule out, that you can get the high speed internet tests directly on the LAN cable where the AP is connected. Best is to use it's IP on your test machine.

    Second, if going to a support case, you need to prove, the test machine with WiFi can handle a higher speed that you see on the APX530 WiFi. Test with a different WiFi Vendor or Home Router.

    Testing further with either 2.4 or 5 GHz disabled.

    What are the client connection settings of the SSID? bridge to VLAN? If yes, do you get high speed connection when connected by cable with that VLAN?

    Also give this test a try: after hours, disconnect 8 of the APX530 from power and test when only one is active. Eventually they are too near to each other and channels heavily overlapping.

  • Hi Erick,

    Current Case Number: 06852908

    we already logged the case regarding the same about 4-5 months ago : Case Number :06182567, but not got any satisfactory solution.

  • Hi LHerzog,

    Thanks for the options, but if i connected my home router, Nighthawk Tri-Band WiFi Router AC3200 (R8000), where i am getting upto 850 Mbps speed on the same network.

  • that is good. please go through the other questions and suggestions in my previous post.

  • Hi Tejveer,

    Thank you for sharing the case ID.Upon checking,

    For the old case of 06182567: The issue was occurring only when there were an increase of users and possibly a bandwidth issue.

    Both sides agreed to close the case

    For case 06852908:  The case will be forwarded to our Global Escalation Engineer team for further checking.

    Apologies for the experienced and will further monitor the case.

    Erick Jan
    Community Support Engineer | Sophos Technical Support
    Sophos Support Videos Product Documentation  |  @SophosSupport  | Sign up for SMS Alerts
    If a post solves your question use the 'Verify Answer' link.

  • Hi Tejveer,

    Upon checking the case 06852908. This was closed due to no response received from your side. 

    You may reach out to Sophos Hotline for re-opening the case or creating a new with and linking your old case#. 

    Erick Jan
    Community Support Engineer | Sophos Technical Support
    Sophos Support Videos Product Documentation  |  @SophosSupport  | Sign up for SMS Alerts
    If a post solves your question use the 'Verify Answer' link.