Important note about SSL VPN compatibility for 20.0 MR1 with EoL SFOS versions and UTM9 OS. Learn more in the release notes.

XG 125w rev.3 Home License Registation Problem

I am wondering if anyone can assist me with the registration of my device XG125W. When I try to register/claim the firewall using the serial number of the device, I receive one of two error's.

Error 1, Licensing,Ficewall licenses, Claim firewall, Enter Serial number and click on validate, Claim firewall Just claim the firewall with base license click on claim firewall. Error Failed to claim firewall please try again later.

Or Error 2, Devices Firewall, Add Firewall, enter device Serial number, Claim Firewall and continue. 400: A Bad request was made.

I have changed the hard drive as suggested on here and reflashed the device using HW-v19.5.3 MR3 firmware, I have tried to put the home license product key in with no success using any of the methods.

E.g CLI, Sophos Central or Web UI, during the inital setup, I either get an error after a few seconds, when using the Web UI saying I have no internet connection which then turns green again. As soon as I try it again I get the same issue. When using the CLI, I can see the WAN & LAN has activity but as soon as I use AA command and use the home key, it drops all connections. When trying to use the Sophos Central I get the error as described above.

If anyone could help me with this issue it would be very much appreciated.

Edited TAGs
[edited by: Erick Jan at 4:48 AM (GMT -8) on 21 Dec 2023]
  • Since you are talking about a home license (but on a hardware device) and have changed the harddrive.

    Which serial number are you using when trying to register? You should NOT use the hardware serial of the XG125 but instead use the serial that you got when registering for the home use license.

    Managing several Sophos firewalls both at work and at some home locations, dedicated to continuously improve IT-security and feeling well helping others with their IT-security challenges.

  • Yes that is exactly what I am trying to do but for whatever reason it is not accepting the home license. A friend has a SG 450 that is running on a home license which I was present when they set it up from a fresh firmware flash with no issues at all. Hence I know what the process is for getting it up and running using the home license that is provided for free by sophos. But it is not working for whatever the reason is. I even took the XG 125W over to their house the other night to see if using a different Internet connection would help but it hasn't made the slightest difference in trying to get it to register the home license. Both of us have tried to get this up and running for god knows how long now but with no luck unfortunately which has left me with basically an expensive door stop as I can't get this up and running and I can't call Sophos support as it is a home license and not a business. I would love to get this working so I can then start using it and secure my network better plus start learning more.

  • Hi rfcat_vk Yes I have tried both and even tried 2 different drives but it hasn't helped. I have looked all over the internet for answers to how to resolve this issue. I have even tried using a different internet connection not that I see why that would have made a difference when I had no issues at all setting up the SG450.

  • Does the bios on the XG only work with UEFI install which is not supported on the SFOS installer.


    XG115W - v20.0.1 MR-1 - Home

    XG on VM 8 - v20 GA

    If a post solves your question please use the 'Verify Answer' button.

  • Sorry I am a bit confused in what you mean?

    The way I have tried to do the home firewall firmware flash is the same way as I did it on my SG450. 

    The steps I did was done by downloading the firmware, then writing the image file to the USB using rufus and then tried to flashed it. 

    All of this is above as I have explained before but it is very confusing as to why it won't work with the original drive, and when I change the drive it doesn't allow me to register even though I have tried about 3 different serial/ registration numbers.

  • Just a dumb question, maybe try to follow all these steps in this video on YouTube. At the time of your first post, the video did not exist. He restored all defaults on the BIOS on the XG 135, maybe something to try if you haven't already?

  • Have you tried defaulting your BIOS settings?

  • Hello Rod,

    I think we have to clarify a bit here: Home licenses does only work with the software image "SFVH", not with a hardware image of SFOS.

    The hardware image is coupled to the system hardware serial number, so this would not accept any other license than the correct one for the hardware model you got. Home licenses instead are given out without knowing your "fw model", because this is the way it is meant.

    The SSD/HDD drive has a file, where the syste, stores its model, type and serial number, if this is a Sophos piece of hardware. So this may have worked on the old "SG" type of firewall, because this file wasn't in place. On a "new" XGS system, you either have to wipe the drive completely or use a new drive. That's the whole secret.

    Mit freundlichem Gruß, best regards from Germany,

    Philipp Rusch

    New Vision GmbH, Germany
    Sophos Silver-Partner

    If a post solves your question please use the 'Verify Answer' button.

  • Hi Philipp 

    Thank you for that information. I have tried using both the HW & SW FW files but neither worked I have also tried it using the original drive and 2 different drives. 

    I managed to get the FW to flash but it will not accept any of the home registration/ serial numbers which is where this problem is at and hence unfortunately having a non use able firewall.

  • Yes I have also tried that too. Nothing I seem to do allows me to get past the registration part of the setup.

  • I still think you are using the wrong image. Could you post the filename of that image, please?

    Mit freundlichem Gruß, best regards from Germany,

    Philipp Rusch

    New Vision GmbH, Germany
    Sophos Silver-Partner

    If a post solves your question please use the 'Verify Answer' button.

  • When installing the software version, you will get a firewall model "SFVH", this one will accept a home license for sure. I did this myself and it works.

    Mit freundlichem Gruß, best regards from Germany,

    Philipp Rusch

    New Vision GmbH, Germany
    Sophos Silver-Partner

    If a post solves your question please use the 'Verify Answer' button.

Reply Children
No Data