Sophos Email customers using IP-based mailflow rule connectors must migrate to certificate-based configuration by March 31st. To see if you're affected Click Here.

This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

"Outbound Emails sent from Sophos" Connector Failed to Setup

I am attempting to setup Sophos Mailflow for a O365 tenant with Microsoft Basic Business licenses. The "Outbound Emails sent from Sophos" inbound connector fails to enable and when I try to enable it manually I get the error: 

Error executing request. For this service offering, you can't enable an inbound connector. Please contact Support to enable it. Organization '0f4eda73-53b3-4e46-ad7f-aec9d9ff6dad', Service Offering: 'O365_BUSINESS_ESSENTIALS'.

Apparently Microsoft made an unannounced change, that took affect 01/01/2023, restricting admins from activating newly-created inbound connectors for new tenants. This change affects the following SKUs:

Microsoft 365 Business Standard
Microsoft 365 Business Basic
Exchange Online Essentials

These connectors are created as “Disabled” by default. Customers that experience this behavior must contact Microsoft support with a business justification to enable an Inbound connector of OnPremises type within their tenant.

I have opened a ticket with Microsoft to enable the connector. I will update this post with my experience and steps.

This thread was automatically locked due to age.
  • Update to original post:

    Only the O365 licenses mentioned in my original post are restricted from enabling inbound connectors from your org. to O365 that are configured to use an IP address. However, if you use a certificate domain name instead of an IP address, you can enable the inbound connector without an elevated license. In my case, I have pressed the tech and he is going to get with his senior engineers to see if they will enable the connector still since I have explained its legitimacy.

    It seems to me that Sophos should adjust this connector to use a certificate domain name automatically now that Microsoft has implemented this change so that the setup continues to be as smooth and easy as it was prior to the change.

  • Hello there,

    Thank you for contacting the Sophos Community.

    Can you please share the Case ID you have logged so we can follow up?

    I would like to check if this is a Feature Request/if this is in the Road Map/ or if there’s a misconfiguration. 


    Emmanuel (EmmoSophos)
    Technical Team Lead, Global Community Support
    Sophos Support VideosProduct Documentation  |  @SophosSupport  | Sign up for SMS Alerts
    If a post solves your question use the 'Verify Answer' link.
Reply Children