Enterprise components mismatch

Hi All,

 

Have a Windows Server 2008 R2 64-Bit that has Sophos Enterprise Console installed on it. They were on 5.5.1 but when I tried to install the 5.5.2 upgrade it came up with a mismatch (Management Console = 5.5.1, Management Database 5.5.2, Management Server 5.5.1) So looking over some of the other documentation it showed saying if I uninstalled the 5.5.2 component and then ran the installation again it may resolve the issue.

 

I wanted to see if it was at all possible to downgrade the Database back to 5.5.1 so that it is all on the same version. I have tried running the 5.5.1 installation but getting an error on that saying custom action failed. I am guessing this is due to the database files already existing.

 

I did try running the 5.5.2 install but keep on getting a Missing access right to Sophos Credential Store error (even though running it as the Sophos Management Account and the Database Access and Update Manager Account.

 

I think we may have gotten into this situation when an upgrade was run but then failed (but not before it upgraded the dataset).

 

If anyone could advise me how to roll back the Database to Version 5.5.1, or to get everything up to the 5.5.2 version then that would be greatly appreciated.

 

JR

  • Hi  

    Please check this article and perform the steps mentioned, this would help you to resolve the issue with the components of different versions installed. 

    Shweta

    Community Support Engineer | Sophos Technical Support
    Support Videos | Product Documentation@SophosSupport | Sign up for SMS Alerts
    If a post solves your question use the 'Verify Answer' link.

     

  • Hi Shweta,

     

    I tried following the instructions there. I have uninstalled the Database version 5.5.2. I then tried to run the 5.5.2 Installer to update the 5.5.1 components but it keeps on saying "Missing access rights to the Sophos Credential Store" even though I have checked and the user is part of the SophosPowerUser group, the user has been set to Logon as a Service and tried running the Setup as an administrator.

     

    Any suggestions?

     

    Regards,

  • Hello JR,

    the relevant section in the Prerequisite checks article mentions two things to check: User Rights for NT Service\Sophos.Credential.Store.Service - if the service is running then this is not the cause - or group membership for the installing user. Please note that the 5.5.2 installer creates the new Sophos Console Power Users group (this is not SophosPowerUser that is related to the Endpoint software or any other of the Sophos Console/DB/Full groups) and populates it with the account that runs the installer. If this group already exists when you re-run the installer you must have logged off and on again. If you did not reboot the server or log off this account after the "partial" 5.5.2 install you'll run into this error (I've been there :) ...).

    Christian