Uninstall failed from server endpoint (10.8)

Hello Sophos Community,

Windows 2008R2 - Sophos Endpoint 10.8

Unable to uninstall, cannot locate package 'Sophos Anti-Virus.msi' in specific source path. It is correct, it is not there.
Looking at Registry it says localpackage should be: C:\Windows\Installer\d0b4ddb5.msi
This package does not exist anymore.
Almost all folders in Programdata\Sophos are emptied of files, only folders remain.
We can start sophos and disable tamper protection, but without the MSI i am unable to uninstall.

How to uninstall sophos so we can run the installer from Sophos Central which now gives a error because it detects a old sophos.

Thank you for any help you can give.
I can create a support call with sophos but like to try this route first.


  • If i had the old installer msi from 10.8 could i run a install with the repair option to fix this issue?

  • Hello Arris,

    for whatever reason the cached MSI has disappeared. You need an MSI with the correct product code and version - 10.8 is not detailed enough.

    Are you trying to uninstall or has the server failed to update (if the latter then likely for this very reason - that it could not uninstall the existing one).


  • Hi QC,

    Thanks for helping me.

    I am trying to uninstall manually, as the Sophos Central installer fails to update the current sophos SEC installation.

    We used SEC and moved to Windows defender for 2 years and are now starting to use Sophos Central, so its not a migration from SEC to Central.

    It says its version in programs and Features page.

  • Tried to locate Sophos in HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall to run 'msiexec /x' on the GUID but it is not in the list.

  • Hello Arris,

    moved to Windows defender - and did not uninstall SAV? As ProgramData is (almost) empty you didn't keep the CIDs, did you? Any chance there's a matching MSI on another machine?


  • Yes true, i admit this server was sneaked under our radar, it was a Physical converted to Virtual, during this we forgot about the installed sophos client.
    All my virtual machines used SSVM/vShield back then and the remaining physical had sophos removed, i do not have quick access to the matching MSI anymore.
    I do have a backup of the SEC server and could restore that, just need to find the localpath where SEC stores its installers.
    But the possibility is high it will have much newer MSI's in its store or will it also keep a copy of older versions?

    Is there perhaps a place where we can download old sophos endpoint msi's?

  • Hello Arris,

    depends on what you've backed up. First choice is the very file under \Windows\Installer. If this location wasn't backed up then the Sophos Anti-Virus.msi in the CID under the SuphosUpdate share (%ProgramData%Update Manager\Update Manager\CIDs\S00x\SAVSCFXP\savxp\) , or the one in AutoUpdate's cache.

    Support might have the .msi, can't say if the can provide it and how fast.

    P.S.: wanted to send you a PM but you have disabled them

  • We backup the full VM so everything should be available, i will try it now and let you know.
    There is no rush so if the msi is impossible to find i will approach support.

    My apologies, this account is new and has the default settings, its set to everyone now.

  • I found the s00x folders.

    Running the S000\SAVSCFXP\savxp\Sophos Anti-Virus.msi seems to work, it requested a reboot. 
    It installed full version next to
    The newly installed version has Sophos icons in the Program&Features page where the old version has blank icons.

    Had not expected 10.8.4 would install while it can see 10.8.2 is present, seems like the Sophos Central is a lot more picky about what it allows where the old SEC install would just steamroll over any pre-existing installation.

  • Hello Arris,

    running the SAV MSI stand-alone might always have been possible. Under normal conditions either setup.exe or AutoUpdate performs the checks for previous (or higher) versions and initiates the uninstall.