Advisory: Sophos Endpoint "Your connection isn't private" after reboot. Policy settings can be returned to normal. See: KB-000045954 for the latest updates.

This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

Sophos Community new user sign up broken

I needed to use Sophos Community for the first time last month to request a documentation update.  I had to create a customer care case to get my Sophos user ID to work with Sophos Community because the sign up process is broken.  I asked Customer Care to fix the site but once my user ID worked they needed to close the case.

Steps to recreate the issue:

Prerequisites:

  1. A public Sophos ID that has never been used to sign in to Sophos Community

Method A

  1. Login to id.sophos.com
  2. Click Sophos Community link

Method B

  1. Open support.sophos.com in a browser
  2. Search for and click on an article
  3. At the bottom of the page click the "Product Documentation Feedback" link
The Sophos Community page that appears broken because of a problem displays.  Under the menus and messages the page says "Welcome Please help us customize your experience. Complete the fields below."  Below this text is a Join Now button.  No fields appear.  Nothing appears to happen when clicking the Join Now button.

I have tested on Windows 10, Windows Server 2016, OSX, iPad and iPhone using Chrome, Safari and Microsoft Edge, using two different ISPs and creating a new test Sophos ID. 

The workaround is to open a case at support.sophos.com and reference case 07005482.  Sophos IT will add your ID to Sophos Community in a week or two.



This thread was automatically locked due to age.
Parents Reply Children
No Data