This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

Delete app from my laptop

I made the download of the Sophos Endpoint App and this *** block all my laptop and websites, i don´t have a login, and to delete the app ask for a password of protection wich i don´t have. I was going to work from home, where i work they start to use this program, but after this problem i got so angry, i just want to delete the app from my laptop. I can´t disable nothing because this *** app. I never saw a webpage that don´t have a phone or e-mail.

This thread was automatically locked due to age.
  • What OS and product are you referring to?

  • Sophos Endpoint Agent i made the download to use with VPN to use with SAP, but after the download this Sopho anti virus block a lot of webpages and other things in my laptop, but to uninstall aks to disable the password of protection. Do to this i need to login, but i don´t have a login. So i can´t uninstall this app. Just pathetic And how this block all your laptop and you can´t disable nothing. I will have to format the laptop to delete this ***. I'm furius.

  • The products for Windows endpoints are:

    - Sophos Central managed here  - This is a cloud based management platform where policies are defined, i.e. what categories of sites can be viewed for example.  This has the potential to block certain web sites and where you can enable/disable tamper protection.  Someone would have had to have configured this and provided you a SophosSetup.exe to install.  It's hard to believe this is the scenario you are in as if you'd had set up a Sophos Central account you would know about it.  So someone could have provided you an installer instructions to install and now they control the policies.  To get the tamper protection password you'd need access to Sophos Central. Did someone give you a link to a SophosSetup.exe installer you ran?

    - Sophos Home -  This is another cloud based management platform aimed and home users or for a family to use.  Again someone with access to  and can login can define who can access what sites, for example.  

    - Sophos on-premise, this is even less likely but possible but again, someone would have had to have setup this all up on your behalf and they control the policies. This is not a cloud based management solution. I really doubt this is the product.

    If you have either Sophos Central or Sophos Home, then you can remove from Programs and Features but if tamper protection is enabled but you have no means to obtain the password, you will need to follow this article:

    Sophos Endpoint Defense: How to recover a tamper protected system

    There is also tool called SophosZap - SophosZap: Frequently Asked Questions - This will remove the software but Tamper Protection will need to be disabled.

    The software is designed not to be easy to bypass and it seems like someone must have asked you to install it if you don't have access to the management software.

    The software is not the problem, the issue is I suspect someone has asked you to install it but not provided you with any guidance.

  • No one ask me to download the app, i take the app from de computer of work with a pen drive to work from home  on weekend with my laptop. But i have no idea that to uninstall it was a big problem. I talk today with TI of work and they don´t know the password. The only way is to format my laptop. Thanks for all information.

  • Do you have the link of Sophos Zap Tool? But i can´t log in the account to disable tamper protection, because i don´t know the password.

  • You definitely do not need to format the laptop.  This can be fixed in 5-10 minutes.

    I can only assume maybe your company outsource their IT to a MSP or someone that manages Sophos Central. Your computer will be sitting in the management console and from there someone can gain you the password.  Without all of that, it is possible to disable and uninstall Sophos.  You do however have to follow the steps in the KBA to the letter.

    You don't need to login to get SophosZap.  

    Service and Support (

    links to 

    You need to enter a name just for export compliance reasons but you will get SophosZap.exe.

    That said getting this tool isn't the main work, that comes later.  The first thing to do is disable Tamper Protection and for that you need to boot the computer into the recovery command prompt as per the other article:

    Service and Support (

    Once that is done, SophosZap may make things a bit easier but to be honest, if the install isn't broken, you will be able to remove the software from Programs and Features. You probably don't need SophosZap but it's good to have.

    If you have Bitlocker enabled you will need the recovery key to gain access to the drive in the recovery command prompt.  This is potentially another hurdle.

  • Hi USER 930 this is harder than i thought. Disable the tamper protection - OK, than in uninstall appears fail to uninstall because of Sophos Autoupdate Service, i made i few reserchs and download the Total Uninstaller and got to disable the Sophos Autoupdate Service. And now fail to uninstall Sophos Anti Virus. Always like this...thinking....thinking....thinking and after 5...10 minutos fail. Now i download the Sophos Zap but nothing happens i press enter and nothing happens. I´m almost burning this laptop. I´m furius.

  • You have to run SophosZap from an admin command prompt and you have to run it with 
    This is to prevent people accidentally double clicking on it and it starts to remove the software (assuming tamper is off)

  • When i run the SophosZap open the Prompt Comand and says about uninstall and press enter, but when i press enter close the window and nothing happens. After this i tried to uninstall but keep the same menssage failed to uninstall sophos anti virus. I re start the laptop but keep the same. I don´t know what to do.

  • You launch an admin cmd prompt.  Change directory to where SophosZap.exe is.  For example:
    CD C:\users\user\downloads
    Then you run SophosZap.exe with the --confirm command line option, i.e.
    SophosZap.exe --confirm

  • Finally Sophos uninstalled aleluia Thanks for your help.

Reply Children
No Data