Turn SMTP Proxy on, all mail flow stops

Running 9.400-9 On Saturday I noticed that I hadn't received any emails for a long time. After much investigation, turned off the SMTP proxy. Everyone started receiving emails, and they should be sent to external addresses as well.

Looks like I'm not the only one having this issue:


Nothing in the logs. Rebooting the system doesn't help.

Thought I'd post it here, as 9.4 is still considered beta?

Anyway, it's obviously a pretty important issue!

Known bug or something specific to my (and others') configurations?

  • Just an update from the other thread. This is a known issue and will be fixed, but in the mean time:

    Ssh in, login as root, then issue:

    'pkill -9 smtpd* && /var/mdw/scripts/smtp restart'

    Re-enable SMTP Proxy from the web interface.

    That will get things workings again.

  • Hi James,

    Let me clarify:

    A) If SMTP Proxy is currently turned off and you want to leave it that way, but for some reason receive these notifications, just issue 'pkill -9 smtpd*'.
    B) If SMTP Proxy is currently turned off but want to enable it, or is enabled, run the above mentioned 'pkill -9 smtpd* && /var/mdw/scripts/smtp restart'. This will take care of everything and you DON'T need to re-enable SMTP Proxy via WebAdmin - actually doing so after running the command will just break it again, as the problem is with the init script: it does not take care of the new Sandbox watcher process, causing the whole proxy to get stuck.

    NOTE: Changing the config via WebAdmin should not cause any problems as it only forces a config reload.

    Kind regards,