This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

Trying to set up Site Path Routing - end up getting 404 errors

Hello everyone here.  Please help with advice and ideas
I have a tough task of crossbreeding 2 websites based on 2 different technology stacks.
I have website 1 a.k.a which is running on WordPress on LAMP server and this is the public website.
I have website 2 a.k.a and this is a custom developed ecommerce system running on IIS, the whole application is written in VB.NET.
My intention is to make website 2 to open within the context path of website 1 so it looks to the visitors like website 2 is running inside the website 1; something like
With this plan I set up Site Path Routing in the following manner:
Site Path Routing
My problem is that when I access website 1 everything is good, but once I add manually the path I get 404 error suggesting that website 1 does not have such path.  For the sake of experiment I tried creating a folder ‘commerce’ inside website 1 and disabling the SPR rule but then the error naturally changes to 403 Forbidden suggesting that I am not allowed to browse the folders.

My question – what am I doing wrong about site path routing setup?  Is what I am trying to do achievable?

This thread was automatically locked due to age.
Parents Reply
  • Dirk,

    I made an additional path route which looks like this

    Virtual Web Server:

    Path: /commerce

    Real Web Server: Real Webserver for Virtual Server 2

    However I still get the same 404 errors, so my source server (Webserver 1) is still trying to locate an non-existent folder in its file system, which I believe, means site path routing instruction has no effect on Webserver 1.  What do you think?


  • with Path: /commerce --> Real WebServer 2    the Webserver 1 should not show you access.

    Please give us some screenshots from virtual ws, real ws and sitepath settings.


    Sophos Solution Partner since 2003
    If a post solves your question click the 'Verify Answer' link.