Hi Everyone,

Today we've released UTM 9.505. The release will be rolled out in phases. In phase 1 you can download the update package from our FTP server, in phase 2 we will spread it via our Up2Date servers.


Up2Date Information


  • Security Release


  • System will be rebooted
  • Connected APs will perform firmware upgrade
  • Connected REDs will perform firmware upgrade


  • NUTM-8984 [RED] WPA2 KRACK vulnerability fixes for RED15w

  • NUTM-8789 [Wireless] WPA2 KRACK vulnerability fixes

  • My 105w's 2.4 Ghz WLAN didn't work anymore after the UTM Up2Date 9.5.05 on 10.11.2017 , please fix!

  • oh well I'll stay clear!  Last thing I want to do is mess around after doing an update with irate users.  Time this was fixed PROPERLY!

  • Ok, did a Up2Date for my UTMS. Worked fine, the Up2date process started to do every update till 9.505-4. Then restarted the UTM and the backup System also updated to 9.505-4.

    After that, no SSO, no users, no nothing, as I expected. Rejoining the Domain resulted in no success. Looked into the Logs and found:

    "Failed to join domain: failed to find DC for domain WORKGROUP"

    googled it and it worked again by adding "local" to my Domain Name in the AD Single-Sign-On Domain join window. Prior to updating there was only the name of the domain. Now it works with domain.local.

    Nevertheless, I experienced a loss of domain user authentications when restarting the UTM even with 9.501-5. I have to do a AD-rejoin every time I restart the UTM :-( . Looks like 9.505-4 is no better in this case.

  • likewise we're on 9.501-5 I tried going to 9.502-4 and it broke sso badly so I've stuck with what were running, which is ok'ish but every now and again I get a random sso issue and have to rejoin the domain.  Thankfully its a running as a virtual and I always snapshot before an update!

    So does 9.505-4 have any sso issues!?  Sophos really have had enough time to fix this bug!

  • didn't found infos on this topic, so can I directly jump from 9.501-5 to 9.505-4 in up2date, or do I have to go step by step (9.502, then 9.503, ...) till 505-4?

    I'll do it with a snapshot anyway