AP100c >>> "SSH could not reach the selected AP"

I just bought the AP100c for my Sophos UTM sg105w to expand and upgrade my wifi and give it a (hopefully) 1,3Ghz boost.
But the idea had a problem in the beginning when I realized that the AP100c is only using the 40 MHz and not the 80 MHz band.
I followed the instruction to connect to the UTM via SSH, open a command line (putty) and enter the awetool menu on the shell.
I entered the menu choosing "1 - Connect to an AP" followed by choosing my listed AP (which is the "AP100c"). So far so good.
When trying to connect the awetool realized that SSH wasn't active on the AP100c and asked me wheter to activate SSH on it.
So - for sure - I said "yes". The menu then asked me for a little patience. But - even after a reboot of my UTM - I can't connect.
I always get the "Connecting ..." - which takes approx 1-2 minutes until I get the following error messges from the awetool:

"SSH could not reach the selected AP. Please try again later."

Anyone got the same problem? Just asking because the "Enable SSH?"-question came in the beginning. So SSH must be on (?).
So why the heck isn't the awetool able to connect via SSH to the attached (withe the stock PoE power supply) AP100c right away?
Maybe some had the same problem. Would appreciate any help to access the AP100c and be able to activate the 80 MHz band.

Parents
  • Why do you want to connect to the AP in the first place? 

    Activate the 80 MHz Band should be able to perform without logging into the AP. 

    See: 

    Peter told me in a PM that he's a home user and therefore doesn't have access to Sophos Support.  Here are the steps to try what I suggest above:

    1. Find the REF_ of an Access Point definition named Klepsch:

    cc get_object_by_name awe device 'Klepsch' |grep \'ref

        That should return something like 'ref' => 'REF_AweDev1',

    2. Change the MHz of the second radio to 80:

    cc change_object REF_AweDev1 'channel_width11a' 'VHT80'

         If that command worked, it will return REF_AweDev1, if it failed, it will return 0 (zero).

    If testing shows that that didn't work, you can see how to change it back to HT40.  Please tell us your results.

    Cheers - Bob

    __________________________________________________________________________________________________________________

  • Hi LuCarToni. I can access my sp105w through SSH using Winscp and accessing the console using putty.exe.
    But hanging in step 1. What do you mean with "Find the REF_of an Access Point definition named Klepsch"?
    I tried the command 'cc get_object_by_name awe device 'Klepsch' |grep \'ref'. But nothing happended on my end.
    So i just tried "cc get_object_by_name awe device 'Klepsch'" (without the "") and got "0" as return for it. *wierd*
    Do I have to extract a name ("Klepsch"? is that an example for a result?)? So if how and where do i find this?
    I can access the 'awetool'. Unfortunately this doesn't work for me because smtp is not beeing enabled on my end.
    Or do I have to open a tunnel like when using 'open ssh' or other command and then send this command line?

  • Hello 491810,

    Thank you for the follow-up

    Try the following:

    utm1:/tmp # cc

    127.0.0.1 MAIN > OBJS

    127.0.0.1 OBJS > awe

    127.0.0.1 OBJS awe > device

    127.0.0.1 OBJS awe device > REF_AweDevA400095d2b[A400095D2BDXXXX,awe,device] (Tab for autocomplete)

    127.0.0.1 OBJS awe device [REF_AweDevA400095d2b] > channel_width
    channel_width11a=HT20 channel_width11a=VHT20 channel_width11a=VHT80 channel_width=HT40
    channel_width11a=HT40 channel_width11a=VHT40 channel_width=HT20

    In the step above auto complete by using the TAB to select the channel you want once it is complete, press Enter, you will see something like this, with the new Channel Width 

    'channel' => 0,
    'channel11a' => 0,
    'channel_width' => 'HT20',
    'channel_width11a' => 'HT20',
    'comment' => '',
    'country' => 'ca',
    'dfs_ability' => 0,
    'enabled' => 1,
    'id' => 'A400095D2BDXXXX',
    'interface' => 'REF_IntEthAp10',

    Type the letter w to save.

    Regards,


     
    Emmanuel (EmmoSophos)
    Community Support Engineer | Sophos Technical Support
    Sophos Support VideosProduct Documentation  |  @SophosSupport  | Sign up for SMS Alerts
    If a post solves your question use the 'Verify Answer' link.
  • Okay. Got it (finally). Now I got the following return. Can you pls check the code? Is it now corect?

    Do I need to reboot? Access Point in the gui still shows me the following 5GHz bands listed:

    "35,40,44,48,52,56,60,64,100,104,108,112,116,132,134,140"

    127.0.0.1 OBJS awe device [REF_AweDevA400299b79] > w
    {
              'autoname' => 0,
              'class' => 'awe',
              'data' => {
                          'ac_ability' => 1,
                          'active_channels' => [
                                                 11,
                                                 52
                                               ],
                          'allowed_channels' => [
                                                  1,
                                                  2,
                                                  3,
                                                  4,
                                                  5,
                                                  6,
                                                  7,
                                                  8,
                                                  9,
                                                  10,
                                                  11,
                                                  12,
                                                  13,
                                                  36,
                                                  40,
                                                  44,
                                                  48,
                                                  52,
                                                  56,
                                                  60,
                                                  64,
                                                  100,
                                                  104,
                                                  108,
                                                  112,
                                                  116,
                                                  132,
                                                  136,
                                                  140,
                                                  144,
                                                  149,
                                                  153,
                                                  157,
                                                  161,
                                                  165
                                                ],
                          'allowed_countries' => [],
                          'ap_localdebuglevel' => 8,
                          'ap_vlantag' => 1,
                          'auto_channel' => 1,
                          'auto_channel11a' => 1,
                          'band' => 'g',
                          'bridge_modes' => [
                                              'lan',
                                              'none',
                                              'vlan'
                                            ],
                          'channel' => 0,
                          'channel11a' => 0,
                          'channel_width' => 'HT20',
                          'channel_width11a' => 'VHT80',
                          'comment' => '',
                          'country' => 'de',
                          'dfs_ability' => 1,
                          'enabled' => 1,
                          'id' => 'A400299B79CB1C7',
                          'interface' => 'REF_IntEthLan',
                          'key' => 'OEVn/lG4lXcNE1jo/MwKbdof9AxL7O0wv/bsal61ewc=',
                          'lan_mac' => '00:1a:8c:87:48:66',
                          'last_ip' => '172.16.0.254',
                          'location' => 'AP100c',
                          'max_ssids' => 8,
                          'mesh_ability' => 0,
                          'mesh_ability11a' => 0,
                          'mesh_ability11g' => 1,
                          'name' => 'A400299B79CB1C7',
                          'networks' => [
                                          'REF_ItfAwe24Ghz5ghz'
                                        ],
                          'r0kh_secret' => 'iPueX9NKLWuJDGSZGyS0WBtI4wHiMf',
                          'scan_interval' => 0,
                          'scan_interval11a' => 0,
                          'sched_scan_interval' => 0,
                          'sched_scan_interval11a' => 0,
                          'status' => 1,
                          'stp' => 0,
                          'time_scheduling' => 0,
                          'time_scheduling11a' => 0,
                          'time_select' => [],
                          'time_select11a' => [],
                          'tunnel_id' => 800,
                          'tx_power_control' => 1,
                          'txpower' => 100,
                          'txpower11a' => 100,
                          'type' => 'AP100C',
                          'vlantagging' => 0,
                          'wifi_mac' => '00:1a:8c:87:48:67'
                        },
              'hidden' => 0,
              'lock' => '',
              'nodel' => '',
              'ref' => 'REF_AweDevA400299b79',
              'type' => 'device'
            }
    Changes to object saved successfully.
    {
              'ac_ability' => 1,
              'active_channels' => [
                                     11,
                                     52
                                   ],
              'allowed_channels' => [
                                      1,
                                      2,
                                      3,
                                      4,
                                      5,
                                      6,
                                      7,
                                      8,
                                      9,
                                      10,
                                      11,
                                      12,
                                      13,
                                      36,
                                      40,
                                      44,
                                      48,
                                      52,
                                      56,
                                      60,
                                      64,
                                      100,
                                      104,
                                      108,
                                      112,
                                      116,
                                      132,
                                      136,
                                      140,
                                      144,
                                      149,
                                      153,
                                      157,
                                      161,
                                      165
                                    ],
              'allowed_countries' => [],
              'ap_localdebuglevel' => 8,
              'ap_vlantag' => 1,
              'auto_channel' => 1,
              'auto_channel11a' => 1,
              'band' => 'g',
              'bridge_modes' => [
                                  'lan',
                                  'none',
                                  'vlan'
                                ],
              'channel' => 0,
              'channel11a' => 0,
              'channel_width' => 'HT20',
              'channel_width11a' => 'VHT80',
              'comment' => '',
              'country' => 'de',
              'dfs_ability' => 1,
              'enabled' => 1,
              'id' => 'A400299B79CB1C7',
              'interface' => 'REF_IntEthLan',
              'key' => 'OEVn/lG4lXcNE1jo/MwKbdof9AxL7O0wv/bsal61ewc=',
              'lan_mac' => '00:1a:8c:87:48:66',
              'last_ip' => '172.16.0.254',
              'location' => 'AP100c',
              'max_ssids' => 8,
              'mesh_ability' => 0,
              'mesh_ability11a' => 0,
              'mesh_ability11g' => 1,
              'name' => 'A400299B79CB1C7',
              'networks' => [
                              'REF_ItfAwe24Ghz5ghz'
                            ],
              'r0kh_secret' => 'iPueX9NKLWuJDGSZGyS0WBtI4wHiMf',
              'scan_interval' => 0,
              'scan_interval11a' => 0,
              'sched_scan_interval' => 0,
              'sched_scan_interval11a' => 0,
              'status' => 1,
              'stp' => 0,
              'time_scheduling' => 0,
              'time_scheduling11a' => 0,
              'time_select' => [],
              'time_select11a' => [],
              'tunnel_id' => 800,
              'tx_power_control' => 1,
              'txpower' => 100,
              'txpower11a' => 100,
              'type' => 'AP100C',
              'vlantagging' => 0,
              'wifi_mac' => '00:1a:8c:87:48:67'
            }
                                                                                                                                                                                                 127.0.0.1 OBJS awe device [REF_AweDevA400299b79] >
    
    sg105w:/root #
    

  • Hello 491810,

    127.0.0.1 OBJS awe device > REF_AweDevA400095d2b[A400095D2BDABCDE,awe,device]

    Once you are there, press enter, which will populate what you showed above, I think you need to enter the full REF and S/N AXXXXXXXXXXX. which is the reason why if you use the tab key to autocomplete will make it easier

    So once you press Enter you should see at the bottom 

    127.0.0.1 OBJS awe device [REF_AweDevA400095d2b] >

    I am using tab to autocomplete which is why it shows more lines and I am changing to only HT40

    127.0.0.1 OBJS awe device [REF_AweDevA400095d2b] > channel
    channel11a= channel= channel_width11a=HT20 channel_width11a=HT40 channel_width11a=VHT20 channel_width11a=VHT40 channel_width11a=VHT80 channel_width=HT20 channel_width=HT40
    127.0.0.1 OBJS awe device [REF_AweDevA400095d2b] > channel
    channel11a= channel= channel_width11a=HT20 channel_width11a=HT40 channel_width11a=VHT20 channel_width11a=VHT40 channel_width11a=VHT80 channel_width=HT20 channel_width=HT40
    127.0.0.1 OBJS awe device [REF_AweDevA400095d2b] > channel_width11a=
    HT20 REF_DefaultTimeEventWeekend[Weekend,time,recurring] REF_TimRecTimedefini[SSLVPN,time,recurring]
    HT40 REF_DefaultTimeEventWork[Work hours,time,recurring] VHT20
    REF_DefaultTimeEventAutoinstall[Time to install updates,time,recurring] REF_ItfAweJoshwifi[House,itfhw,awe_network] VHT40
    REF_DefaultTimeEventLunch[Lunch,time,recurring] REF_ItfAweTesthome[wlan1 (Remote Wireless Network),itfhw,awe_network] VHT80
    127.0.0.1 OBJS awe device [REF_AweDevA400095d2b] > channel_width11a=HT40
    REF_DefaultTimeEventAutoinstall[Time to install updates,time,recurring] REF_DefaultTimeEventWork[Work hours,time,recurring] REF_TimRecTimedefini[SSLVPN,time,recurring]
    REF_DefaultTimeEventLunch[Lunch,time,recurring] REF_ItfAweJoshwifi[House,itfhw,awe_network]
    REF_DefaultTimeEventWeekend[Weekend,time,recurring] REF_ItfAweTesthome[wlan1 (Remote Wireless Network),itfhw,awe_network]
    127.0.0.1 OBJS awe device [REF_AweDevA400095d2b] > channel_width11a=HT40

    After here if you press Enter you will see something like this

    {
    'ac_ability' => 0,
    'active_channels' => [
    1
    ],
    'allowed_channels' => [
    1,
    2,
    3,
    4,
    5,
    6,
    7,
    8,
    9,
    10,
    11
    ],
    'allowed_countries' => [],
    'ap_localdebuglevel' => 0,
    'ap_vlantag' => 1,
    'auto_channel' => 1,
    'auto_channel11a' => 0,
    'band' => 'g',
    'bridge_modes' => [
    'lan',
    'none',
    'vlan'
    ],
    'channel' => 0,
    'channel11a' => 0,
    'channel_width' => 'HT20',
    'channel_width11a' => 'HT40',

    And at the very bottom you will see another prompt, type enter, and then you will see the output again, in the middle of the output you should see "Changes to object saved successfully"

    127.0.0.1 OBJS awe device [REF_AweDevA400095d2b] > w

    Changes to object saved successfully.
    {
    'ac_ability' => 0,
    'active_channels' => [
    1
    ],
    'allowed_channels' => [
    1,
    2,
    3,
    4,
    5,
    6,
    7,
    8,
    9,
    10,
    11
    ],
    'allowed_countries' => [],
    'ap_localdebuglevel' => 0,
    'ap_vlantag' => 1,
    'auto_channel' => 1,
    'auto_channel11a' => 0,
    'band' => 'g',
    'bridge_modes' => [
    'lan',
    'none',
    'vlan'
    ],
    'channel' => 0,
    'channel11a' => 0,
    'channel_width' => 'HT20',
    'channel_width11a' => 'HT40',

    Regards,


     
    Emmanuel (EmmoSophos)
    Community Support Engineer | Sophos Technical Support
    Sophos Support VideosProduct Documentation  |  @SophosSupport  | Sign up for SMS Alerts
    If a post solves your question use the 'Verify Answer' link.
  • Hello 491810,

    Yes it does look correct!

    Regards,


     
    Emmanuel (EmmoSophos)
    Community Support Engineer | Sophos Technical Support
    Sophos Support VideosProduct Documentation  |  @SophosSupport  | Sign up for SMS Alerts
    If a post solves your question use the 'Verify Answer' link.

  • I saved the 80MHz (VHT80) option. But the Sophos GUI still shows me only the 20Mhz 5GHz bands:

    "35,40,44,48,52,56,60,64,100,104,108,112,116,132,134,140"

    Doublle-checked the listing and saw that the 80Mhz channels are not part of the current listing.
    Also the 40Mhz channels are not part of the list. How can I also add the 40Mhz next to the 80Mhz?

    • 20MHz: 36, 40, 44, 48, 52, 56, 60, 64, 100, 104, 108, 112, 116, 120, 124, 128, 132, 136, 140
    • 40MHz:  38, 46, 54, 62, 102, 110, 118, 126, 134
    • 80MHz: 42, 58, 106, 122
    • 160MHz: 50, 114

    I can do whatever I like. I am able to add the "VHT80" instead of the "VHT40" by using the following code:

    channel_width11a=VHT80

    But isn't it possobiel to add the "VHT40" AND the "VHT80" so that both are available and can be used?
    How can I do this? The followng code doesn't work. In the end it is not saved - so not available:

    channel_width11a=['VHT40','VHT80']

    How do I have to setup the order so that both channels (40 AND 80MHz) are added successfully to the AP100c?
    And why do you use channel_width11a='HT40' and not "VHT40"? I cannot set and save "HT40" or "HT80" on mine.

    What wonders me more than the VHT40-VHT80-problem is the question how to add the missing channels?
    I activaed the 80Mhz but the channels are not listet. How do I add the 80Mhz channels "42, 58, 106, 122"? 
    Or do I have to add the missing channels not to "allowed_channels" but to "channels11a". But doesn't work either.

    Tried to go back to "VHT40" - which worked". Wifi restarted. But Admin GUI still only shows the 20MHz channels:

    "35,40,44,48,52,56,60,64,100,104,108,112,116,132,134,140"

    So - to summ it up - The admin GUI only offers me the 20Mhz - no 40Mhz or 80MHz channels offered at all!
    Any idea why neither 20MHz nor 80MHz is shown in the admin GUI - even when enabled and saved properly?
    Does this makes sense in any way? Why is AP100c not able to access the 20MHz or the 80MHz if configured?

  • Does anyone has an idea why I can add "VHT80" or even reset it to "VHT40" but not seeing the channels in the GUI?
    I can only see the 20MHz channels. I guess because the 40Mhz and 80Mhz channels are not in "allowed_channels".
    I am also not able to add the missing channels. Wenn saving with "w" exiting and reentering they are not there any more.
    I thought the missing 40MHz or 80Mhz channels would be added automaticly. But that isn' happening. Any ideas here?

  • You should ask this question in the UTM section to increase visibility. 

    __________________________________________________________________________________________________________________

  • Will do that additionally. Was just pushing the thread after "Emmanuel (EmmoSophos)" already replied to my posting several times I hoped for another hint to my problem. But thanks

  • Hello 491810,

    Sorry I didn't see the follow-up reply.

    Not sure why you are not able to see it, but you should be able to see it. I don't have an AP at the moment that supports 5GHz, if in the backend it is showing that you are using the 80Mhz then in the GUI should show the channels for this and not only the 36, 44, 44, 48.

    Try setting to VHT80 as my example was just for how to enter the commands, but here is a guide that probably you know already.

    • Narrow channel = 20Mhz / HT20
    • Wide Channel = 40Mhz / HT40
    • 802.11ac Wide Channel = 80Mhz / VHT80

    You can only have either 40Mhz or 80Mhz not both at the same time.

    If you are unable to see the channels in the GUI, I would recommend you to open a ticket with support, to get this investigated. 


     
    Emmanuel (EmmoSophos)
    Community Support Engineer | Sophos Technical Support
    Sophos Support VideosProduct Documentation  |  @SophosSupport  | Sign up for SMS Alerts
    If a post solves your question use the 'Verify Answer' link.
  • Ive got the same problem with an AP55C. That sounds like a general problem with sophos. Any solution?

    community.sophos.com/.../20mhz-und-oder-80mhz-band-in-wireless-protection-auf-ap100c-aktivieren

Reply Children
No Data