This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

sip module only works for a short time

Hello all,

I use a Fritzbox behind the XG with PhonerLite or LinPhone as SIP client. My provider is 1&1.

Unfortunately, I have noticed that the SIP module crashes after a short time and that I only hear the ringing on new calls, but not the person I am talking to.

I have now searched through the logs and found that the telephony works until I find the following in the log:

localhost kernel: [266259.312048] ip_nat_sip_expected: doing self nating: <212.227.124.5>
localhost kernel: [266261.783797] ip_nat_sip_expected: doing self nating: <212.227.124.5>

Does anyone have any idea what the problem is here?

Regards
Marc



This thread was automatically locked due to age.
Parents Reply Children
  • Thank you for trying. What does logviewer show for the attempts?
    ian

  • I got this error at 13:52:06 and 13:52:08 in /var/tslog/syslog.log

    Sep 17 13:52:06 localhost kernel: [629954.088001] ip_nat_sip_expected: doing self nating: <212.227.124.70>
    Sep 17 13:52:08 localhost kernel: [629956.539844] ip_nat_sip_expected: doing self nating: <212.227.124.70>

    But I can't find anything in the log viewer at this time:

  • Hi,

    how many Nat rules do you have in place and are any of them linked?
    ian

  • Hier sind alle meine NAT rules:

    The 4th is connected to the Default Firewall Rule from above

  • Hi,

    this might not be the answer, but linked Nat rules take precedence regardless of where they sit in the Nat order. Also why do you have linked rules, they are really only needed if you have multiple wan links?

    ian

  • There is no specific reason for this. It came with the basic installation of XG.

    I have unlinked everything, but unfortunately the problem persists. :-(

  • Maybe I am missing something, but your error message is from your voip device not the XG, correct? So maybe you need to disable Nat on your voip device?

    the error message would imply that you have the voip device wan interface connected to the XG, not the lan interface.
    ian

  • No, the log is from the XG itself:

    SFVH_SO01_SFOS 18.5.1 MR-1-Build326# tail -f /var/tslog/syslog.log
    Sep 19 10:00:01 localhost kernel: [788829.597191] 750:appdev_open:dev open 3
    Sep 19 10:00:01 localhost kernel: [788829.597214] 703:appdev_write:ptr U 8,ACCEPT
    Sep 19 10:00:01 localhost kernel: [788829.597215] 75:appfiltermap_adt_parser: buff U 8,ACCEPT
    Sep 19 10:00:01 localhost kernel: [788829.597219] 711:appdev_write:count 10
    Sep 19 10:00:01 localhost kernel: [788829.597222] 758:appdev_release:dev open 3
    Sep 19 10:00:01 localhost kernel: [788829.597223] 771:appdev_release:counter 8 size 128
    Sep 19 10:00:01 localhost kernel: [788829.597224] 774:appdev_release:dev open 0
    Sep 19 10:58:27 localhost nsgsig-verify: /sdisk/u2d/downloads/avira_4.00_1.0.417524_immdiff.tar.gz.gpg: not an NSGSIG file
    Sep 19 11:16:23 localhost kernel: [793411.148074] ip_nat_sip_expected: doing self nating: <212.227.124.6>
    Sep 19 11:16:25 localhost kernel: [793413.607723] ip_nat_sip_expected: doing self nating: <212.227.124.6>
    

  • It seems that I found a solution now.

    I have set in the Fritzbox "Keep port forwarding of the Internet router active for telephony" from 5 minutes to 30 seconds.

    Many thanks to all for the support.