intercept x for mobile affected phone encryption password (cyanogenmod 13 [android 6])

intercept x on my daughter's phone kept pestering her about web filtering needing some sort of access, so i decided to turn web filtering off.  to do so, i had to enable sophos as a device admin or something (sorry, i don't recall the details).  during this process either sophos or i ended up turning the lock screen pin off, so i set that back up again.

at the next reboot, she was unable to decrypt the phone because the boot screen was asking for a pin instead of a password.  her phone was encrypted with a 16-character alphanumeric password, which she obviously couldn't enter from the pin screen.  she tried her lock screen pin but that also didn't work.

now we're stuck with a phone that won't boot and only 7 more chances to try before it wipes the memory.  we've tried pretty much everything we can think of.

when i boot into twrp (recovery), it's unable to decrypt (or back up) the data partition because of this same unknown password.

we really don't want to lose her data.  does intercept x use any sort of default password?  is there anything else we can try?