Advisory: Support Portal Maintenance. Login is currently unavailable, more info available here.

Constant "SBIE2101 Object name not found" Errors

Evening.

I used to use this program on Windows 7 last year without fail. Worked fine when I had to update to Windows 10. Now months ago I formatted my drive and system and installed a clean Windows 10 and installed Sandboxie 5.33.1 fresh. I can not get it to work the way I used to use it. I used to always just run it in Windows Explorer and execute programs from there. I even tried these from Sandboxie Control to no avail now.

I always get similar errors when I try to execute files. Whether trying to install a program or a single file (runs with just one exe file) program or game that I have had for decades, nothing ever runs and I get errors all with the same beginnings (using an old game I had for a long time as an example below):

SBIE2101 Object name not found: \Sessions\1\BaseNamedObjects\ISWWH_BEACON@150c@EFR-controller, error CreateEvent (C0000022) access=001F0003 initialized=1
SBIE2101 Object name not found: , error OpenProcess (C0000022) access=001FFFFF initialized=1
SBIE2314 Canceling process ELFBOWL.EXE [5388 / 7]
SBIE2101 Object name not found: \Sessions\1\BaseNamedObjects\ISWWH_BEACON@22c8@EFR-controller, error CreateEvent (C0000022) access=001F0003 initialized=1
SBIE2314 Canceling process ELFBOWL.EXE [8904 / 7]

Whatever I try to do, I get and SBIE2101 Object name not found: \Sessions\1\BaseNamedObjects\ISWWH_BEACON nothing runs. I have looked in these boards but found nothing really similar to what I have going on, unless I missed a post mentioning a working solution I not tried (on this fresh installation of the program).

I have seen people post their config file so here is mine. Thanks for any thoughts on the matter.

[GlobalSettings]

Template=7zipShellEx
Template=AutoSizer
Template=WindowsRasMan
Template=SynapticsTouchPad
Template=WindowsLive
Template=OfficeLicensing

[UserSettings_083601A6]

SbieCtrl_UserName=main
SbieCtrl_NextUpdateCheck=1587682598
SbieCtrl_UpdateCheckNotify=n
SbieCtrl_ShowWelcome=n
SbieCtrl_WindowCoords=343,150,880,450
SbieCtrl_ActiveView=40021
SbieCtrl_ProcessViewColumnWidths=250,70,300
SbieCtrl_BoxExpandedView=DefaultBox

[DefaultBox]

ConfigLevel=7
AutoRecover=y
BlockNetworkFiles=y
Template=qWave
Template=WindowsFontCache
Template=BlockPorts
Template=LingerPrograms
Template=Chrome_Phishing_DirectAccess
Template=Firefox_Phishing_DirectAccess
Template=AutoRecoverIgnore
RecoverFolder=%{374DE290-123F-4565-9164-39C4925E467B}%
RecoverFolder=%Personal%
RecoverFolder=%Favorites%
RecoverFolder=%Desktop%
BorderColor=#00FFFF,ttl
Enabled=y

  • The programs update check says it is updated by I see from these message boards there is also 5.33.3 and 5.33.6 but neither helped. Same errors.

  • I had a similar problem and I solved it. I hope this may helps:

    Check if there is a subfolder named "32" under your Sandboxie directory, when your work on a x64 system. And a Win32 version of Sandboxie service program should be put into that folder. My error SBIE2101 occurs when I did not create that folder.

  • I do.

     

    \Sandboxie\32

    04/18/2020  09:00 PM    <DIR>          .
    04/18/2020  09:00 PM    <DIR>          ..
    03/18/2020  06:09 PM           590,168 SbieDll.dll
    03/18/2020  06:09 PM           252,760 SbieSvc.exe 

  • I'm having this same problem.

    No matter what I try to install in the Sandbox I get the SBIE2101 Object name not found Error.

    I am running a new install of Windows 10 Pro x64 up to date with all the latest updates and just updated to SB 5.33.6.  Same errors.

    I don't follow the comment about having a \32 subfolder under the \Sandboxie folder.  I don't think I have ever had this.  This is needed if you are running SB x64?

    I don't think I ever had that folder and I've always been able to install things in my SB folders in the past.  It just suddenly stopped working.  Seems to me the only thing that changed was Windows 10 updates.  Thinking maybe that broke SB?

    Don't know what to do at this point.  Everything already installed in the sandboxes works.  But can't install anything else.

  • Hi,

    I used Sandboxie in Win7 64bit without any problem (except when installing software that created virtual printer drivers). Then 2 years ago I moved to Win10, and problems began to arise, but after Win10 September 2019 update nothing works anymore! Impossible for me to install EVERYTHING. Last year on a VMware Win10 image I installed qbittorrent: after Win10 update I could still run it sandboxed; I tried to install the same qbittorrent executable on another VMware image (based on the same empty Win10 source) but after the Win10 update and Sandboxie always fails with SBIE2101 error.

    It is very frustrating because I cannot install any software in the sandbox.

    But, yesterday I did a more refined search and I succeeded in installing a software using this trick (it requires relaxing Sandboxie's protection, so I am not going to use it to test potentially dangerous software, but only trusted software I want to be able to uninstall simply by deleting the sandbox).

    I started Sandboxie (my version is 5.31.6 64bit), opened File|Resource Access Monitor and I launched sandboxed my setup.exe using the context menu. Sandboxie failed with SBIE2101 error as usual. I copied and pasted the Resource Access Monitor log into a Notepad blank window and I looked for the last IPC entry, that with a "X" instead of an "O". My item was

    "\Sessions\3\BaseNamedObjects\ISWWH_BEACON@8808@EFR-controller"

    So I opened my Sandbox Settings and in Resource Access|IPC Access|Direct Access I added the following:

    *\BaseNamedObjects\ISWWH_BEACON*

    Then I tried to run the setup.exe again. The SBIE2101 error rose again but with a different message. I ran Resource Access Monitor again and so forth and I found that the previous ISWWH_BEACON... entry was ok and the problem were in another part. I added another ICP entry in Direct Access list and I succeeded in completing the setup.exe installation!

    I don't know what an ICP is, how dangerous could it be to allow direct access to some of those entries, but at last I understood how to install something.

    I hope this could be useful to you, even if I strongly desire that Sophos would address this issue more seriously as months passed since its first reports.

    Regards,

    Filippo

  • Filippo that is absolutely BRILLIANT!

    I wasn't even aware that SB had a Resource Access Monitor command until you mentioned it here.

    I have not tried this, but don't see any reason why it shouldn't work.

    However, I agree with both of your caveats.

    1. We don't know if this is safe for other programs running in that sandbox.  But this is easy to deal with, just don't apply those settings to any sandbox you are not using for trusted programs.

    2. This needs to be addressed.  I think Sophos said they are finished with further development several versions ago, yet still made some changes.  Don't know if they are interested in fixing this anymore or even addressing it here to shed some more light on it since they seem ready to pull the plug on this forum.

    So it may have to be addressed by whoever is involved with the opensource development.

    Nonetheless, it would be much appreciated if Sophos could at least comment on it here so we have a better understanding of what's going on and whether or not is is safe to make those changes (If they know).

    Thanks again Filippo... awesome idea! 

  • Filippo...

    Just wanted to comment on this:

    "I used Sandboxie in Win7 64bit without any problem (except when installing software that created virtual printer drivers)."

    =============

    I don't think it's possible to run any software that uses a driver in a sandbox is it?

  • Ryan Cruze said:

    I don't think it's possible to run any software that uses a driver in a sandbox is it?

     

    I'm not sure but I think that I can run sandboxed quite every software that uses drivers (we need drivers to access devices, like video cards, mouse, audio, printers,...). So for istance I can run a game in a sandbox and take advantage of my nVidia drivers without problems. If I remember well, with Sandboxie, I cannot INSTALL new drivers (keeping them confined in the sandbox), so for example I cannot install a new print driver (neither a real one nor a virtual PDF one) or the drivers to emulate a cd-rom device in order to mount ISO images.

    P.S.: please, let me know if you find out how to deal with SBIE2101 error hearing from other people outside this forum.

    Regards,

    Filippo

  • I tried that but then got stuck. So with my error:

    SBIE2101 Object name not found: \Sessions\1\BaseNamedObjects\ISWWH_BEACON@55c@EFR-controller, error CreateEvent (C0000022) access=001F0003 initialized=1
    SBIE2314 Canceling process QuickSFV.EXE [1372 / 7]

    I added in:

    *\BaseNamedObjects\ISWWH_BEACON*

    Then my next error was:

    SBIE2101 Object name not found: , error AlpcConnectPort (C0000022) access=001F0001 initialized=1
    SBIE2314 Canceling process QuickSFV.EXE [4772 / 7]

    I even added in *.* but that did nothing.