ASG 425 Display with homelicense


I'm using the ASG 425 Rev3 (Core2Duo E6400) Hardware Appliance in a private Network.

I got the Home-License running achieved through deleting the ASG File in /etc Folder.

Since i did that, the display isnt working anymore.

Is there any solution for that problem?

Kindly regards

  • Officially, an LCD is unsupported when using a home license. There were several threads on that gave suggesed workarounds, with avrying levels of complexity and success. Unfortunately, most of the data on those forums is currently inaccessible, but is expected to be restored, then ported over to here, soon. So, for the time being, you won't be able to use the LCD.
  • Hello Scott Klassen,
    thanks for your fast respond and the Note to the old forum.
    I tried to use google cache Versions of some threads in the old forum, but the important sites weren't accessible.

    In hope that the old forums content is restored soon...

    Kindly regards..
  • The file /etc/asg is used by the following procedures:

    - "initasg" (the difference between the ssi* and asg* ) to assign the correct names to the interfaces. After deleting /etc/asg initasg wont work correct anymore.

    - "utm-lcd" controls the lcd display.

    - Hardware License is needed, if /etc/asg exists.

    From my old post. It worked with ASG220 and UTM7-8 (pre utm-lcd):

    1. Install ASG Hardware with ssi****.iso

    2. rm /etc/lcd.conf (Link to /etc/asg for lcd4linux)

    3. mv /etc/asg /etc/lcd.conf (because i like the lcd-information)

    4. Change in /etc/init.d/initasg the line 34

    ASG_HW_FILE="/etc/asg" to


    5. Install HomeLicense via WebAdmin

    Now in UTM9 you should do this:

    1. Install ASG Hardware with ssi****.iso

    2. mv /etc/asg /etc/lcd.asg

    3. Change in /etc/init.d/initasg the line 34

    ASG_HW_FILE="/etc/asg" to ASG_HW_FILE="/etc/lcd.asg"

    4. Change /etc/init.d/utm-lcd the line 1

    ASG_FILE="/etc/asg" to ASG_FILE="/etc/lcd.asg"

    5. Install HomeLicense via WebAdmin

    Please test and post the result!

  • In reply to CS:

    These steps work on a UTM 320 r.5. Thank you.

  • In reply to CS:

    just tried on my 425, line number on the first file is off, otherwise, works like a champ!


  • Hi, just tested it out, and it works, but it does not cycle the display, through the interface/ram/cpu values, it just stands on one page with the utm version and uptime.

    I found out that /etc/ is not being generated on software installs, so you have to create /etc/asg again and remove the id and serial number, then everything works like on a hardware appliance :-)

    Read here on bottom where it says : Updated: 15/11-2016:

  • Hi Does anyone have copies of the ASG file for both UTM220 and UTM540(old astro v7 unit) as I have appliances I want to get running 



  • In reply to twister5800:

    As a followup for anyone.

    I picked up a UTM 220 for nothing. I applied the home licence and as you would expect, the lcd stopped working. Having fully updated the firmware and patterns I had a look at the lcd.


    I came across this post



    And followed the newer set of instructions.


    Do a “vi /etc/asg”

    It creates a new file and then insert:

    Ex. for SG 210


    Ex. for UTM 220


    As you see UTM and SG’s have different LCD controller.

    Now reboot and watch the display cycle through the widgets, you can also see if /etc/ is being populated.

    This worked for me.

  • In reply to Mark T:

    Man, thanks a are my hero and made my day!

    Your solution works perfect and I think a easier way would not be possible...


    I installed a SG210 for private usage with the software "home version" of the UTM. For this kind of installation source the display usually doesnt work; but I wanted to know it finally today so I tried to use google again for a new search and solution for this problem... long story short answer:

    1. Install a new and naked UTM Home software ISO image

    2. Configure it out to get shell access

    3. Do it the same way you said

    4. After reboot the display works perfect like any HW ISO installation.


    THANKS A LOT!!!! :)

    <3 <3 <3