Version 9.6.3353 not compatible with Android 8.1.0



Last night, I got a notification saying Intercept X for Mobile is not up to date with the latest version (that is 9.6.3353). So I opened Google Play > My apps and games > Updates tab and Sophos is not showing on the list of apps to be updated (both Intercept X and Security & Antivirus Guard).


I decided to go to Intercept X > App security > App security issues then tapped the message saying 'New version Sophos Intercept X for Mobile 9.6.3353 available' and it redirected me to the app's page in Google Play. To my surprise, there's a banner there saying 'This app isn't compatible with your device anymore.'


I'm not sure why this is happening. I was still able to update my other apps to the latest version last night, so it does not look like Google has dropped support for Android Oreo (yet). An Android version usually reaches end of life just before or after it hits 3 years old, and 8.1.0 isn't quite there yet (still a few months out).


Although the virus definitions are still coming through as I got an update less than 8 hours ago (3.79.0:2020070702), it's rather annoying to see Intercept X say my device is 'unsafe.' Anyone have any idea what's going on?

  • Hi  

    I will check this with my team and shall update you further. Kindly check this retirement calendar for your reference. Would you please suggest what is the device you are using that is currently facing this issue? 

  • In reply to Shweta:



    I checked the retirement calendar you quoted, but I'm not sure what I should find there. My mobile and my tablet, which are both on Android Oreo, have version 9.6.3339 of Intercept X. So those are on the 9.6 branch, which is does not have a maintenance stop nor a support stop date specified.


    As for the devices, these are as follows:

    OEM Model Android Patch Level
    MyPhone myA11 8.1.0 August 2019
    Cherry Mobile Aura 3s 8.1.0 September 2018


    In case you point out the patch level of my devices, unfortunately that's the way it is for local brands here in the Philippines. You would consider yourself lucky if your device got one OS update from the manufacturer for the entire useful life of the Android version that shipped with it. But it has always been that way and my devices were getting app updates for Intercept X until this problem happened.


    I know the devices are getting old, but I'm not scheduled to replace these until Android Oreo's expected end of life, which should be around the last quarter of this year.


    Please let me know once you have something. Thanks in advance.

  • In reply to macOng7:

    I have the same error message. I am running 9.6.3339 on a Lenovo 7 inch tablet with Android 8.1.0 on patch level of June 2020. It says it has an upgrade to 9.6.3353 available, but Play Store mentions it is not compatible with that device.

  • In reply to mite3cybersec:

    Looks like I'm not the only one having this problem. I guess it's important to highlight here that @mite3cybersec has an up-to-date Android Oreo yet he is also experiencing it.


    And I'm still getting virus definition updates. As of 1751H yesterday Philippine Standard Time, my devices have definition version 3.79.0:2020071003, so I'm still not sure where the disconnect is with the app upgrade.


    , are there any updates from your team? Please advise.

  • In reply to macOng7:

    True, I have the same issue.

    • When you look at Google Play --> --> It says Android 5.0 and up. So that cannot be the issue.
    • When you look at their retirement calendar --> --> It says 9.5 support ends December 2020 and 9.6 ends June 2021. So that cannot be the issue.
    • I am running at June 2020 patch level of Android 8.1.0, and you August 2019 and September 2018. I dare to say that ain't the issue. Also because security patch level does not impact compatibility related requirements.
    • We both receive signature updates, so the app in itself works fine (just as the other features). And the warning in Sophos is just because we have an older version than the Play Store version installed.

    My best bet that it is a one (or more) of the following issues.

    • Secundaire specs went up (think about RAM requirements).
    • Hardware features are required with update that appear not to be present in our devices.
    • Some screensize / form-factor requirements changed.
    • Geo-location issues (which I doubt, as it works on my other devices).

    And please note, the above can also just be accidental (as in someone messed up the listing in Play Console and/or in the APK).

  • In reply to mite3cybersec:

    Hi there, 

    I have checked this with my global escalation team and it would require an in-depth investigation, hence I would request you to open a support case and PM me the case number. 

  • In reply to Shweta:

    Hi ,


    I initially posted the case number here as a reply but took it down and sent it to you via private message after reading your message for a second time.

  • In reply to macOng7:

    I also sent my ticket number through a PM.

  • In reply to mite3cybersec:

    Thanks, but I think I'll pass on installing from third-party sources.


    I wonder how the investigation is doing though. Their support people actually replied to my ticket saying only paid users can file a case number, so my best guess is my ticket is either dead in the water or automatically closed.

  • In reply to macOng7:

    I can confirm that my ticket is still open. Probably due to us being an authorized partner.

    I'll share any relevant details here.

  • In reply to macOng7:


    Your issue has been escalated to our development team with the above reference number. Issues are prioritised based on severity and customer impact. We will discuss your case with development and provide preliminary analysis and next steps by latest end of next week.

  • In reply to mite3cybersec:

    Sounds like it's getting somewhere now. Thanks for the update! Greatly appreciated.

  • In reply to mite3cybersec:

    @mite3cybersec, do we have any news by any chance? , perhaps you could help with putting in some pressure with your development team regarding this matter?

  • In reply to macOng7:

    No real progress. I got a message back that the problem has likely to due with a X86 processor architecture. I replied that I have ARM 32-bit.

    And I also received evasive behavior of Sophos Support, stating that I should contact Google (because Play Store is wrong...). I replied to that that I cannot go to Google, as I do not have support there. In addition, any fix needs to applied by Sophos anyway.

    So, no progress and back to square one I guess.

    Let's wait and see....