This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

[Resolved] Migration server to server 5.5.0 build failed


I tried to migrate my Sophos Enterprise Console, but when I want backup the new server I have issues.

I use this documentation, page 15:

Logs: (sorry it's in French)

c:\Program Files (x86)\Sophos\Enterprise Console>DataBackupRestore.exe -Action=backup
Microsoft (R) Build Engine, version 4.7.3190.0
[Microsoft .NET Framework, Version 4.0.30319.42000]
Copyright (C) Microsoft Corporation. Tous droits réservés.

La génération a démarré 28/04/2021 17:23:47.

c:\Program Files (x86)\Sophos\Enterprise Console>sqlcmd -E -S "(local)\SOPHOS" -b -Q "BACKUP DATABASE SOPHOSPATCH52 TO DISK = 'C:\ProgramData\Sophos\TempData\SOPHOSPATCH52.bak'"
Processed 358040 pages for database 'SOPHOSPATCH52', file 'SOPHOSPATCH52' on file 1.
Processed 5 pages for database 'SOPHOSPATCH52', file 'SOPHOSPATCH52_log' on file 1.
BACKUP DATABASE successfully processed 358045 pages in 53.007 seconds (52.770 MB/sec).
Copy file C:\ProgramData\Sophos\TempData\SOPHOSPATCH52.bak successful.
Backup successfully for registry key: HKEY_LOCAL_MACHINE\SOFTWARE\Sophos\Patch
Backup successfully for registry key: HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Sophos\EE\Patch

c:\Program Files (x86)\Sophos\Enterprise Console>sqlcmd -E -S "(local)\SOPHOS" -b -Q "BACKUP DATABASE SOPHOS550 TO DISK = 'C:\ProgramData\Sophos\TempData\SOPHOS550.bak'"
Processed 12664 pages for database 'SOPHOS550', file 'SOPHOS550' on file 1.
Processed 4 pages for database 'SOPHOS550', file 'SOPHOS550_log' on file 1.
BACKUP DATABASE successfully processed 12668 pages in 2.943 seconds (33.626 MB/sec).
Copy file C:\ProgramData\Sophos\TempData\SOPHOS550.bak successful.
Backup successfully for registry key: HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Sophos\Certification Manager
Backup successfully for registry key: HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Sophos\EE\Management Tools
Backup successfully for registry key: HKEY_LOCAL_MACHINE\SOFTWARE\Sophos\ManagementServer
Backup successfully for registry key: HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Sophos\EE\Sophos Enterprise Console
La récupération de la fabrique de classes COM pour le composant avec le CLSID {2C5339F1-B8D3-4D40-9245-E68E0F8C6380} a échoué en raison de l'erreur suivante : 80080005 Échec de l'exécution du serveur (Exception de HRESULT : 0x80080005 (CO_E_SERVER_EXEC_FAILURE)).

ÉCHEC de la build.

Temps écoulé 00:03:03.71
Process 'C:\Windows\Microsoft.NET\Framework64\v4.0.30319\msbuild.exe "c:\Program Files (x86)\Sophos\Enterprise Console"\BackupRestore.proj /t:backup /clp:NoSummary /p:SubSystem=all;DataSourceType=all;ExcludeDB=False;LocationSpecific=False;SlientMode=False;DBServerInstance=' returned Error 1

I already looking on forum, but nothing works.

Can you help me please ?

Thank you

This thread was automatically locked due to age.
  • Hello ,

    please see Retrieving the COM class factory ..., - or have you already found this article or the two or three threads about the same error?


  • Hello QC,

    I tried this article

    But I don't understand this:

    sqlcmd -E -S .\SOPHOS -Q "IF  EXISTS (SELECT * FROM sys.server_principals WHERE name = N'DOMAIN\Sophos DB Admins') DROP LOGIN [DOMAIN\Sophos DB Admins]"
    Note: Change DOMAIN to match the location of the group Sophos DB Admins.

    My Local Groups Sophos DB Admins is configured in the local server, not in my domain. So it doesn't work.

    In resume: I have 1 user on my domain is "SophosManagement", and 1 group Sophos DB Admins in local server.

    The user "SophosManagement" is in the group "Sophos DB Admins".

  • Hello C Bo,

    for local (non-domain) accounts (users or groups) user the server name in place of DOMAIN.


  • Thank you QC it works !

    Just one more thing, I finished the documentation, but my client continue to looking for update in my old server. But I already change my policy to update to the new server. I already do everything the documentation said. Do you have an idea ?

    I restart the server, and now all computers are shown disconnected.

  • Hello C Bo,

    did you change the updating policy on the old server? Apart from updating the endpoints must be told to communicate with the new server.
    The Migration Guide tells you to reprotect the endpoints.Another option is described here. If you reused the certificates you could configure the CID (I'll dis regard this for the moment). Last but not least if you no longer need the old server you can simply add the old server's name as alias for the new in DNS - would work.


  • Hello QC,

    Thank you for your help. I change the policy update on the old server, and create the script.

    Its seems work. I wait 1 or 2 day, and I close the case if it's good.