This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

Error: Updating failed because WindowsCloudClean is missing.

All of our machines managed through Sophos Central are having the same error: Updating failed because WindowsCloudClean is missing. Found some discussions here in Sophos Community from 3 years ago that they have this same issue ( Contacted the support and asked to check our license activation on Sophos-side and was found that our license was inactive. Done a remote session for troubleshooting - so far, zero help.

This thread was automatically locked due to age.
  • Hello Kheir,

    Thank you for reaching out to the Sophos Community. 

    I tried looking into the account and it looks like there are valid licenses present. I have triggered a synchronization with your Sophos Central Admin portal at this time. Please update the support case or follow up on this thread and let us know if the issues are now resolved. 

    I will reach out to you via DM to request Remote Assistance to be turned on so that we may check further details on the account. 

    Kushal Lakhan
    Global Community Support Engineer
    Connect with Sophos Support, get alerted, and be informed.
    If a post solves your question, please use the "Verify Answer" button.
    The New Home of Sophos Support Videos!  Visit Sophos Techvids
  • Hi Kushal,

    I've checked our endpoints - so far, it still has issues updating

  • Even when trying to install endpoint protection, this "WindowsCloudClean" is still appearing -

    Sophos Installer (SophosCloudInstaller_20211015_071138.log):
    2021-10-15T07:12:20.5457699Z INFO : SUL info: [V18227] SU::Metadata::findWarehouse Failed to find WindowsCloudClean in any warehouse
    2021-10-15T07:12:20.5547633Z ERROR : DownloadCommand::onRun() failed with std::exception: Product handle for distribution files not available
    2021-10-15T07:12:20.5547633Z INFO : Command 'Download' completed with failure with reboot code '0' and error message 'Could not download software'.
    2021-10-15T07:12:20.5557626Z ERROR : Installation failed.

  • Update: I've created another ticket. Gone through with another support - they were able to tweak something on the licenses, but the issue still persist. Not sure if they tweaked it correctly...

  • UPDATE: Seems to be working okay now. The support just needed to trigger another synchronization after doing some tweaks on the license.