Unable to connect to the network after this mornings update

I've tried putting a static IP on the network adaptors, connecting to a different internet source and nothing. Sophos shows it updates this morning, I turned off tamper protection from sophos cloud from another computer, but since this computer can't talk to the internet it can't see it's been disabled and I am unable to uninstall Sophos. I need to get Sophos off this machine or something to allow it to get back online. I have opened a ticket, waiting to hear back. Any ideas? 

  • HI,

    Thank you for reaching us. In line with the above query that you've shared, may we know if this happens only to a certain device or happens to most of your machines? May we know the status of your NIC adapter? Was it showing the APIPA IP address? If so? have you tried resetting your NIC adapter by running a command line "netsh Winsock reset." Were there any recent changes on your network which cause the update not to push through? Please share the chase ID with us to have a quick check on it.

    GlennSen 
    Community Support Engineer | Sophos Technical Support
    Sophos Support Videos | Product Documentation | @SophosSupport | Sign up for SMS Alerts
    If a post solves your question use the 'Verify Answer' link.
  • I have a Windows 7 system with the same issue, lost network connection after the update on 7/20 11:11am. The system could not identify the network through either of 2 different network interfaces (mainboard integrated & USB adapter). I connected the cable to a different system and confirmed the network was fully accessible.

    The system was rebooted multiple times after updating the main board network adapter drivers as well as the mainboard USB drivers and the USB network adapter drivers. The system was not able to contact the DHCP server to acquire an IP. I also attempted setting a static IP address but the network remained "unidentified" to Windows and the system could not ping or contact any domain servers or other hosts on the network even with static IP and internal DNS set properly.

    I have a second Windows 7 system that is critical to our operations that I have kept from restarting because the same "update" appears to be queued up and ready to cripple our operations upon reboot.

    The update seems to have had no negative effects on Windows 10 PCs.

    "netsh Winsock reset" did not resolve the issue.

    I uninstalled Sophos Endpoint Protection on the Windows 7 PC that has the issue and the system is functioning perfectly without it. I reinstalled Sophos and the issue returned - no network connectivity. The system is presently without Sophos "protection" because that is the only way it will function.

    Please release a patch for the "update" released ~7/20/21 or tell me how to work around the issue.

  • Hello Ross,

    Thank you for sharing, By any chance do you have 3rs party security software installed on your win7 machines? Please check if the system s free from 3rd party security software as this may also cause an issue. 

    GlennSen 
    Community Support Engineer | Sophos Technical Support
    Sophos Support Videos | Product Documentation | @SophosSupport | Sign up for SMS Alerts
    If a post solves your question use the 'Verify Answer' link.
  • No, there is no 3rd party security software installed.

  • What is the status of this issue? Has an update been released since 7/20/21 that does not disable network access on Windows 7? 

  • Sorry to just update this. I was finally able to get the Tamper protection code and Uninstall Sophos from my computer and then after a reboot it connected just fine. Something with the update last week caused the issue. Uninstalling is the only fix for now.

  • Hi Ross, 

    To further check this, I would request you to raise a support case to further Idolate and investigate the issue you’re currently facing.. One case has been created. You may DM me directly the case ID.

    GlennSen 
    Community Support Engineer | Sophos Technical Support
    Sophos Support Videos | Product Documentation | @SophosSupport | Sign up for SMS Alerts
    If a post solves your question use the 'Verify Answer' link.
  • Hi There,

    It came up to us that there was an ongoing issue being faced for Windows 7 machines. Some examples of behavior seen so far are:
    Unable to obtain an IP Address
    Unable to connect via a VPN

    And was being observed on the below version.

    Sophos Core Agent 2.19.5
    Sophos Endpoint Advanced 10.8.11

    The initial workaround should be to turn off "Protect Network Traffic" within the threat protection policy. If this does not solve the issue. You can unload ntp using the following commands:

    net stop sntpservice
    netcfg -v -u sophos_sophosntplwf.

    If the Issue still persist. We would like to encourage you to log a support case and provide the below details on the case.


    1. Collect a diagnostic log of the machine
    2. Request the following information from the customer:
    * Are they using a VPN if so provide the vendor and version
    * Does the machine have an IP Address?
    * Are they experiencing issues connecting to the VPN, websites or both?
    * Confirm if the below workarounds were successful and which workaround the customer is using

    GlennSen 
    Community Support Engineer | Sophos Technical Support
    Sophos Support Videos | Product Documentation | @SophosSupport | Sign up for SMS Alerts
    If a post solves your question use the 'Verify Answer' link.