This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

Account registration for Community not possible


I tried for weeks to register an account to use in these community forums (until we tried this older one I'm currently using). 
No matter what operating system, browser or language setting this doesn't work anymore. No addons were active.
After registration we're asked to provide some additional information to get activated for the forums. It says we have to fill out some forms. But there is none. The code sent from the server doesn't include anything. So the user is stuck. Pressing the button returns to the side because - of course - no form inputs were filled.

I tried to find a way to contact SOPHOS' web developer, but I couldn't find any. I always got redirected to the forum which didn't work of course.

This thread was automatically locked due to age.
  • Apparently this is still a problem a month later.  I experienced the same thing you did (being prompted to fill in additional information but without any facility to do so on that page) and also saw this message on the same page:  "If you are experiencing issues logging in to the Sophos Community, please reach out to us at so we can assist you."  I did that, and  reached out to help.  Eventually she manually created a Community account for me and provided credentials to link that to my Sophos ID.

    I know that doesn't really solve your problem, but hopefully it provides some information that might be helpful.  Maybe they'll get the registration process fixed at some point.

  • This reply was deleted.
  • You're welcome.  I'm glad that it actually helped.  Thanks for taking the time to let me know!

Reply Children
No Data