Advisory: Sophos Endpoint - "Your connection isn't private." We're aware of a certificate issue and are actively working to resolve it. Please see: KB-000045954 for the latest updates.

This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

authentication failed

Hi everyone!
when I try to log in into my self-serve portal https://central.sophos.com/manage/self-service which I was able to do before, it says

Authentication failed. Please check your credentials and try again.

I am sure the password is right since I have a Sophos central account on a different email and use the same password without problems.

then I click on forgot password, I get the code on my email enter it verify it - get a prompt to enter a new password, create a password that was not used before, and I still get

Authentication failed. Please check your credentials and try again.
  • We've verified your email address. You can now create a new password.
    I've used a browser I never use in incognito and every other option, cache, passwords clear etc.
this is something that's started happening with more users in my organisation


This thread was automatically locked due to age.
Parents Reply Children
  • I know, I have included the link where it says which one I can't access - the self-service one!

    honestly, I don't see why you answered this question, but it doesn't resolve my problem or helps it in any way

  • I just wanted to clarify that admin credentials are not being used on self service login, we have many such support cases logged and concluded as one credentials(central admin) is used to login to self service portal that fails and vice versa.

    If you are sure about the credentials and URL being used for login, please log a support case so support engineer can check back end logs for login fails.

    Hardik R 
    If a post solves your question use the 'Verify Answer' link.