Advisory: Sophos Endpoint "Your connection isn't private" after reboot. Policy settings can be returned to normal. See: KB-000045954 for the latest updates.

This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

Sophos Webadmin Connection with Edge and Firefox

Hello,

 

when i connect to https://192.168.0.1:4444 via Firefox i get the message: 

 

192.168.0.1:4444 uses an invalid security certificate.

 

The certificate is only valid for sec

 

Error code: SSL_ERROR_BAD_CERT_DOMAIN

 

When i add this as exception, i can connect to the webadmin Interface, but getting in browser, that the connection is "Not Secure" 

 

When i connect to https://192.168.0.1:4444 via Microsoft Edge i get the message: 

 

Cannot securly connect to this page

 

This might be that the site uses outdated or unsafe tls security settings.

 

How can i fix this issues?

 

Thanks

Sally



This thread was automatically locked due to age.
  • I also tried under WebAdmin Settings - Re-generate WebAdmin Certificate to change from hostname UTM to the IP 192.168.0.1 , but when login to the Webadmin still get the Cert Error

  • After regeneration of the certificate with the hostname 192.168.0.1, Import the certificate to Trusted Root Certificate Authorities or Trusted Publishers
    In Friefox just click Import certificate under "Webadmin Setting"> "HTTPS Certificate"

  • Also, Firefox uses a per-user certificate store, so certificates need to be loaded per-user.   I thought this was going to change, but I just checked and it appears to be the same way it was in the past.   If Firefox settings do not float with the user, you may need to apply the setting per-user per-PC.

    Note that you need to propagate the root certificate for Webadmin, not the identity certificate.

    The Webadmin certificate is also used for User Portal.   I recommend using a commercial certificate.   Then you only have to distribute the Webadmin root certificate.

     

  • Hello,

     

    I tried the steps after regeneration to import again, import is successful but when login again still see in the browser that the session is not secure

     

    What else I can do ?

     

    Thx

    Sally

  • And with Microsoft Edge I cant connect to the admin portal, still get the message outdated or unsafe tls securitty settings, using actual edge version with updates

     

  • Delete any previous certificate than import the new one. After import click on Certificate > Advanced and trust the certificate for everything. Than restart the browser.  Do these steps in Internet Explorer (or what they call it nowdays), chrome should work if in the  Edge is properly configured, the share the same certificate store for the user. Dont forget to clear the cache and restart the browsers.

  • Thanks Oldeda, now it works

     

    Best Regards

    Sally