This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

Skype call quality suffering from UDP blocking

Hello

I'm having an issue with Skype and call quality because of UDP blocking.
A forum/Google search did not turn up anything relevant.

Using ASG home licence 8.202 - (haven't updated in awhile)

In the Skype Call Technical Info window, I have consistently bad local UDP.

Skype Call Technical Info dialog
-------------------------------------------
Packet loss=0.0% (5)
Send packet loss=0.0%/0.0%
Recv packet loss=0.1%/0.1%

UDP status=local:Bad remote:Good
-------------------------------------------

From O'Reilly Skype Hacks: "If either end of a Skype call has poor UDP, call quality will suffer"

I use the SOCKS5 proxy /w authentication for Skype, and have no problems making/receiving calls.
I have an allow all firewall rule for the port I'm using for incoming connections.
and a DNAT rule:  Allow - Any->Skype->WAN - Dest: MYPC - Auto Firewall rule

I tried turning off IPS or making an allow all for ICMP/UDP in IPS exceptions as a test - no good
Also tried turning of ICMP and UDP flood protection.

All tests with the Skype Echo Call Test Service consistently show bad local UDP,
in the Call Technical Info dialog.

IPS log shows
severity="info" sys="SecureNet" sub="ips" name="ICMP flood detected" action="ICMP flood" fwrule="60014" initf="eth0" srcip="MYPC" dstip="ASG" 

Anyone have an idea what I can do about this?


This thread was automatically locked due to age.
Parents
  • Hello

    I'm having an issue with Skype and call quality because of UDP blocking.
    A forum/Google search did not turn up anything relevant.

    Using ASG home licence 8.202 - (haven't updated in awhile)

    In the Skype Call Technical Info window, I have consistently bad local UDP.

    Skype Call Technical Info dialog
    -------------------------------------------
    Packet loss=0.0% (5)
    Send packet loss=0.0%/0.0%
    Recv packet loss=0.1%/0.1%

    UDP status=local:Bad remote:Good
    -------------------------------------------

    From O'Reilly Skype Hacks: "If either end of a Skype call has poor UDP, call quality will suffer"

    I use the SOCKS5 proxy /w authentication for Skype, and have no problems making/receiving calls.
    I have an allow all firewall rule for the port I'm using for incoming connections.
    and a DNAT rule:  Allow - Any->Skype->WAN - Dest: MYPC - Auto Firewall rule

    I tried turning off IPS or making an allow all for ICMP/UDP in IPS exceptions as a test - no good
    Also tried turning of ICMP and UDP flood protection.

    All tests with the Skype Echo Call Test Service consistently show bad local UDP,
    in the Call Technical Info dialog.

    IPS log shows
    severity="info" sys="SecureNet" sub="ips" name="ICMP flood detected" action="ICMP flood" fwrule="60014" initf="eth0" srcip="MYPC" dstip="ASG" 

    Anyone have an idea what I can do about this?


    yes..use the socks proxy and then in the settings of skype you have to tel it to use the proxy on the ASg...best way to do this and you don't have to go chasing all of hte p2p ports skype uses..[:)]  I did this and skype works wonderfully.

    Owner:  Emmanuel Technology Consulting

    http://etc-md.com

    Former Sophos SG(Astaro) advocate/researcher/Silver Partner

    PfSense w/Suricata, ntopng, 

    Other addons to follow

  • William Warren said:
    Hello

    I'm having an issue with Skype and call quality because of UDP blocking.
    A forum/Google search did not turn up anything relevant.

    Using ASG home licence 8.202 - (haven't updated in awhile)

    In the Skype Call Technical Info window, I have consistently bad local UDP.

    Skype Call Technical Info dialog
    -------------------------------------------
    Packet loss=0.0% (5)
    Send packet loss=0.0%/0.0%
    Recv packet loss=0.1%/0.1%

    UDP status=local:Bad remote:Good
    -------------------------------------------

    From O'Reilly Skype Hacks: "If either end of a Skype call has poor UDP, call quality will suffer"

    I use the SOCKS5 proxy /w authentication for Skype, and have no problems making/receiving calls.
    I have an allow all firewall rule for the port I'm using for incoming connections.
    and a DNAT rule:  Allow - Any-> Skype-> WAN TPV - Dest: MYPC - Auto Firewall rule

    I tried turning off IPS or making an allow all for ICMP/UDP in IPS exceptions as a test - no good
    Also tried turning of ICMP and UDP flood protection.

    All tests with the Skype Echo Call Test Service consistently show bad local UDP,
    in the Call Technical Info dialog.

    IPS log shows
    severity="info" sys="SecureNet" sub="ips" name="ICMP flood detected" action="ICMP flood" fwrule="60014" initf="eth0" srcip="MYPC" dstip="ASG" 

    Anyone have an idea what I can do about this?



    yes..use the socks proxy and then in the settings of skype you have to tel it to use the proxy on the ASg...best way to do this and you don't have to go chasing all of hte p2p ports skype uses..[:)]  I did this and skype works wonderfully.

     

    I had the same problem with Skype and I have solved it with your recommendation. I was going crazy for several weeks... I just wanted to thank you for the help [Y]

  • Would someone mind elaborating on the Sock5 proxy?

    From where to where?

Reply Children
  • Skype should recognize that you're accessing through a Proxy.

    Cheers - Bob

     
    Sophos UTM Community Moderator
    Sophos Certified Architect - UTM
    Sophos Certified Engineer - XG
    Gold Solution Partner since 2005
    MediaSoft, Inc. USA
  • Ah, That makes sense!

    I'm assuming of course the Skype for Business client needs to be "pointed" to / told to use the proxy.

    Now to see if Corp IT will unlock my Skype for Business client so I can set the proxy... :(

  • As I understand it, the new version of the Skype app is supposed to work without explicitly setting it to use the proxy explicitly.  I have not confirmed that with any test myself.

    Cheers - Bob

     
    Sophos UTM Community Moderator
    Sophos Certified Architect - UTM
    Sophos Certified Engineer - XG
    Gold Solution Partner since 2005
    MediaSoft, Inc. USA
  • I'll report back after my go-about with Corp IT.

    Just to confirm, you meant Skype for Business, right?

  • I was just about to ask that too. Is it skype4business?

    Our setup has two servers on the lan and another two in the dmz (dmz sandwich setup) and requires five public IP's