This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

External devices (like soundbar / vaccumcleaner) not being able to connect.

Hi community,

I have this issue with getting other devices connected to the WIFI network using the (phone) app they provide. I will explain in detail and i really hope someone can help me, because i am totally clueless.

First of all i run Sophos XG with latest firmware and use a couple AP55C's in the house. I have my WIFI network setup pretty basic:

and AP config:

I bought an soundbar earlier this year (Yamaha YAS-109) which uses this technique where you install their app, then connect to their wifi, and it should connect to the wifi where the phone was connected to. This did not work. I tried everything. In the end, Yamaha support said it had something to do with my sophos firewall and was not their issue. The soundbar worked anyway so i let it go. Today i bought a Xiaomi RoboRock S7, which uses the same technique with the app. Again it won't connect to my wireless network. Perhaps it is something in the Sophos config .. i ran out of ideas, but maybe someone who reads this can help me, i would be very thankful. 


This thread was automatically locked due to age.
  • Alright after some digging into this some more and having a brainwave while running i figured it could possibly had nothing to do with the wireless part of the XG but perhaps these devices at an issue with a relay DHCP server. So after adding a IP reservation to the MAC-addresses of these devices and tried again i both would get the IP and worked as they should. Hopefully this could help someone else with the same issue.

  • I think you can accept your own answer? Thanks for keeping us up to date.

Reply Children
No Data