Slow WiFi with XG230 and (3) APX 530 and (2) APX120

Hello,
We are experiencing slow WiFi for the (3) Dell Laptops we have in the office. Happens to be the CEO and the Director of Operations. We have an XG230  with (3) APX530s and (2) APX120s. The XG230 is on release SFOS 18.0.5 MR-5-Build586.
The Dell XPS 7590s come the Killer 1650 WiFi card. I have tried updating the drivers to newest versions, even to beta versions and playing with power settings and registry changes per complaints about slow performance on the Dell forums, nothing works.  The Dell forums are full of users complaining about speed so I thought it a Dell/Killer 1650 problem.
Sitting in the conference room with line of site access from my Macbook Pro laptop (Mid 2012) I achieve wireless speeds of 150-200mbs to the AT&T Speedtest. In the same spot I get these speeds with my Mac, the Dell 7590 it struggles to get 2-3 MB/s. We have (3) of these Dells and they all have the same low wifi speed issue.
Today, I tried swapping out the Killer 1650 for an Intel 9560NGW wifi board. This did not improve the speeds at all. Same 2-3 MB/S. per this Youtube www.youtube.com/watch
I tried a USB Stick WiFi a BlueShadow AC130mbps in the 7590 Laptops and in my Desktop. Still only 2-3 MB/S in both computers
When I enable the Intel Wifi in my Dell desktop I get 100_mbs on WiFi. So in the same location and same computer an internal WiFi performs well and the USB stick does not.
I re-enabled the WiFi on the router that comes with the AT&T fiber service we have. Even though the AT&T router is far away from the Dell 7590, no line of site and many walls in between the Dell 7590 gets 20MB/s connecting to the AT&T router's wifi.
When I connect my Iphone 11 to the WiFi I get 150+mb/s speeds up and down.
We do not have a lot of WFi devices on our network. We have only (3) SSIDs and (5) APs. My Macbook Pro and Dell Desktop work fine with the Sophos wireless. Some devices though seem to have an incompatibility issue with the Sophos APs.  
Hopefully someone here has cracked this nut on WiFi compatibility issues or settings nuances.
Best, Tom
  • Hey Tom,  https://www.intel.com/content/www/us/en/download/19779/intel-killer-performance-suite.html

    Have you tried the above "Killer Performance Suite for the 7590's.

    Also, are you running your APX units in the Central Wireless platform or managed from the Firewall? 
    Are your channels setup to avoid any local interference?  Leaving the AT&T WiFI off would be best to avoid introducing 5GHz interference into the environment.
    Are you using TKIP on any of the SSIDs?  If so, consider switching over to AES.

    Sorry, lots of questions! Slight smile

  • Matthew,


    Thank you for the reply!

    1 - Regarding Intel Killer Suite - Yes I tried installing those drivers and did not make any difference. 

    2 - I manage the APX units from the XG Firewall directly - 

    3 - AES (Secure) is selected for encryption

    4 - Normally the AT&T is disabled, I enabled it just to test the laptop against another WiFi AP

    Best,


    Tom

  • Matthew,

    I am moving the Access Points to the Sophos Central tonight.  I need to register them while they are initializing.  Apparently, Sophos Central has more controls for the APs.

    There is a firmware upgrade to apply also 11.0.015 (I am on 11.0.9)

    Sophos support logged in remotely and looked around.  They moved the firewall rule for the Private WiFi from further down the list to the top.

    My Macbook gets 200Mb/s up and down and the Dell 7590 now is getting 15-20MB/S down/up - usable.

  • Tom, when you move them to Central, the firmware is handled automatically, and APX units are kept up to date on a schedule by Central.  Interesting about the firewalls rules, possibly a rule above it was misapplying QoS, glad you are up to some speed now though!