Sophos VPN Client - disable autoconnect when in local network

Hi all,

I'm struggling with setting up Sophos VPN Client on user's Windows computers.

What behaviour I expect is to automatically connect when user connects any network except internal LAN/WIFI.

So if users is turning on the laptop at home and connects to his/her home WIFI, Sophos Client shoud connect VPN immediately. But when user comes to the office and connects to LAN network, Sophos Client should stop connecting. I edited ovpn config file and added auto_connect parameter as LAN VLAN network address (192.168.3.1), but it didn't help - after connecting to office's wifi, Sophos Client is connecting to VPN.

Next thing I tried was to block SSL VPN in firewall administration and it helped, but now Sophos Client is continuously trying to connect, fails, tries again, fails, and so on.

How to set it up so it just stops trying to connect when in LAN, and after network change (going back to home), connects VPN immediately?



Added TAGs
[edited by: Raphael Alganes at 11:11 PM (GMT -7) on 24 Mar 2024]
Parents
  • Should I create another thread concerning proper setup for .pro file or someone will help in this thread? I wrote earlier about .pro file isn't working - doesn't matter if user is in LAN or on a hotspot. Now I can't even make this connection to connect automatically, even if it is checked in Sophos Client to auto-connect.

Reply
  • Should I create another thread concerning proper setup for .pro file or someone will help in this thread? I wrote earlier about .pro file isn't working - doesn't matter if user is in LAN or on a hotspot. Now I can't even make this connection to connect automatically, even if it is checked in Sophos Client to auto-connect.

Children