Advisory: Sophos Endpoint - "Your connection isn't private." We're aware of a certificate issue and are actively working to resolve it. Please see: KB-000045954 for the latest updates.

This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

How to satisfy a continuous: To keep protecting you, Sophos needs access to your device message.

 am on a fresh install of macOS Ventura and I have the latest 13.2 update. I continously get a message throughout the day saying:


To keep protecting you, Sophos needs access to your device. Do as follows:

1. Open "Secuirty & Privacy" preferences

2. Sign on as administrator by clicking the. padlock icon.

3. Select the "Full Disk Access" group.

4. Drag the Sophos icon below to the application list.


I go to open the Secuirty and Privacy preferences, click the padlock, type in my password, select Full Disk Access, and drag the Sophos icon over to the Security and Privacy window. However, in about an hour, the same Sophos Anti-Virus message will pop-up again saying I need to add Sophos to the Full Disk Access group.
 
Currently, the following Sophos applications are enabled in Full Disk Access:
1. Sophos Diagnostic Utility
2. SophosScanAgent
3. SophosAutoUpdate
4. Sophos Scan
5. SophosCleanD
6. Sophos Anti-Virus
7. SophosServiceManager
I have tried to remove these applications from Full Disk Access and re-add them without luck. I have also attempted to manually add the applications by selecting the + icon from Security & Privacy Preferences (instead of dragging the icon from Sophos pop-up) but still no luck. This issue has been going on for a few weeks now.
The version of Sophos Anti-Virus I am using is Version 9.13.0
None of the resources I have seen look remotely like the current updated way that MacOS deals with full disk access


This thread was automatically locked due to age.
  • Thank you for reaching the community forum.

    To configure your privacy setting, You may follow the instruction listed in this documentation.

    Let us know if you have questions/clarification about this. 

    Glenn ArchieSeñas (GlennSen)
    Global Community Support Engineer

    The New Home of Sophos Support Videos!  Visit Sophos Techvids
  • I've tried this several times and it doesn't work.  The Security & Privacy panel in Ventura 13.x doesn't look or function as in this documentation.

  • I have the same problem. The Security & Privacy panel in Ventura 13.x doesn't look or function as in this documentation.

  • Hi, I have the same problem. MacOS Ventura (13.13.1), Sophos Endpoint 9.13.0 (as provided by the IT department of the university I work for) - the popup shows up every hour. I've tried all the suggested ways to give it full disk access. Here's the list of Sophos services that do have full disk access:


    com.sophos.endpoint.scanextension
    Sophos Anti-Virus
    Sophos Diagnostic Utility
    Sophos Network Extension
    Sophos Scan
    SophosAutoUpdate
    SophosCleanID
    SophosScanAgent
    SophosServiceManager


    I also uninstalled the endpoint completely and installed it again. And I removed all services from full disk access to add them again.
    Nothing helps. Super annoying! Don't know anything else to do than uninstall Sophos completely.