This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

FYI: DynDNS / policy change

I received an email from (aka et al); apparently they're going to free require users to manually login every month or they will expire accounts.

Starting now, if you would like to maintain your free Dyn account, you must log into your account once a month. Failure to do so will result in expiration and loss of your hostname. This activity helps us eliminate hostnames that are no longer needed and/or dormant. Note that using an update client will no longer suffice for this monthly login.

(emphasis mine)


This thread was automatically locked due to age.
  • Please run the whole script as you need the variables, not just the single command. But within the script you have to remove the (-s) from the curl line and the output should look like this:

    UTM:/home/login # ./
      % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                     Dload  Upload   Total   Spent    Left  Speed
    100 12074    0 12074    0     0  16669      0 --:--:-- --:--:-- --:--:-- 75462
    Login successful
  • same errors for me 

    mktemp: too few X's in template `dyndnslogin_cookie_***XX'
    mktemp: too few X's in template `dyndnslogin_output_***XX'

    curl: (6) Couldn't resolve host 'username=&password=&iov_id=&sub mit=Log+in&multiform='

    curl: (1) Protocol  https not supported or disabled in libcurl

    tested with a different password and still getting the same error
  • Which version is installed on the UTM? I'm still running 9.006...didn't tested with 9.1xx
  • version 9.103005

    I had to change the following in order not to get any errors in the script
    1. the path for me is #!/bin/bash
    2. I had to add more "xx" (2 more) to the COOKIE/OUTPUT command  (The forum replaces the XX with * )
    COOKIE=`mktemp --tmpdir="/tmp" -t ${PROGNAME}_cookie_******X`
    OUTPUT=`mktemp --tmpdir="/tmp" -t ${PROGNAME}_output_******X`

    3. There was an extra space on the curl command and that's why I got the error before

    I am still getting the "https not supported or disabled in libcurl" error message. Removing the space before the  https://URL (as below)
    curl -s -k --location -A "$USERAGENT" -b $COOKIE -c $COOKIE -o $OUTPUT \--data "username=$USERNAME&password=$PASSWORD&iov_id=&sub mit=Log+in&multiform=$MULTIFORM" \
     did the trick


      % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                     Dload  Upload   Total   Spent    Left  Speed
    101 11681    0 11681    0   111  17364    165 --:--:-- --:--:-- --:--:-- 17364
    Login successful
  • Damn too bad the forum changed symbols within the script. I'll try to solve it and post another final script.

    Great! Then it works and you can insert (-s) for silent mode, save it an run it via cronjob one time per week for example [:)]


    crontab -e

    and insert:

    15 23 * * 0 /home/login/

    to run the script every sunday at 23:15 o'clock
  • BTW I just tested it with v9.103005 and 

    works fine for me.

    It seems the only issue is with 
  • Maybe edit the file and upload the actual script on your post (you will have to zip it as .sh is not supported format)