*Unofficial* Hardware Compatibility List (HCL)

The OFFICIAL Sophos / Astaro UTM HCL is currently at http://www.sophos.com/en-us/support/knowledgebase/118185.aspx
As it does not contain all possible hardware, I've created this thread...

Please don't post questions like "will X work?" here. Open a new thread if you have a question about buying hardware not already mentioned here.
Open a new thread if you have an installation or other question.


Update: This thread is for system configurations. If you'd like to mention a single component such as a NIC or RAID controller, please post in https://community.sophos.com/products/unified-threat-management/astaroorg/f/52/t/27166

If you are having trouble with installation, please open a new thread unless you are sure that the hardware is incompatible, and if it is incompatible, be specific, e.g. "fails to detect disk", etc. Know how to use ALT-F3 etc. Ask questions in a new thread if you're not sure.


I propose that we post here with our tested system configurations, Astaro versions, and success or problems, using this template:

Template for copying/pasting:
Status: [Working|NOT Working], currently using at [Home|Work|Client]
Astaro Version(s) tested: 
System OR Motherboard: 
BIOS version: 
CPU:
RAM: 
Disk Controller 1: 
Disk Controller 2: 
Network Interfaces: 
VLAN support: (unknown|untested|no|working)
Video Controller: 
Hard Disk: (optional but please at least specify SATA/PATA/SCSI/SAS)
Optical Drive: (optional)
Case/Chassis: (optional)
Power Supply:  (optional)
What's not working: e.g. SATA doesn't work but IDE does
Total Power Consumption (in Watts, if known): [measured|estimated based upon...] please do not use the power supply rating
Total Cost: (optional, please specify currency, retail|used, and date)
Comments / Notes: (please include your Internet connection speed)


Note I used 'lscpi' to get the controllers information.
Note that one can EDIT their post later to add changes/corrections instead of posting a 'correction' post.

Also see IPS Throughput benchmarks at: https://community.sophos.com/products/unified-threat-management/astaroorg/f/52/t/29110


Please don't post questions like "will X work?" here. Open a new thread if you have a question about buying hardware not already mentioned here.


Thanks!
Barry

  • Status: Working (tv 7.4+, 8.x, 9.00x), 100% stable, Home use
    Astaro Version(s) tested: 7.403 - 7.512; 8.103, 8.305, 9.000
    Motherboard: MSI IM-945GSE-A (MS-9830-010)(fanless)
    BIOS version: 1.10
    CPU: Intel Atom n270 (1.6GHz single-core, HyperThreading (HT) enabled)
    RAM: 2GB SO-DIMM (1)
    Disk Controller 1: onboard Intel 82801G (ICH7 Family) IDE Controller
    Disk Controller 2: onboard Intel 82801GBM/GHM (ICH7 Family) SATA IDE Controller
    Network Interfaces: dual onboard Intel 82574L gigE
    VLAN support: yes, in use.
    Video Controller: onboard Intel GMA 950 (lspci says 945GM/GMS/GME,943/940GML)
    Hard Disk: Hitachi 80GB 5200RPM PATA 2.5" laptop hdd
    Optical Drive: external HP USB DVD-RW
    Case/Chassis: Morex T-3310 Mini-ITX case (fanless)
    Power Supply: Morex Built-in 80W DC-DC board + External 12V 60W AC adapter brick
    Total Power Consumption: 17watts average, 21watts peak, measured with Kill-a-Watt
    Total Cost: approx $350USD retail (as of October 2009) w/o optical drive.

    Comments / Notes: I haven't tried the SATA controller, although other users here have.
    There are rumors online about unreliable power supplies, but mine is still running strong for over 4 years.
    System is fanless
    Case does not have room to use the mb's PCI slot. Motherboard has a WatchDog timer (partially tested). 
    Estimated faster than older Astaro 120 models (circa 2009) but definitely slower than Astaro 220. (Newer 110/120's have an Atom CPU so should offer similar or better performance than mine.)
    OK for home/soho use on low bandwidth (under 25mbps) connections with several users.

    Performance: not very good anymore with IPS enabled.
    See https://community.sophos.com/products/unified-threat-management/astaroorg/f/52/t/29110

    Barry
  • In reply to BarryG:

    FYIs, I tested a Hewlett-Packard DL365 last year...

    Status: briefly tested at work
    Astaro Version(s) tested: 7.200
    System OR Motherboard: HP DL365 gen5
    BIOS version: summer 2008
    CPU: Quad-Core AMD Opteron 2346HE
    RAM:4GB Reg PC2-5300 ECC RAM (3.2GB seen, as expected)
    Disk Controller 1: HP P400i/256 SAS controller with battery
    Disk Controller 2: onboard for CDROM
    Network Interfaces: 2 embedded NC373i gigE NICs "Broadcom NetExtreme II BCM 5708"
    VLAN support: not tested
    Video Controller: onboard ATI ES1000
    Hard Disk: 2 SAS in RAID1 using P400i hardware RAID
    Optical Drive: HP DVD (ata?)
    Case/Chassis: HP
    Power Supply: dual HP
    Total Power Consumption: I measured another DL365 with 2 high-end quad-core CPUs (8 cores total) and 4 drives at 240-360w, depending on load, but should be much lower with a single HE CPU and only 2 drives.
    Total Cost: est $4000-5000USD

    Notes: only tested installation and webmin. Astaro saw all NICs, but I didn't fully test networking. 
    No problems noticed during my brief testing.

    (I also posted this last year at https://community.sophos.com/products/unified-threat-management/astaroorg/f/52/t/26564)

    Barry
  • Status: Working, currently using at Work
    Astaro Version(s) tested: 6.00->7.501
    System OR Motherboard: ASUS P5Q WS LGA 775 Intel P45 ATX Intel Motherboard
    BIOS version: 1605
    CPU: Intel 2.66GHz Quad Core LGA 775
    RAM: 4GB Geil GE22GB800C4DC
    Disk Controller 1: Onboard Intel ICH10
    Disk Controller 2: Promise SATA PCI 2 port controller
    Network Interfaces: 6 total, two onboard 4 on PCI-X
    Realtek 2 x 8111C Dual Gigabit LAN
    Intel Pro/1000 Quad Port PCI-X
    VLAN support: Should be OK, untested. Intel NIC supports VLAN
    Video Controller: nVidia card, passive heatsink
    Hard Disk: Western Digital 300GB 10K RPM VelociRaptor
    Optical Drive: None.  (Used USB one to install)
    Case/Chassis: (optional)
    Power Supply: 600W Coolermaster
    What's not working: Using Promise controller for SATA, onboard ICH10 not working.
    Total Power Consumption (in Watts, if known): Unknown
    Total Cost: Approx $1500AUD
    Comments / Notes:

    Very stable.  Runs nicely, CPU usage graph barely shows any bumps with 70+ users with all features turned on with 8 VPNs running.
  • In reply to Simon Shaw:

    Status: [Working], currently using at [Home]
    Astaro Version(s) tested:  v8b
    System OR Motherboard: Gigabyte M61PME-S2P rev 1.0
    BIOS version:  f5
    CPU: AMD x2 5050e (45w)
    RAM: 2gb DDR2 match pair of 1gb (800) but only works at 667
    Disk Controller 1: NVidia GeForce 6100/nForce 430 chipset
    Disk Controller 2: IT8718 (floppy,  lpt, etc)
    Network Interfaces: on-board RTL 8201CLwas recognised during beta, but failed to connect PPPoE, now not recognised at all. 
      Intel 1000 Pro:  2 different version 84251PI and 82572EI
    VLAN support: 2 vlans (working)
    Video Controller:  NVIDIA GeForce 6100/ nForce 430
    Hard Disk: Western Digital AV 320gb (SATA)
    Optical Drive:  what ever is handy at build time (have changed config to use USB CD)
    Case/Chassis: Gigabyte “Chassis”
    Power Supply:  came with case, fan too noisy changed the fan for an Artic. Tried a Zalman 460 low noise power supply, base load does not appear to be sufficient to allow the PSU to function correctly, power went up to 47-55 and peaked a lot around the high 60s until I put the load on the IDE leads. 
      Not sure of power rating, very hard to find high efficiency, low power rated powersupplies or even fanless power supplies.
    What's not working: e.g. HPET, causes a panic and stop during installation. Gigabyte advise me to change OS because they can't replicate the problem on MS, so the problem doesn't exist.
    HPET is working after BIOS upgrade
    Total Power Consumption 44w idle, low use – 55w starts at 75w: [measured.] Power consumption with v8b is idle 36w
      Total Cost: about $500 AUD, retail, about Aug 09
    Comments / Notes: I think the CPU is the limiting factor on memory performance. Power consumption went up from high 30s to 44 when I changed from a 2.5” sata drive to the AV 3.5” and added the extra NIC. Even with 3 fans the system is very quiet, the Artic fans move a lot of air very quietly. The case fan is a PWM linked to the cpu fan. CPU occasionally peaks at 6-9% usually below 1%

    Update 7th Dec 09.
    I removed one Intel NIC and configured the onboard NIC for PPPoE. Secret appears to be use the Intel NIC for configuration, don't use v7.501, go from 7.500 to 7.502. Power still around 44 but drops to 42. Next experiment, remove the Intel NIC and replace with a cooler version and drop the memory speed.
  • In reply to RFCat_vk_01:

    Status: [NOT Working], currently using at [Home] (Spare)
    Astaro Version(s) tested: 7.500b -7.505
    System OR Motherboard: Intel D945GCLF2
    BIOS version: LF94510J.86A
    CPU: Atom (x2) 330 with HT
    RAM:  2gb Corsair 800 only runs at 533 (BIOS recognises that the memory stick is Corsair 800)
    Disk Controller 1: ICH7
    Disk Controller 2: 
    Network Interfaces: On-board RTL8111/8168B, PCI Intel 82541PI
    VLAN support: (working)
    Video Controller: 945GC
    Hard Disk: Seagate Momentus 200gb 7200 2.5”, SATA
    Optical Drive: USB 
    Case/Chassis: Unknown - micro atx or mini itx
    Power Supply: unknown, came with case IP-AD120-2 (120w)
    What's not working:  
    Total Power Consumption (in Watts, if known):  42-55w measured 
    Total Cost: Approx $450 AUD, retail, 2009
    Comments / Notes: The onboard chipset fan is very noisy and prone to failure. Do NOT operate with the MB on its side, this causes the fan to fail even faster. I replaced the fan with a bigger (thicker), quieter, spins slower, but does not report speed to mb. The power supply gets quite hot and has a small high speed fan. The case has a fan which is low noise and is most definitely required to force air through the case.
      [FONT=&quot]To me this box appears to be slower than the AMD x2 5050e running about the same power consumption[/FONT]. CPU runs at about 3% peaking to about 20%.

    Ian MSmile
  • In reply to RFCat_vk_01:

    Great to see this thread in addition to my question (https://community.sophos.com/products/unified-threat-management/astaroorg/f/52/t/27163).
    I've bought the following system (with crossed fingers ;-)) to replace the crappy small form factor system Astaro is currently running on.

    Status: Working, currently using at SMB
    Astaro Version(s) tested: 7.501
    System OR Motherboard: Asus P5KPL-AM
    BIOS version: AMI 2.58  (ASUS 5.18)
    CPU: Intel Pentium D E5300 s775
    RAM: 2GB Corsair DDR2 667
    Disk Controller 1: Onboard Intel Corporation 82801GB/GR/GH (Intel G31/ICH7) SATA IDE Controller
    Disk Controller 2: 
    Network Interfaces: Onboard NOT Working! added 3 extra NICs with RTL8139 chipset
    VLAN support: unknown
    Video Controller: Onboard VGA compatible controller: Intel Corporation 82G33/G31 Express Graphics Controller (rev 10)
    Hard Disk: SATA 160GB Western Digital
    Optical Drive: Plexwriter (IDE / PATA)
    Comments / Notes:
    Set Compatible mode on / true for the onboard storage controller.

    I had to to run the Astaro installation in 'Classic' mode!

    Thanks, 

    Donnie Smile
  • In reply to donnie:

    Status: [Working], currently using at [Home]
    Astaro Version(s) tested: 7.501
    System OR Motherboard:  Gigabyte GA-7S748
    BIOS version: 
    CPU: AMD Athlon XP 2200+ 1,8GHz FSB266 
    RAM: 1 GB
    Disk Controller 1: 
    Disk Controller 2: 
    Network Interfaces: 1  SiS900 PCI Fast Ethernet (onboard); 1 RTL-8029(AS) PCI; Adaptec ANA620xx/ (4 x 100Mbit)
     VLAN support: (unknown|untested|no|working)
    Video Controller:  HIS RADEON 9250 128MB 
    Hard Disk: PATA 120 GB
  • Status: [Working], currently using at [Home]
    Astaro Version(s) tested: 7.50x / 8.00x
    Motherboard: Asus AT3GC-I, mini-ITX, onboard Atom 330, 533MHz FSB, Intel® 945GC / ICH7, 1 x DDR2 667/533 Mhz, VGA, PCI
    LAN, SATA, Audio 
    CPU: Atom 330
    RAM: 2GB SO-DIMM, Kingston Memory DDR2 2GB PC2-4300, 533MHz, CL4,Non-ECC, 256Mx64, 240Pin
    Disk Controller 1: 1 x UltraDMA 100/66 
    Disk Controller 2: 2 x SATA 3 Gb/s ports 
    Network Interfaces: 1 x onboard, 1 x D-Link DGE-530T: 1Gbps, low profile
    VLAN support: (untested)
    Video Controller: Integrated Intel Graphics Media Accelerator 950
    Hard Disk: WESTERN DIGITAL Scorpio Black WD3200BJKT, 320GB, 2.5", 16MB Cache, 7200 U/Min, 12 ms, SATA II 3.0Gb/s, Free-fall Sensor
    Optical Drive: none (USB CD-ROM for install)
    Case/Chassis: APLUS CS Cupid 1
    Power Supply: 90W PSU
    What's not working: I had to set several BIOS settings (try and error) to get 7.500 running (SATA settings)
    Total Power Consumption (in Watts): [measured] ~36 W
    Total Cost: 600 CHF = 600 USD ;-), retail (Oct 2009)
    Comments / Notes: This is an complete fanless system (I disconnected the CPU fan), it works well and fast, now for over an month (24/7)
  • In reply to Copyright:

    Status: (SATA DVD) NOT Working 
    Astaro Version(s) tested: 7.500
    System OR Motherboard: HP Proliant DL360 G6 - Chipset Intel 5520
    BIOS version: 2009.10.01 (A) 29 Oct 2009
    CPU: Xeon 2.13 E5506 Quad-Core
    RAM: 2 x 1 GB PC3-10600 DDR3 SDRAM
    Disk Controller 1: Smart Array P410i w/ BBWC
    Disk Controller 2:
    Network Interfaces: HP NC382i
    VLAN support: unknown
    Video Controller: ATIES1000
    Hard Disk: SAS
    Optical Drive: DVD SATA
    Case/Chassis: 2 U

    What's not working: 
    Install error:
     Unable to find the installation CD
    Appears 7.500 Soft ISO does not have driver for this Serial ATA DVD-ROM. Install works fine using external USB CDROM.
  • Status: WORKING, Using at Home
    Astaro Version(s) tested: 7.500-7.502 - got much faster after installing 7.502
    System OR Motherboard: Intel D865GBFL (home built system)
    BIOS version: 
    CPU: P4 3.0, HT enabled
    RAM: 1024MB
    Disk Controller 1: Built-in ICH5/ICH5R
    Disk Controller 2: 
    Network Interfaces: Onboard Intel 82562EZ 10/100 and mix of 3Com 3c905, 3c905B, and 3c905C (I have all six PCI slots populated and tested connections)
    VLAN support: (unknown|untested|no|working)
    Video Controller: Onboard 82865 graphics chip
    Hard Disk: 250GB SATA Hard Drive using onboard controller
    Optical Drive: (optional)
    Case/Chassis: (optional)
    Power Supply: (optional)
    What's not working: n/a
    Comments / Notes:
    Everything appears to work.
  • In reply to ifshmn:

    Status: Working, currently using at Home|Client
    Astaro Version(s) tested: 7.502 now 8.01
    System OR Motherboard: Lex Brik 3I270D Mini Barebone
    BIOS version: ??
    CPU: Intel Atom N270 1.6GHz - Hyperthreading on
    RAM: 1GB onboard DDR2 533
    Disk Controller 1: ICH7M
    Network Interfaces: 4x 1G/bit Realtek RLT8111C
    VLAN support: unknown
    Video Controller: integrated Chipset - only Sub-D
    Hard Disk: 1x SATA
    Optical Drive: ----, with USB-external only
    Case/Chassis: Brik 2.5" Ver.
    Power Supply: 30W external
    What's not working: ----
    Total Power Consumption (in Watts, if known): 18W at startup, ~ 5W after Boot is finished 
    Total Cost: ~ 400€ with 2.5" HDD
    Comments / Notes: Vesa Mounting Support 75x75, absolutly noiseless
  • In reply to ManfredHeubeck:

    Status: Working, currently using at Home|Client
    Astaro Version(s) tested: 7.502
    System OR Motherboard: Intel D510MO FANLESS!!!
    BIOS version: MOPNV10J.86A.0154
    CPU: Intel® Atom™ Prozessor D510 2x 1.66Ghz - Hyperthreading on
    RAM: 1GB Kingston DDR2 800
    Disk Controller 1: unknown
    Network Interfaces: 1x 10/100/1000 Mbits/sec LAN subsystem using a Realtek 8111DL Gigabit Ethernet Controller
                                1x Intel MT1000 PRO Desktop Adapter
    VLAN support: unknown
    Video Controller: integrated Chipset - only Sub-D
    Hard Disk: 1x 2,5" SATA 5400rpm 120GB Hitachi 
    Optical Drive: ----
    Case/Chassis: Chieftec CS601
    Power Supply: 120W internal 20PIN
    What's not working: ----
    Total Power Consumption (in Watts, if known): 27W 
    Total Cost: don't know, refurbished old parts.. bought only the mainboard for 70 euro
  • Status: Working, currently using at Home
    Astaro Version(s) tested: 7.502, 7.503
    System OR Motherboard: Intel D945GSEJT
    BIOS version: JT94510H.86A
    CPU: ATOM N270 (1,6 Ghz, Single-Core )
    RAM: Corsair VS2GSDS667D2 PC2-5300 2 GB  
    Disk Controller 1: Intel 82801GBM I/O Controller Hub (ICH7M)
    Disk Controller 2:
    Network Interfaces: 1 x onboard, 1 x D-Link DGE-530T
    VLAN support: unknown
    Video Controller: Mobile Intel 945GSE Express Chipset
    Hard Disk: Adapter CF > SATA (Delock) with CF CARD Transcend 16 GB
    Optical Drive: None
    Case/Chassis: In the Moment no Case, comming later
    Power Supply: FSP060-1AD101C, 60W
    What's not working: 
    Total Power Consumption (in Watts, if known): 16 W [measured]
    Total Cost: TOTAL arround 210 Euro(Germany) retail in January/February 2010
    (D945GSEJT,90 Euro + DeLOCK CompactFlash Card (CF) 2,5 Laufwerk SATA,22 Euro + 
    Transcend CF Card 16GB,40 Euro + Networkcard D-Link DGE-530T, 19 Euro + RAM Corsair VS2GSDS667D2, 40 Euro)
    Powersupply existed
    Case is comming later
    Comments / Notes: System is fanless, System installed with 7.502 in beginning of February 2010, Update up to 7.503 at beginning of March 2010.
    In the Moment ist is running well and stable.
  • Status: [Working|NOT Working], currently using at [Home|Work|Client]
    Astaro Version(s) tested: 7.502-7.503
    System OR Motherboard: Toshiba Magnia SG30
    BIOS version: ?B149? 12/12/2003
    CPU: Celeron 1.2ghz
    RAM: 512MB ECC
    Disk Controller 1: VT82C686A
    Disk Controller 2: n/a
    Network Interfaces: Intel i82555 & Realtek 8139 (Connected to built in 7 port switch)
    VLAN support: (unknown|untested|no|working)
    Video Controller: None (Headless)
    Hard Disk: 80GB Hitachi 2.5"
    Optical Drive: None
    Case/Chassis: SG30 Stock Case
    Power Supply: 110Watt Internal
    What's not working: LCD front panel power button shutdown
    Total Power Consumption : Not known yet
    Comments / Notes: Old system, but 7.502-4 seems to run great on it.  Details on the install can be found in this thread:
    https://community.sophos.com/products/unified-threat-management/astaroorg/f/52/t/27356
  • Status: [Working|NOT Working], currently using at [Home|Work|Client]
    Astaro Version(s) tested: Release 7.504
    System OR Motherboard: MSI G41M-E43
    BIOS version: v7.7
    CPU: Intel Dual Core Celeron E3300 S775
    RAM: 2x 1GB DDR3 (Kingston Value)
    Disk Controller 1: onboard IDE Intel ICH7
    Disk Controller 2: 
    Network Interfaces: Onboard Realtek Gigabit LAN, 2x Intel PCI Gigabit LAN, 1x Intel PCI-E Gigabit LAN
    VLAN support: (unknown|untested|no|working)
    Video Controller: onboard/integrated (Intel G41 chipset)
    Hard Disk: 2,5" WD Scorpio Blue 80GB (IDE)
    Optical Drive: none
    Case/Chassis: random desktop case
    Power Supply: PicoPSU 150w
    What's not working: ---
    Total Power Consumption (in Watts, if known): [measured|estimated based  upon|unknown]
    Total Cost: ~200€, new items
    Comments / Notes: system is running passively cooled, cpu is undervolted from 1,3v to 1v while using a SilverStone Nitrogon NT06 CPU cooler.