Skype call quality suffering from UDP blocking

Hello

I'm having an issue with Skype and call quality because of UDP blocking.
A forum/Google search did not turn up anything relevant.

Using ASG home licence 8.202 - (haven't updated in awhile)

In the Skype Call Technical Info window, I have consistently bad local UDP.

Skype Call Technical Info dialog
-------------------------------------------
Packet loss=0.0% (5)
Send packet loss=0.0%/0.0%
Recv packet loss=0.1%/0.1%

UDP status=local:Bad remote:Good
-------------------------------------------

From O'Reilly Skype Hacks: "If either end of a Skype call has poor UDP, call quality will suffer"

I use the SOCKS5 proxy /w authentication for Skype, and have no problems making/receiving calls.
I have an allow all firewall rule for the port I'm using for incoming connections.
and a DNAT rule:  Allow - Any->Skype->WAN - Dest: MYPC - Auto Firewall rule

I tried turning off IPS or making an allow all for ICMP/UDP in IPS exceptions as a test - no good
Also tried turning of ICMP and UDP flood protection.

All tests with the Skype Echo Call Test Service consistently show bad local UDP,
in the Call Technical Info dialog.

IPS log shows
severity="info" sys="SecureNet" sub="ips" name="ICMP flood detected" action="ICMP flood" fwrule="60014" initf="eth0" srcip="MYPC" dstip="ASG" 

Anyone have an idea what I can do about this?
  • Im interested in this as well

    BUMP
  • Maybe disabling the icmp / udp flooding option, or setting the thresholds higher may help?

    Wer Schreibfehler findet, darf sie behalten. Wenn ich via IPad poste, sind Verschreiber und grammatikalische Aussetzer irgendwie an der Tagesordnung.
  • Hello

    I'm having an issue with Skype and call quality because of UDP blocking.
    A forum/Google search did not turn up anything relevant.

    Using ASG home licence 8.202 - (haven't updated in awhile)

    In the Skype Call Technical Info window, I have consistently bad local UDP.

    Skype Call Technical Info dialog
    -------------------------------------------
    Packet loss=0.0% (5)
    Send packet loss=0.0%/0.0%
    Recv packet loss=0.1%/0.1%

    UDP status=local:Bad remote:Good
    -------------------------------------------

    From O'Reilly Skype Hacks: "If either end of a Skype call has poor UDP, call quality will suffer"

    I use the SOCKS5 proxy /w authentication for Skype, and have no problems making/receiving calls.
    I have an allow all firewall rule for the port I'm using for incoming connections.
    and a DNAT rule:  Allow - Any->Skype->WAN - Dest: MYPC - Auto Firewall rule

    I tried turning off IPS or making an allow all for ICMP/UDP in IPS exceptions as a test - no good
    Also tried turning of ICMP and UDP flood protection.

    All tests with the Skype Echo Call Test Service consistently show bad local UDP,
    in the Call Technical Info dialog.

    IPS log shows
    severity="info" sys="SecureNet" sub="ips" name="ICMP flood detected" action="ICMP flood" fwrule="60014" initf="eth0" srcip="MYPC" dstip="ASG" 

    Anyone have an idea what I can do about this?


    yes..use the socks proxy and then in the settings of skype you have to tel it to use the proxy on the ASg...best way to do this and you don't have to go chasing all of hte p2p ports skype uses..Smile  I did this and skype works wonderfully.
  • first of all update to 8.303.  Secondly are you running a firewall on your pc? j thirdly what anti-stuff is on your pc?  Fourthly need system specs on pc and astaro.
  • also get rid of that nat rule..you are now having two routes internally for your skype traffic..either use the nat rule(not advise IMO) or use only the socks(advised).  I use only the socks and it works great as long as you set it up correctly both on the ASG and the skype itself.  Skype won't automatically use the socks you have to tell it or it will try to use the p2p style it likes to use.
  • Hi Sascha and William.

    Thank You for your response.

    Sascha, I've already tried turning off icmp and udp flood protection, and turning off IPS, adding exclusion rules, etc.

    I forgot the more relevant firewall log in my first post...
    There are dropped udp packets.

    William, I've now applied all updates up to 8.303, and the DNAT rule is off.
    I have only four packet filter rules for wireless device access.

    I get Good local UDP when I connect the XP/Win 7 box (same issue with Skype on both OS) directly to the cable modem.
    So that eliminates software as an issue (Avast AV only on both XP/Win7 - no software firewalls) 

    I also tried connecting the XP/Win 7 box directly to the ASG (eliminating a switch and wireless router access point), still have bad local udp.

    The ASG box is an old Dell OptiPlex GX280 (unreliable onboard NIC disabled) with a 2.8ghz Pentium 4 /w 1gb ram (yes, I know it's underpowered, but I have only two pc boxes and phone/ipod using it, with mem use about 70-80%) 
    The NIC is an HP Compaq NC7170 Dual Port Gigabit (Intel 82546EB)

    I already have setup Skype to use the SOCKS5 proxy with authentication.
    Tools/Options/Advanced/Connection
    Use port 33000 for incoming connections (was originally using same port for torrent with a port forwarding rule)
    SOCKS5 Host 192.168.x.***:1080 (address of ASG)
    Enable proxy authentication
    Username: *** Password: ***

    I have changed the XP/Win7 box Host network definition to Any instead of Internal.

    Skype is not using the SOCKS5 proxy for UDP, I'm getting Default Drop UDP messages in the Firewall log,
    even if I add an any-udp-any rule as first rule.


    I get dropped packets between remote IP and ASGWAN, PC and ASGLAN and PC and MYWANIP on ASGLAN

    name="Packet dropped" action="drop" fwrule="60001" initf="eth1" srcmac="REMOTE" dstmac="ASGWAN" srcip="REMOTE" dstip="MYIP" proto="17" 

    length="56" tos="0x00" prec="0x00" ttl="49" srcport="41390" dstport="33000" 

    name="Packet dropped" action="drop" fwrule="60001" initf="eth0" srcmac="MYPC" dstmac="ASGLAN" srcip="MYPC" dstip="ASGLAN" proto="17" length="98" 

    tos="0x00" prec="0x00" ttl="64" srcport="6655" dstport="56429" 

    name="Packet dropped" action="drop" fwrule="60001" initf="eth0" srcmac="MYPC" dstmac="ASGLAN" srcip="MYPC" dstip="MYIP" proto="17" length="56" 

    tos="0x00" prec="0x00" ttl="64" srcport="10841" dstport="54100"
  • In reply to orangealert:

    Hi orangealert,

     

    Did you find a solution for this?

    We are using UTM 9 (9.411-3) and i have the same issue. Audio Quality is bad with breaks.

    Did you have a working config now?

     

    Thanks

    Stephan 

     

  • In reply to Gerber Stephan:

    Hi,, Stephan, and welcome to the UTM Community!

    What do you learn from doing #1 in Rulz?

    Cheers - Bob

  • In reply to BAlfson:

    Hi Bob

    Thanks, very good Post!

    I have checked #1

    - Firewall Log shows  dropping  udp 35xxx to 443 if i analyze the skype connection

    - UDP Flood Protection is off

    Checking also #3 - #5. Found some direct bindings.

    I will check skype again tomorrow.

    Cheers Stephan

  • In reply to William Warren:

    William Warren
    Hello

    I'm having an issue with Skype and call quality because of UDP blocking.
    A forum/Google search did not turn up anything relevant.

    Using ASG home licence 8.202 - (haven't updated in awhile)

    In the Skype Call Technical Info window, I have consistently bad local UDP.

    Skype Call Technical Info dialog
    -------------------------------------------
    Packet loss=0.0% (5)
    Send packet loss=0.0%/0.0%
    Recv packet loss=0.1%/0.1%

    UDP status=local:Bad remote:Good
    -------------------------------------------

    From O'Reilly Skype Hacks: "If either end of a Skype call has poor UDP, call quality will suffer"

    I use the SOCKS5 proxy /w authentication for Skype, and have no problems making/receiving calls.
    I have an allow all firewall rule for the port I'm using for incoming connections.
    and a DNAT rule:  Allow - Any-> Skype-> WAN TPV - Dest: MYPC - Auto Firewall rule

    I tried turning off IPS or making an allow all for ICMP/UDP in IPS exceptions as a test - no good
    Also tried turning of ICMP and UDP flood protection.

    All tests with the Skype Echo Call Test Service consistently show bad local UDP,
    in the Call Technical Info dialog.

    IPS log shows
    severity="info" sys="SecureNet" sub="ips" name="ICMP flood detected" action="ICMP flood" fwrule="60014" initf="eth0" srcip="MYPC" dstip="ASG" 

    Anyone have an idea what I can do about this?



    yes..use the socks proxy and then in the settings of skype you have to tel it to use the proxy on the ASg...best way to do this and you don't have to go chasing all of hte p2p ports skype uses..Smile  I did this and skype works wonderfully.

     

    I had the same problem with Skype and I have solved it with your recommendation. I was going crazy for several weeks... I just wanted to thank you for the help Yes

  • In reply to Alex Clicowski:

    Would someone mind elaborating on the Sock5 proxy?

    From where to where?

  • In reply to Pedulla:

    Skype should recognize that you're accessing through a Proxy.

    Cheers - Bob

  • In reply to BAlfson:

    Ah, That makes sense!

    I'm assuming of course the Skype for Business client needs to be "pointed" to / told to use the proxy.

    Now to see if Corp IT will unlock my Skype for Business client so I can set the proxy... :(

  • In reply to Pedulla:

    As I understand it, the new version of the Skype app is supposed to work without explicitly setting it to use the proxy explicitly.  I have not confirmed that with any test myself.

    Cheers - Bob

  • In reply to BAlfson:

    I'll report back after my go-about with Corp IT.

    Just to confirm, you meant Skype for Business, right?