I have the same problem re #131959

What should I do? When I power up, I get the message "Please contact your system administrator.  Your Mac is running with non-standard permissions on key directories and your Mac may be insecure.  Reference Sophos Knowledge Base Article #131959."  What should I do?  I have no system administrator and don't see any solution that I can understand in the Knowledge Base #131959.  I don't even know what Sophos is.  Thanks for your help.

  • Hello Eve Ma,

    I have no system administrator [...] I don't even know what Sophos is
    so how did it get onto your Mac as an administrator is needed to install this software? Is this a private Mac or?

    Christian

  • In reply to QC:

    Yeah I've had this issue also and it pops up every 2 mins. Very annoying. I am the admin for the computer but not coding friendly. Need a fix for this!

     
  • Here is a simple solution that worked for me [I also found the "Knowledge Base Article #131959" quite useless].

    To implement it you will need administrator access; if you are a single user you have it and your password is the one you use when you login. If you never set one up, go to "System Preferences", then accounts, select your account, and then "change password". If you never selected a password, it means it is now empty; so change it to something meaningful.

    OK, this done, select your main drive [where the operating system resides ... most people leave it at the default "Macintosh HD"] and do a "Get Info" on it from the finder. Go down to the bottom of the Get Info window and check the permissions that show up there. They should read
      System:   Read & Write
      Wheel:    Read only
      Everyone: Read only

    Most likely you have the wrong permissions under "Wheel". Change them so they are as above. To do this you will have to first "unlock" the permissions section; click on the lock and enter your password. Then fix the Wheel's permissions.

    Note: this is what worked for me. Those permissions got screwed when I cloned my drive. In your case something else may have done this ... or your problem may not be the same one I had ... But fixing your main drive permissions, if they are wrong, cannot hurt.

     

    Hope this helps, and sorry if I over-explained trivial things you already knew.

  • Please see

    https://community.sophos.com/products/endpoint-security-control/f/sophos-endpoint-software/109120/i-have-the-same-problem-re-131959/393267#393267

    where I suggest a fix. OK here it goes again:

    Here is a simple solution that worked for me [I also found the "Knowledge Base Article #131959" quite useless].

    To implement it you will need administrator access; if you are a single user you have it and your password is the one you use when you login. If you never set one up, go to "System Preferences", then accounts, select your account, and then "change password". If you never selected a password, it means it is now empty; so change it to something meaningful.

    OK, this done, select your main drive [where the operating system resides ... most people leave it at the default "Macintosh HD"] and do a "Get Info" on it from the finder. Go down to the bottom of the Get Info window and check the permissions that show up there. They should read
      System:   Read & Write
      Wheel:    Read only
      Everyone: Read only

    Most likely you have the wrong permissions under "Wheel". Change them so they are as above. To do this you will have to first "unlock" the permissions section; click on the lock and enter your password. Then fix the Wheel's permissions.

    Note: this is what worked for me. Those permissions got screwed when I cloned my drive. In your case something else may have done this ... or your problem may not be the same one I had ... But fixing your main drive permissions, if they are wrong, cannot hurt.

     

    Hope this helps, and sorry if I over-explained trivial things you already knew.