This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

How do I boot to previous firmware with Putty?

Hi All,


I 'upgraded' to firmware version 17 MR2 from 17 MR1.


Since the 'upgrade' I cannot access the web UI - I get a blank page with "Internal Server Error" in the top right corner in response to login submission.


I do not have easy access to connect a terminal cable but I can get access through Putty.


Is there a way to remove the MR2 or boot to MR1 using a connection with Putty?



This thread was automatically locked due to age.
  • I have exactly same issue. Username and password screen is visible and when login pressed it shows internal server error. How I can boot with firmware  SFOS 17.0.1 MR-1 using SSH?

  • Same problem here, after upgrade firmware from 17.0.1-mr1 to 17.0.2-mr2 I get an internal server error after login to the webconsole

    Cli is accessable, XG seems to work fine.

    Restart the webservice via cli does not solve the problem. Is this a known Issue of MR2, any other ideas how to solve this problem?



    Danny Oosterveer

  • When you ssh in to the firewall, go into Device Management, then Show Firmware(s). Make a note of the firmware numbers and the current firmware in use.

    Then go into Advanced Shell and type the following:

    rebootfw -f <n>

    where <n> is the firmware number not in use.

    That is, if Firmware 1 is the current firmware, then <n> is 2, and vice versa.

  • Cheers it solved the problem. But when try to upgrade the box again to 17.0.2-mr2 resulted in same problem again. Is this is known issue or upgrade seem to regenerate same problem again?  I have upgraded two boxes (running in HA mode) at our production site with no issue. However, I am not being able to upgrade my DR box. Logically it doesn't seems to be known issue. What do you say. How can I upgrade cleanly, any ideas?

  • Hi,


    see the below link for boot old Firmware.

    i am also received the same issue after upgrading.


    Kamal Patel 


  • I'd download the upgrade file from the Sophos site, verify that the checksums match, back up the configuration, perform a factory reset, perform the upgrade, then either restore the backup or reconfigure from scratch (preferrred method when upgrades fail like this).

    Failing that I'd log a support ticket with Sophos and get them to investigate.

  • OK will ask my engineer at DR site to perform the above mentioned steps. 

  • Same issue with upgrading our boxes from 16.8 to 17.2. It showed both versions firmware installed in the console but 16.8 was the active firmware, with the inability to login to the web interface. All I can say is eventually the devices rebooted and 17.2 was running and has been running fine since. Frustrating the Quality Control on these is still so bad but glad it magically worked.

  • I managed to re-start using 17.0.1 and was able to log in. I tried booting to 17.0.2 without using the settings from the previous version, then, once I had gone through the problems of reconfiguring a PC on the network and reconfigured the managed switch between it and the Sophos, I restored my backed up settings.

    Upon the restart, having again configured the PC and switch, I was back to square one... "Internal Server Error".

    I used PuTTY to reboot to 17.0.1, which is working correctly, and left it there...

    Today, to my delight, I found 17.0.3 was available and promptly got it installed. I hoped that it would allow me to access the web UI, however, as with 17.0.2, I am getting the same "Internal Server Error" problem.

    This really isn't good enough Sophos.


    Self employer computer technician (mostly domestic) and photographer.

    Language: English English (UK) - No, NOT (U.S.).
    Why is it that the IT world assumes that if you speak English then it is American, not English.
    English did not come from America, that's why it's not called American!!!

  • Hi All,


    The same problem tried MR-2 and MR-3 Internal server error when trying access Web Admin portal, user portal work fine. Thanks "ChrisKnight" for work around both is not the best solution to stop upgrade firmware version at all. Sophos any update we can see many users with the same issue. Thank you