This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

openvpn tls-remote ? deprecated yet used.

hi,

 

very confused about this in 9.501

 

Fix [NUTM-6504]: [Access & Identity] OpenVPN 2.4.0 deprecated option "tls-remote"

Fix [NUTM-7448]: [Access & Identity] SSLVPN: download of configuration for windows should use tls-remote option

 

The config file you then download has tls-remote however this does NOT work at all with the latest openvpn client (errors out) where you need to replace tls-remote (as its deprecated since long) with "verify-x509-name" thus rendering the download option for clients in userportal useless.

 

What got fixed now ? tls-remote got finally deprecated in utm and properly replaced but then overridden by nutm-7448 ? 

Anyway since very long that option no longer works with openvpn client.

Or is there a fix (workaround:) ) so i can have users have a proper config file that works to download in userportal ?



This thread was automatically locked due to age.
Parents
  • Hi,

    I've edited my config.ovpn file. There is a line like the following

    tls-remote "/C=Country/L=City/O=Company/CN=Name/emailAddress=email address"

     

    You have to replace the line with the following line

    verify-x509-name "C=Country, L=City, O=Company, CN=Name, emailAddress=email-address"

     

    After this I can start vpn and connect successfully.

     

    Kind regards,

    Marc

  • Can't you just log into the user portal and redownload the configuration files for ovpn after the upgrade?

Reply Children
No Data