5% upload speed on Sophos UTM

First off let me say I know this has been a frequent question posted here regarding slow upload speeds on the UTM.  I have been a UTM user for well over a decade probably closer to 15 years.  I may not be a Bob expert but I know my way around the software. 

I recently got an ATT symmetric 1GB fiber line and plugged it up to my UTM VM.  At first, performance was normal and expected.  I was getting close enough to max throughput with the understanding that I would be getting less because it was running in a VM on older hardware.  All fine.  Then one day, and I honestly don't know when, upload performance just took a nose dive.  I would get 3-5Mbps on uploads.  Sometimes spiking to 7%.  

I did all the normal things, turned off IDS, turned off web filtering, confirmed 1500 MTU on all NICs, you name it.  I have a small Ubiquiti FW as a backup and it was able to get full 1Gb from all my VM's and my physical boxes, so I know my internal network is fine and can handle it.  I even built not 1 but 2 brand new UTMs.  One I did a restore of a config and another I did unconfigured, no settings.  The performance of all these UTMs is the same 5Mbps upload.  Download speeds are fine and close to theoretical maximums.  I am at a complete loss.  I do NOT want to migrate my services to Ubiquiti.  I want to keep using the UTM. What else can I do?  there are no IDS or filtering logs to check since all of that is disabled.  Is this an ATT thing?  Is there some special setting I need to make on the ATT FW or UTM interface setting I need to make to get this to work?  It doesn't have to be perfect, but symmetrical upload is all I want.  

  • I've never heard upload speeds being an issue with UTM, just the downloading from the poor implementation of single thread snort use which no one seems to want to upgrade to multi threading. :/

    Anyways, the only thing I've heard about upload issues with ATT Fiber (which is almost in my area, so I can't wait) is a setting on NICs that are enabled - Large Offload IPv4 (v2). Disabling that apparently fixed upload speeds.  Not sure if UTM supports that feature or not, but your VM might? 

    Worth a try to find and disable that.

    UTM - 9.713-19 64-bit | Intel Xeon 4-core v3 1225 3.20Ghz
    16GB Memory | 500GB SATA HDD | GB Ethernet x5

  • With 100MBit we see this behaviour with fixed interface-speed settings from ISP.

    Should not be relevant with 1GBit connection ... but you may try different interface settings ... change from "auto" to "1000baseT/Full"

    Interfaces & Routing // Interfaces // Hardware // ...


    Dirk

    Systema Gesellschaft für angewandte Datentechnik mbH  // Sophos Platinum Partner
    Sophos Solution Partner since 2003
    If a post solves your question, click the 'Verify Answer' link at this post.

  • Good thinking.  Went looking but there is not a place to configure that at least not in the VM.  I do have some 1GB links in a VSS on my ESXi host that I can host at least for the Internal network.  I moved the NIC over there and there was no difference.  

  • Went looking under interfaces... hardware.  The only options available to the VMXNET3 adapters is HA monitoring and virtual MAC.  I guess the virtual UTM is smart enough to know physical layer options aren't available to it.  I thin my next guess is to try with E1000 NICs and see if that matters.  

  • HI, welcome to participation in the UTM Community and thanks for the tip-o-the-hat!

    I'm not a fan of the wireless routers that AT&T uses in homes.  My experience when I tried AT&T for a year in my lab at home was that their router kept losing its configuration.  I'd be interested in knowing if you're seeing that in today's equipment.

    I do have two clients that I know of that use AT&T fiber.  In both cases, we had to disable 'Auto negotiation' and set fixed speeds and duplex for the UTM interface hardware and the interface on the Cisco router provided by AT&T.

    Any luck with that?

    Cheers - Bob
    PS  I'm about 200 miles straight north of you.

     
    Sophos UTM Community Moderator
    Sophos Certified Architect - UTM
    Sophos Certified Engineer - XG
    Gold Solution Partner since 2005
    MediaSoft, Inc. USA
  • Tell more about the specs of your system.

    What CPU does it have? Amount of RAM?

    Are you using Intel NICs or Realtek?

    Would QoS cause these problems? 

    Can someone here say if using IPv4 or IPv6 would make a difference?

    It's hard to tell if it's a hardware issue since you are running the UTM in a VM (instead of bare metal) which will create overhead and reduce performance.

  • Possible you can change the interface-settings at VMWARE-level


    Dirk

    Systema Gesellschaft für angewandte Datentechnik mbH  // Sophos Platinum Partner
    Sophos Solution Partner since 2003
    If a post solves your question, click the 'Verify Answer' link at this post.

  • I've been off and on here before.  Mainly off and then when something happens I can't remember what Email address I used on the forums so I make a new one.  

    I haven't messed with the settings of the ATT router much since I can get full  gig on another device plugged into it.  I may see about flopping cables and/or ports.  I thought I had done that but perhaps not.

  • The ESXi hosts are Dell R720 servers with Broadcom and Intel physical NICS.  The procs are Xeon 2.6GHz 8 cores 2 sockets.  The VM NICS are VMXNET3.

    I checked QoS as well on the initial existing UTMs and it was not configured.  Same on the new ones I built.  

    Ooooo IPV6.  I hadn't thought of that.  

    I agree about the virtualization overhead not being the best for performance.  I am getting anywhere from 500-900Mbps on download.  If I can get the same on upload, I would be ok.  

  • If it ends up being something in the virtual stack that I cannot remediate, since this is a Home license and I want to have full gig both ways, what hardware device would you guys recommend?