BUG - logviewer search for specific category does not work fully.

Hi folks,

sometime ago I logged a question about how a home user is able to have a website classification changed and was advised to use the logviewer to find the specific URL.

I have tried many different ways and so far none have produced a valid result when searching for e-commerce. So I tried today under v18 to see if the search issue had been fixed and appears not. I can search for other categories in both web and application logviewer displays, just not e-commerce.

Ian

  • There is no web category "e-commerce".

    You can see the list of categories in Web > Categories.  There is a category Financial Services, which may be what you want.

     

     

  • Hi,Michael,

    I just found there is no e-commerce category, but the daily reports show the entry as e-commerce.

    So somewhere in XG there's a table pointing at e-commerce that needs updating?

    Ian

     
    V18.0.x - e3-1225v5 6gb ram with 4 ports - 20w. 
    3 AP55s and 2 APX120s having a holiday until software update is released.
    If a post solves your question use the 'This helped me' link.
  • Ahh, there is an Application categorization called E-commerce.

    Configure it using Applications > Application filter rules and look at it in the Log Viewer > Application filter.

     

    Application categorizations are separate from website categorizations.

     

    What is it that you are actually trying to do?  What is the bug?

  • Hi Michael,

    I am trying to identify a site that I think is incorrectly classified as e-commerce when it should be advertisement so I can block it in my own filter, the details are in the screenshot I posted. Keyur suggested I look at the logviewer e-commerce report fri the specific site so he could pass the details along, but I search using logviewer and find nothing in applications or web.

    Ian

     
    V18.0.x - e3-1225v5 6gb ram with 4 ports - 20w. 
    3 AP55s and 2 APX120s having a holiday until software update is released.
    If a post solves your question use the 'This helped me' link.
  • Thank you for the pointer. Found it and added it to one of my exiting policies.

    Ian

     
    V18.0.x - e3-1225v5 6gb ram with 4 ports - 20w. 
    3 AP55s and 2 APX120s having a holiday until software update is released.
    If a post solves your question use the 'This helped me' link.
  • There is no application category Advertising.  The two applications with "advert" in their name are both categorized as e-commerce.  I do not believe the current application category is wrong.

    I am not sure, but it may be that the Log Viewer > Application filter only shows blocks, not allows.

    You can create an application filter that selects an individual application and blocks it, then use the application filter within your firewall rule.

    When you have done so, if it is blocked you should see it in the Log Viewer > Application filter.  You might be able to search by timestamp to see if there is a related http/https traffic, but there may not be (application filters can apply to more than just http/https).

     

    Note: This has nothing to do with v18.  v17.5 behaves exactly the same.

  • You can block advertisements by using an XG provided policy. Yes, v17 did behave this way and I asked in v17, but now v18 is the active XG version.

    Ian

     
    V18.0.x - e3-1225v5 6gb ram with 4 ports - 20w. 
    3 AP55s and 2 APX120s having a holiday until software update is released.
    If a post solves your question use the 'This helped me' link.