Firefox v71 and PDF Readers

I am using a Windows 7 Pro  32 bit PC with Sandboxie 5.30 installed.

Before the recent Firefox update I had Firefox set up to read PDF documents.

With the new update to FF v71 when I run FF Sandboxed and I click on a PDF file a window pops up asking me to select the program that I want to open the PDF file in.

The radio button to make the program the deafault is always ticked but every time I go to view the file the same window pops up.

This does not happen when I run Firefox Un-sandboxed.

Is there anything that I can do to remedy this situation?

Has anbody else experienced this?


PS. I also have a Laptop running Windows 7 Home 32 bit, the same thing happens there.

  • I don't have your setup, but have you checked the Applications setting under about:preferences which sets how pdf files are treated? Otherwise, try using the internal pdf viewer - pdf file can be downloaded from it.

  • In reply to henry g:

    In Options (preferences) I have FF set up to use a PDF reader, the default PDF Reader/Editor.

    Changing to FF's viewer makes things worse, in or out of the Sandbox the screen flashes, nothing happens.

    I can set it to "Save file" but I want to be able to delete pages before saving. Prefer not to.

    This is under "Applications" in FF.

     

    The window that pops up that I referred is the Windows7 "Open With" window.

  • In reply to kerflot:

    Same thing is happening with other apps.

    System: Windows 10 1809 x64

    Sandboxie: 5.31.4 & 5.31.6

     

    Before updating Firefox to v71, the open-with pop-up in Firefox functioned properly (e.g., opening a rar\zip archive with winrar\7zip). At the time I was with Sandboxie 5.31.4.

     

    After updating Firefox to v71, the open-with pop-up in Firefox no longer behaves as expected. This is, the save-as works OK, the the open-with no longer opens the desired app. Updated to Sandboxie 5.31.6, but the problem remains.

     

    Running Firefox outside the sandbox works as expected without problems.

     

    More details about the problem: Inside the sandbox, when choosing open-with, the associated app\program doesn't run, but Firefox shows the file as downloaded OK in the download tab (remember that I didn't choose to save the file, just to open it with some app).

    In the about:downloads, the zip\rar\etc... file show as downloaded. Normally, if I double clicked on it, the associated app would open. Nothing happens when Firefox v71 is sandboxed.

    However, If I right-click on it and choose "Open Containing Folder", sandboxie opens a Windows Explorer Window (sandboxed) in "<windows-drive>:\Users\<user-name>\AppData\Local\Temp" where resides the file I wanted to open through Firefox.

    It seems that with the newer version of Firefox, whenever I run it sandboxed and choose to open some file instead of saving it, Firefox still manages to download the file to a temp folder, but is no longer able to open the associated app\program to show it.

  • In reply to Abrupt Kahn:

    I can also confirm this problem with Firefox 71.0 and Sandboxie 5.31.6.

  • In reply to APMichael:

    Same for me, very annoying.

  • In reply to Abrupt Kahn:

    Files with a linked application are stored in the AppData\Local\Temp\ directory, which is normal.

    Files that are to be saved end up in the selected download directory.

    Why the start does not work anymore, I don't know (yet). I wrote a question in the Firefox forum, maybe someone will help.

  • In reply to Herman Smith:

    In Windows 7 32 bit.

    Under General > Applications

    I don't know how I did it but obviously did out outside of Sandboxie.

    I ended up with an extra CONTENT TYPE of file with my preferred PDF Reader. See picture.

    it works for me.