Block specific version build

Hi,

Is it possible to block or script-block a specific version build?

For example, let's say a CVE was released for Notepad v1.0 but Notepad v2.0 is available.  Can or (how can I) block those older builds?

Thanks,

Adam.