New Sophos RED-20 not booting

Hello,

I am having issues with a new Sophos RED 20 that is not booting anymore. I have started it with a console cable and it seems to have a booting issue. I have run a memtest and hardware test and its all fine. How can I flash it manually over the console cable ? Is there any way ? 

U-Boot 2018.09 (Apr 23 2020 - 05:30:45 +0000), Build: jenkins-Red_Unified_Firmware_v3-86

SoC: LS1012AE Rev2.0 (0x87040020)
Clock Configuration:
CPU0(A53):800 MHz
Bus: 250 MHz DDR: 1000 MT/s
Reset Configuration Word (RCW):
00000000: 08000008 00000000 00000000 00000000
00000010: 35080000 c000000c 40000000 00001800
00000020: 00000000 00000000 00000000 00014172
00000030: 00000000 00428120 00000096 00000000
I2C: ready
DRAM: 446 MiB
WARNING: Calling __hwconfig without a buffer and before environment is ready
Using SERDES1 Protocol: 13576 (0x3508)
MMC: FSL_SDHC: 0, FSL_SDHC: 1
Loading Environment from SPI Flash... SF: Recognized JEDEC id bytes: ef, 60, 15
SF: Detected w25q16dw with page size 256 Bytes, erase size 4 KiB, total 2 MiB
SPI NAND PROBE!
SF: Recognized JEDEC id bytes: ef, bb, 21
SF: CONFIG_SPL_BUILD Detected W25N01GW with page size 2 KiB, erase size 128 KiB, total 128 MiB
spi_flash_scan: Printf SR1 = 0x0, SR2 = 0x18, SR3 = 0x0
spi_flash_scan: MAX READ SIZE = 0x40, MAX WRITE SIZE = 0x20
Probe over!
OK
In: serial
Out: serial
Err: serial
Model: SOPHOS RED20 Board
Board: SOPHOS RED20
HW: RevC
MCU Version: 8
WARN: MAC Private MAC address for ethaddr is F2:F1:59:35:C6:33 restore of Sophos MAC required!
WARN: MAC Private MAC address for eth1addr is 42:C3:34:DE:7A:36 restore of Sophos MAC required!
Net: PFE class pe firmware
PFE tmu pe firmware
eth0: pfe_eth0, eth1: pfe_eth1
Hit any key to stop autoboot: 0
Unknown command 'boot_image' - try 'help'

Any help would be appreciate.

Thanks

  • => printenv
    arch=arm
    baudrate=115200
    board=sophos_red20
    board_name=sophos_red20
    board_rev=2
    boot_cmd=boot_image1
    boot_image1=echo starting Image1...;run boot_load_nand_image1; run boot_ram; echo Booting Image1 Failed try Image2; run boot_image2
    boot_image1_once=env set bootcmd "run boot_image2"; env save; run boot_image1
    boot_image2=echo starting Image2...;run boot_load_nand_image2; run boot_ram; echo Booting Image2 Failed try Image1; run boot_image1
    boot_image2_once=env set bootcmd "run boot_image1"; env save; run boot_image2
    boot_load_from=undefined
    boot_load_nand_image1=sf probe; sf nand_read ${kernel_addr_r} ${nand_uimage1_addr} ${nand_uimage1_size}; sf nand_read ${fdt_addr_r} ${nand_fdt1_addr} ${nand_fdt1_size}; env set boot_load_from image1
    boot_load_nand_image2=sf probe; sf nand_read ${kernel_addr_r} ${nand_uimage2_addr} ${nand_uimage2_size}; sf nand_read ${fdt_addr_r} ${nand_fdt2_addr} ${nand_fdt2_size}; env set boot_load_from image2
    boot_load_tftp=mcu led 3 1 1; tftp ${kernel_addr_r} red/red-unified-firmware-layerscape-armv8_64b-red20-initramfs-kernel.bin; tftp ${fdt_addr_r} red/image-sophos-red20.dtb ; env set boot_load_from tftp; mcu led 3 0
    boot_ram=echo Stop PFE...; pfe stop; echo starting openwrt ...; mcu led 1 1 1; env set bootargs ${bootargs_base} ${bootargs_additional} boot_load_from=${boot_load_from} mcu_resetpb_time=${mcu_resetpb_time}; bootm ${kernel_addr_r} - ${fdt_addr_r}; mcu led 0 1 1
    boot_usb=echo Start USB; usb start; usb storage; usb dev 0; fatload usb 0:1 ${fdt_addr_r} boot_${board_name}.bin; source ${fdt_addr_r}
    bootargs=console=ttyS0,115200 root=/dev/ram0 earlycon=uart8250,mmio,0x21c0500
    bootargs_additional=redd
    bootargs_base=console=ttyS0,115200 root=/dev/ram0 earlycon=uart8250,mmio,0x21c0500
    bootargs_kdb=nokaslr kgdboc=ttyS0,115200 kgdbcon
    bootargs_kdb_stop=${bootargs_kdb nokaslr} kgdbwait
    bootcmd=boot_image
    bootdelay=3
    bootfile=red/tftp_boot_red20.bin
    console=ttyS0,115200
    cpu=armv8
    eth1addr=42:C3:34:DE:7A:36
    ethact=pfe_eth0
    ethaddr=F2:F1:59:35:C6:33
    fdt_addr_r=0x80000000
    fdtcontroladdr=979f4fc0
    format_ubi=echo Formatting UBIFS; sf probe; sf nand_erase ${nand_data_addr} ${nand_data_size}; echo Done.
    ipaddr=192.168.0.150
    kernel_addr_r=0x81000000
    mcu_resetpb_action1_time=65535
    mcu_resetpb_action2_time=65535
    mcu_resetpb_debounce_time=100
    mcu_resetpb_debug=0
    mcu_resetpb_factory_time=10
    mcu_resetpb_time=0
    nand_data_addr=0x5c00000
    nand_data_size=0x2000000
    nand_fdt1_addr=0x200000
    nand_fdt1_size=0x100000
    nand_fdt2_addr=0x2f00000
    nand_fdt2_size=0x100000
    nand_uimage1_addr=0x300000
    nand_uimage1_size=0x2800000
    nand_uimage2_addr=0x3000000
    nand_uimage2_size=0x2800000
    resetpb_factory=echo Factroy reset; run format_ubi; run boot_usb
    serverip=192.168.0.11
    soc=fsl-layerscape
    stderr=serial
    stdin=serial
    stdout=serial
    vendor=freescale
    vlan_test=0

    Environment size: 2796/65532 bytes
    =>

  • I have managed to repair the uboot but now the red tries to boot the image and is stuck in a boot loop.

    [ 73.752904] pfe_hif_client_unregister
    [ 73.758101] device redc0 left promiscuous mode
    [ 73.762616] br-lan: port 2(redc0) entered disabled state
    [ 73.908224] pfe 4000000.pfe eth1: pfe_eth_shutdown
    [ 73.923876] hif_lib_client_unregister : client: ffff800000fe28c8, client_id: 1, txQ_depth: 2048, rxQ_depth: 256
    [ 73.940777] hif_process_client_req: unregister client_id 1
    [ 73.946322] pfe_hif_client_unregister
    [ 74.565227] pfe 4000000.pfe eth1: Link is Down
    [ 75.121314] UBIFS (ubi0:1): un-mount UBI device 0
    [ 75.126122] UBIFS (ubi0:1): background thread "ubifs_bgt0_1" stops
    [ 75.161326] UBIFS (ubi0:0): un-mount UBI device 0
    [ 75.166100] UBIFS (ubi0:0): background thread "ubifs_bgt0_0" stops
    [ 78.465403] imx2-wdt 2ad0000.wdog: Device shutdown: Expect reboot!
    [ 78.471714] reboot: Restarting system
    INFO: PSCI Power Domain Map:
    INFO: Domain Node : Level 2, parent_node -1, State ON (0x0)
    INFO: Domain Node : Level 1, parent_node 0, State ON (0x0)
    INFO: CPU Node : MPID 0x0, parent_node 1, State ON (0x0)INFO: BOOT SRC is QSPI
    NOTICE: DDR Init Done
    NOTICE: BL2: v1.5(release):redfw_3.0.000-3-g74a78d4e8
    NOTICE: BL2: Built : 05:30:45, Apr 23 2020
    INFO: BL2: Doing platform setup

  • Hallo Arnold,

    Sounds like a candidate for an RMA - what does Sophos Support say?

    Cheers - Bob

     
    Sophos UTM Community Moderator
    Sophos Certified Architect - UTM
    Sophos Certified Engineer - XG
    Gold Solution Partner since 2005
    MediaSoft, Inc. USA
  • Hey ,

    Thank you for reaching out to the community, yes this needs  to be processed for the RMA, please raise a service request and revert here with the support case id !!

    Thanks & Regards,

    Vivek Jagad | Technical Account Manager 3 | Cyber Security Evolved


    Sophos Community | Product Documentation | Sophos Techvids | SMS
    If a post solves your question please use the 'Verify Answer' button.