This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

Connectwise Automate Feedback & Questions.

Please use this space to create a new post for issues you are having if you do not see a post already created for your issue.  We will also welcome feature functionality feedback, enhancement requests, and general questions.



This thread was automatically locked due to age.
  • Upon trying to add the Sophos plugin DLL to Automate, I encountered an error. When I reached out to Automate support, they refused to help because the plugin is "unsupported" and "not certified". Who can I reach out to for plugin installation support?

  • Are you getting the following error?

    Troubleshooting & Logging

    Installation issues:

    Issue: There was an error uploading the new plugin: Could not load file or assembly
    file:///C:\Users\*******\AppData\Local\Temp\tmp48DB6.tmp' or one of its dependencies. Operation is not supported.
    (Exception from HRESULT: 0x80131515)

    Solution: As this plugin is not available from the solution center, but downloaded from the Sophos Central Community, you may need to unblock the .DLL file by right clicking and navigating to file properties, as shown in the below screenshot

  • That was exactly the issue. Thanks!

  • Does the autodeploy work with Catalina?

  • Deployment is Windows Only right now.

  • What do we do about these frequent, ongoing sync errors:

    "Cannot implicitly convert type 'SophosCentral.Data.ApiModels.SophosEndpoint' to 'SophosCentral.Data.Tables.PluginComputer'. An explicit conversion exists (are you missing a cast?)"

    and

    "Failed WhoAmi call status code: 429, reason is Too Many Requests"

    Do we have the ability to slow down the sync frequency? Seems like it's trying too hard, or something.

    Also, can we mark tenants as "not appearing in Automate" so they aren't showing up in the Clients view at all? Some of our Central tenants are devices-only, or not managed services clients, that sort of thing.

  • Were you using an older Early Access version of the Connectwise Plug-in Previously?

    The 429 Too Many Requests is fine for now. It is hitting an API Limit that we have currently. That limit will be adjusted, which will address those errors.

    You have an option at the top right of the screen to filter by Connectwise Only. On the next release, this will become the default view.

  • Nope, our first install of the plugin was from a download made yesterday. It's the 10072020 named version of the DLL.

    Having fiddled with it a bit more this morning (I spent an hour last night doing the install & linking of clients to tenants) I think the biggest change I'd ask for is a way to slow/control the refresh rate in the filtered computer views. It takes a full minute to load the filter results, then by the time it's done loading it starts over again on a refresh. Hard to get anything done that way.

  • Thanks for the feedback Grey! This is something we'll take into consideration.