This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

Connectwise Automate Feedback & Questions.

Please use this space to create a new post for issues you are having if you do not see a post already created for your issue.  We will also welcome feature functionality feedback, enhancement requests, and general questions.

This thread was automatically locked due to age.
Parents Reply Children
  • Are you getting the following error?

    Troubleshooting & Logging

    Installation issues:

    Issue: There was an error uploading the new plugin: Could not load file or assembly
    file:///C:\Users\*******\AppData\Local\Temp\tmp48DB6.tmp' or one of its dependencies. Operation is not supported.
    (Exception from HRESULT: 0x80131515)

    Solution: As this plugin is not available from the solution center, but downloaded from the Sophos Central Community, you may need to unblock the .DLL file by right clicking and navigating to file properties, as shown in the below screenshot

  • That was exactly the issue. Thanks!

  • This did not work for us, possibly because we have our Automate hosted with the newer CW Cloud offering.  After beating on support for a while and with Steve Weber's assurances, Automate Support finally agreed to load the .DLL from their end and it's working like a top now. 

    William Hincks

    President - Moebius Technology Solutions, Inc.

  • We're also getting the same error. We've unblocked, and we're on premise. I'm trying support now but not getting anywhere unfortunately. They had me move it to the plugins folder, and try to add it again, but I'm getting the same error.

  • I managed to pry the following from them, but it won't work for us. They're bouncing us back to Sophos. 

    Automate Support must install the Sophos DLL for partner
    Add dll to Automate Server (C:\program files\LabTech\plugins)
    Open Plugin Manager > manage plugins
    Select Add Plugin
    Browse to program files plugins and select the Sophos
    Select open and then save and close the plugin screen
    Enable the Sophos plugin in the plugin manager
    Verify that Labtech database agent service restarted
    close control center and log back in
    Navigate to Tools > Sophos to ensure the dashboard opens and loads
  • Candace, are you Cloud Hosted with CW for your Automate instance?  We are and they kept pushing us back to Sophos too, but we finally found an Automate Tech that would truly look into the issue and he loaded the .DLL for us (and it's working smoothly).  If this fits your scenario and you'd like to email me at I'll be happy to provide what info I can from our encounter with support.  It may give you the leverage you need. 

    EDIT:  I just noticed your earlier post that you were on-prem, so our experience with Automate Support may not apply.  I guess I can maybe see why they won't assist with loading a foreign .DLL in that situation.  It's frustrating though, everyone involved is owned by the same parent company... can't we all just get along!  LOL. 

    William Hincks

    President - Moebius Technology Solutions, Inc.

  • Exactly! It's super frustrating being bounced back and forth. I understand it's not signed so they want to wash their hands of it, but it's not like it's some unknown company.  I even made them go check what they did in their notes for you, which is how I got the above steps. Sadly, it's still a no-go. Thanks for responding though!

  • That's frustrating.  Keep on's a great Plug-in and its worth it!!!!

    William Hincks

    President - Moebius Technology Solutions, Inc.

  • What error are you getting? This works with on-premise Automate without a problem. You just have to first unblock the DLL file by right-clicking it and clicking properties. Unblock the DLL and then load it again. PM, me if you need assistance.