Installation stuck at "detecting asg devices"

Hello,

Thank you for providing the Sophos UTM product for home use. I am trying out Sophos UTM for first time on a machine that has been running pfSense for years. The installation is stuck at "Detecting ASG Devices". I have re-run this a few times with the same result.

How do I get past this to install?

I have attached screenshots of the installer and the console in case helpful.

I am using asg-9.510-5.1.iso from a thumbdrive made bootable by Rufus.

 

Thanks,

Ari

  • Hi Ari,

    I would like to recommend you to use Etcher instead of Rufus. Refer to the KBA here, and let us know if that suggestion works.

    Thanks

  • In reply to sachingurung:

    Thank you for the suggestion. I had initially tried win32diskimager per the documentation, but found that it would not support .iso images (only .img). That is why I moved on to try Rufus to burn the image to the USB thumb drive. Rufus made a bootable image from asg-9.510-5.1.iso but not from SW-17.1.3_MR-3-250.iso.

    I have tried the suggestion of using Etcher instead of Rufus. Etcher was not able to make bootable images from either asg-9.510-5.1.iso or SW-17.1.3_MR-3-250.iso.

    Is there a different image I should be using? A different image burning tool? USB thumb drive OK to burn to and boot/install from?

    Again, I am trying to put home version of either Sophos UTM (preferable) or XG onto a device that has been running pfSense for a number of years (i5, 4gb ram, dual intel GB lan, 120GB SSD).

    Thank you again for any assistance.

    Ari

  • In reply to Ari Doucette:

    Hi Ari,

    Did you download the UTMv9 Software Appliance image file from the following source link: https://www.sophos.com/en-us/support/utm-downloads.aspx ?

    Thanks,

  • In reply to sachingurung:

    Per this thread

    I used the image labeled as software appliance with the filename "asg-9.510-5.1.iso"

    Was that the correct one?

    Or please suggest another?

    Thank you

    Ari

  • In reply to Ari Doucette:

    You have the right image, Ari.  Did you run an MD5 checksum on the ISO before you burned it to your USB key?  It could be that some hardware device in your setup is not supported.  The Intel 82574 has problems, but I don't know about yours.  Folks also have problems with video.

    Cheers - Bob

  • In reply to BAlfson:

    The MD5 sum was correct.

    Per the forum it appears others have had problems with the iso images not being bootable.

    https://community.sophos.com/products/unified-threat-management/f/hardware-installation-up2date-licensing/105715/installation-stuck-at-detecting-asg-devices/385793#385793

    Similar to that thread, in my trials, the only way I have been able to get a bootable usb drive from the provided iso images is to use Rufus and to select DD mode (option appears after telling Rufus to burn the image to the thumb drive).

    So I still had the problems with Sophos UTM being stuck at detecting ASG devices. (Could it be hardware incompatibility? My NICs are Intel 82577LM and Intel 82583v).

    However, was able to install Sophos XG. Unfortunately, I could not get XG to provide a DHCP lease on the LAN so that I could get in and configure it. I used the VGA console to set a LAN IP address (192.168.10.1) and then, even connecting directly to the LAN NIC, I was not able to access (or ping) the admin interface at http(s)://192.168.10.1:4444

    So, UTM may not work for my hardware. And as for using XG, this topic would then move into "how to initially configure".