This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

UTM 9.601 - RED issues!

Since upgrading all our customers to 9.601, a bigger part of them are complaining about RED's re/disconnection in a no-pattern way.

It started for all of them just the night we upgraded to 9.601, and they all are on different ISP's and located different places around the country.

Been with Sophos support for 2 hours today, and now they escalated it to higher grounds.

Will return with an update....

Suspicious entries in the log - but all connected REDs do this before connection:

2019:03:06-15:15:38 fw01-2 red_server[17509]: SELF: Cannot do SSL handshake on socket accept from '': SSL connect accept failed because of handshake problems

2019:03:06-15:15:46 fw01-2 red2ctl[12420]: Missing keepalive from reds3:0, disabling peer

I know the last line is written before the tunnel disconnects, because there was no "PING/PONG" answer...

One customer has 2 x RD 50, one 1 100% stable and the other fluctuates in random intervals - we replaced this with a new RED 50, but the same thing occurs.

This thread was automatically locked due to age.
  • Same issues here after 9.601-5 UTM update. 2x RED50 Rev 1. Drop multiple ISPs at varying intervals and lengths. It was advised to re-create RED in UTM. I have performed this, but problems still persist. I was sent two replacement RED50. The first one has been replaced, a new config created, but problem persists. ISPs modems have been replaced although they were reluctant to do so. One of the REDs wont recognize the presence of ISP on WAN1 at all.

    We are losing a lot of productivity and business. We do a sizeable portion of our business via teleconferencing.

    Support Tickets#





    The tech alluded to a potential issue with REDs after the update to 9.6.01-5.

  • My problem is resolved. There is a known issue related to unified firmware.

    from su -

    cc get red use_unified_firmware

    if value returned = 1

    cc set red use_unified_firmware 0

    reds will update and reboot

    confirm value is 0 rerunning get command above


    NOT A PERMANENT FIX. The issue needs to be addressed in Sophos UTM firmware permanently.

  • seems to be a timing issue... When i disable the RED for 5 minutes on the UTM it works fine shortly after reenabling it again.

    No 'stabelizing peers' and such in the log - just 'tunnel -up' -> PING PONG, PING PONG

    Tunnel is stable until the DSL-Line does its 24h reconnect then.
    This brings it out of 'sync'...

    Then until i disable and reenable the RED i can see -> boot -> stabelizing peers -> 5 ICMP Packets go through the tunnel (yay!) -> unstable peers -> reboot (oh no!)
    ... over and over again ...

  • Hi all,


    Sorry for the delay, been on vacation for a week - my nerves cound not stand it anymore ;-)

    I also did the "cc set red use_unified_firmware 0" before I left, and can confirm it solved ALL MY ISSUES.

    Had one customer with two RED 50s, one was very unstable and another was completely offline, we have setup temporary SG115's with IPSEC just to keep the customer running.

    After I have disabled the new unified firmware, both RED 50's are back and 100% stable!

    Sophos Support claims that there are no issues with this, but please, keep refering to this community string, so they can see, that there actually are problems.

    I have enabled RED debugging with suppoort, and inserted USB key for debug logging into the red 50, but nothing important was shown.

    We have the unified firmare enabled with several other customers, which have no issues with it, so it's odd, I think it looks like some ttl, ips issues, with the different ISP.


    Some other issues have been located, and it seems like Sophos it looking into it:


    Best regards

    Sophos XGS 2100 @ Home | Sophos v20 Architect

  • I have had the same issues described.


    I was issued an RMA and got a new RED50 box.


    it bricked again within 12 hours.

  • Hello Bob,

    i am trying to connect a RED 15 to our UTM with 9.6.01 Firmware (SG115) the first time now and get the same error now:

    SELF: Cannot do SSL handshake on socket accept from '': SSL connect accept failed because of handshake problems.

    Do you know when Sophos will fix this and release a new Firmware fot UTM and RED?

    Regards, Reinhold

  • Hallo Reinhold,

    Did you try James Stoy's solution above - switch to MTU1400 and disable/enable the RED?  If that didn't work Sophos may want to RMA the 15.

    Cheers - Bob

    Sophos UTM Community Moderator
    Sophos Certified Architect - UTM
    Sophos Certified Engineer - XG
    Gold Solution Partner since 2005
    MediaSoft, Inc. USA
  • Hello Bob,

    yes, not i tried it out, MTU 1400

    Its a different error in the log now, but it does stikll no connect:

    2019:04:26-08:27:33 fw red_server[4454]: SELF: (Re-)loading device configurations
    2019:04:26-08:27:36 fw red2ctl[4383]: Overflow happened on reds1:0
    2019:04:26-08:27:36 fw red2ctl[4383]: Missing keepalive from reds1:0, disabling peer
    2019:04:26-08:28:41 fw red_server[8474]: SELF: New connection from with ID XXXXXXXXXXXXXX (cipher AES256-GCM-SHA384), rev1<30>Apr 26 08:28:41 red_server[8474]: XXXXXXXXXXXXXX: connected OK, pushing config
    2019:04:26-08:28:45 fw red_server[8474]: XXXXXXXXXXXXXX: command 'CON_CLOSE reason=fallback_config'
    2019:04:26-08:28:45 fw red_server[8474]: id="4202" severity="info" sys="System" sub="RED" name="RED Tunnel Down" red_id="XXXXXXXXXXXXXX" forced="1"
    2019:04:26-08:28:45 fw red_server[8474]: XXXXXXXXXXXXXX is disconnected.

    I have an open ticket at the german Sophos premium support, but still not solution.

    Need to get it running for a homeoffice start in May.

    Regards, Reinhold

  • Hi Reinhold,

    Have you tried the "disable unified firmware" fix yet? Most users who have tried the MTU 1400 fix state that disabling the unified firmware works for them.


    See the answer from  for more details.

    Let us know, if not I'm afraid it is an RMA.

    Kind Regards,


  • Hi James,

    yes, the Sophos Support did this first, but it did not help.

    It's very strange for me that the Sophos (Premium) Support does not know an anser and does not help me in any way.

    Looks like UTM-RED15 is a non working combination and they prefer XG.

    Regards, Reinhold

  • Reinhold, Premium support just means (in Europe) that you can contact Support directly instead of having to go through the Sophos Partner you purchased from.  You still get the lowest level of support personnel to start with.  Thousands of RED 15s are working well with UTMs.  You will want to request escalation.

    Cheers - Bob

    Sophos UTM Community Moderator
    Sophos Certified Architect - UTM
    Sophos Certified Engineer - XG
    Gold Solution Partner since 2005
    MediaSoft, Inc. USA
  • Hi,

    yes, i know, it sounds better than it is.

    In the meantime the Support did point me to the new UTM Firmware 9.602-3, released tonight on the ftp site.

    But it does not help. Now its escalated.

    Regards, Reinhold

Reply Children
  • Hi,

    still no solution, RED15 does not connect to SG115 with Firmware 9.602-3, it trys to connect and at the end says "is disconnected"

    Sophos escalted it to special team and they work on a fix for this new bug. No infor when it will be available

    Too bad that this happens right now, i need a Homeoffice VPN for an employee since 1rst May.

    Regards, Reinhold

  • Hi,


    have you tried with unified firmware = 0 just to see if it's the issue or you are facing other problems with the RED?


    My issues with RED 50's have been solved with 9.602 AND unified firmware = 1


    Best regards

    Sophos XGS 2100 @ Home | Sophos v20 Architect

  • Workaround for me: Just use 1x tunnel between Red and SGxxx - in redundant configuration we had the same problem. But it depends of the ISP on the site of REDs. With some ISPs we can use redundant tunnels, with other ISP we had to use just only one tunnel!

    good luck