Important note about SSL VPN compatibility for 20.0 MR1 with EoL SFOS versions and UTM9 OS. Learn more in the release notes.

This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

Can't register XGS87 with Sophos Central (initial setup)

Hello everyone,

i've already opened a case with Sophos, but since this is really urgent and they don't seem to have a solution yet, i thought i'd also post my issue here.

I'm setting up a new XGS87 for a customer, which i've done like a hundred times before.

I did the initial setup and skipped registration at first. Then i configured the XGS. In the end i tried to register it with Sophos' new integration with Central (Partner).

I logged in, claimed the device and got returned to the initial setup. And then i just had a blank page. And it's been like this for days. We tried different browsers, reset the device to factory defaults multiple times - even reimaged the device. But it all leads back to a blank page the and the error "couldn't connect to the registration service. reason: undefined". 

I checked the licenses log and it says this (i edited the serial number):

FO Nov 03 10:17:52Z [4159756032]: --requestType = 2
INFO Nov 03 10:17:52Z [4159756032]: --lastCheckCode = 00000000-0000-0000-0000-000000000000
INFO Nov 03 10:17:52Z [4159756032]: --cert = /content/licensing/lic_csr.pem
INFO Nov 03 10:17:52Z [4159756032]: --token = Token-Id:X0112xxxxxx
INFO Nov 03 10:17:52Z [4159756032]: --key = /content/licensing/lic_csr.key
INFO Nov 03 10:17:52Z [4159756032]: URL :
ERROR Nov 03 10:17:53Z [4159756032]: license_check failed : Provider returned internal error An error has occurred
ERROR Nov 03 10:17:53Z [4159756032]: licensing_do_licensecheck() :parsing response failed...

The firewall does show up in Central under "Flex Billings", but when i try to assign it to a customer, it gives me another error.

So now whenever we try to register it, it fails by saying "has already been claimed". We're completely stuck here. Support told me it's an issue by our ISP Provider, but we've NEVER had any issues before and i highly doubt that's what the log is saying. It sounds to me that the license provider has an issue and that it has something to do with the license migration to Central. The support also agreed that the license URL is accessible and telnet works either. So i can't imagine it's an ISP Provider issue.

Any help would be much appreciated! Thank you!

This thread was automatically locked due to age.
Parents Reply
  • Hello,

    our issue has been fixed! It was some licensing issue in Central. The firewall now appears under "Firewall licenses" and we were able to assign the licenses. After that we were able to complete the setup. So in case anyone else has this issue, make sure to get in touch with the licensing team at Sophos.