Interface speed Stuck at 10 Mbps - Half Duplex, Auto-negotiated, Grayed out.

I have never been able to change my Network, Interfaces, Connection, PortA=LAN or PortB=WAN, Interface speed.

The Interface speed is set to Auto negotiate and "Grayed out".

I am running on a VMware® Workstation 16 Pro, with NICs set to bridged mode, the NICs are I350-t-4 and I even went into the physical NIC settings and tried to set the negotiation speed from Auto to 100mb and 1gb, and also checked all the setting in the virtual network settings on the VM as well as the VM/Guest settings on the Guest machine hosting the SFVH/SFOS. SFVH (SFOS 19.0.1 MR-1-Build365).

How do I set the Interface speed above10 Mbps - Half Duplexand and resolve the Auto negotiate being "Grayed out"?

 



Updated Tags
[edited by: Erick Jan at 2:22 AM (GMT -7) on 4 Oct 2022]
Parents
  • Hi,

    please check the cable.

    Ian

    XG115W - v19.5 GA - Home

    Test machine - Asus P10S-i E3-1225v5, 6gb, 4 intel NICs, v19.5 GA

    If a post solves your question please use the 'Verify Answer' button.

  • Thank You for your response!

    I did just try the cable but it is the same.

    Note: The NIC on the physical Machine has always shown up as 100 or 1gb full duplex and same 1gb when viewing that NIC if I reassign it to another VM Guest. It is only the Sophos XG Guest that is at 10mbps/Half. 

    If I remember right I had a grayed out problem with something different in the past and the Sophos support cleared it up by using the client interface instead of the GUI..

  • Hi,

    in that case please try searching the forum, the answer might have been posted because I do remember another thread on a similar topic.

    Ian

    XG115W - v19.5 GA - Home

    Test machine - Asus P10S-i E3-1225v5, 6gb, 4 intel NICs, v19.5 GA

    If a post solves your question please use the 'Verify Answer' button.

  • I have found the CLI reference for SFOS 18 but the commands fall short of examples of commands for link speed.

    from console I typed: show network interface-speed PortB

    console states: PortB: 10Mb/s duplex: Half Link: yes auto-negotiation:No

    I tried to type: set network interface-speed PortB 1000fd

    But I get an "Unknown Parameter '1000fd'

    I tried various variables with no luck, I cant find the right string for after speed PortB ????

    Does anyone have a more detailed CLI command list or know what the correct command strings are?

  • Hi,

    it won't be portB more likely port1, mine are labelled port1, port2 etc.

    Ian

    XG115W - v19.5 GA - Home

    Test machine - Asus P10S-i E3-1225v5, 6gb, 4 intel NICs, v19.5 GA

    If a post solves your question please use the 'Verify Answer' button.

  • Mine is PortA and PortB

    I am now stuck at list-of-speeds , none.

    Can I turn this post into a support ticket?

  • Mit freundlichem Gruß, best regards from Germany,

    Philipp Rusch

    New Vision GmbH, Germany
    Sophos Silver-Partner

    If a post solves your question please use the 'Verify Answer' button.

  • Are you a business or a home user? If a home user then the forum is your support.

    Ian

    XG115W - v19.5 GA - Home

    Test machine - Asus P10S-i E3-1225v5, 6gb, 4 intel NICs, v19.5 GA

    If a post solves your question please use the 'Verify Answer' button.

  • Both.

    Thanks for the link, That help doc is limited or missing moved content.

    Her is a more complete doc but its v16. Sophos XG Firewall Web Reference and Admin Guide

    on page 103, line 7.

    7. Enter details for the Advanced Settings. Interface Speed Select interface speed for synchronization. Interface speed can also be configured through CLI using "set network interface-speed" command. Speed mismatch between the device and third-party routers and switches can result in errors or collisions on the interface, disconnection, traffic latency, or slow performance. Depending on the model deployed, the following options are available: Auto Negotiation 10 Mbps - Half Duplex 10 Mbps - Full Duplex 100 Mbps - Half Duplex 100 Mbps - Full Duplex 1000 Mbps - Full Duple

    Command Line Interface [CLI]

    • Log in to the CLI using Telnet or SSH. You can also access the CLI from admin > Console in the upper right corner of the Admin Console screen.
    • Choose option 4. Device Console. Execute the following command:
    • console> set network [interface-speed [Port<port name or number > <1000fd | 1000hd | 100fd | 100hd | 10fd | 10hd | auto >] |

    I tried to type: set network interface-speed PortB 1000fd

    But Error "Unknown Parameter '1000fd' comes up.

    If you type set network interface-speed PortB speed ?

    the CLI helper will show a statement <list-of-speeds> None

    If you type set network interface-speed PortB ?

    the CLI helper will show a statement <Speed   Speed.> 

    So I am stuck at <set network interface-speed PortB speed "What goes here">

    I don't know the correct syntax to type for the port speed, I tried 1000fd and 1000full-duplex ect.

    The only thing I can guess is the version change has different syntax, but it is an undocumented change or maybe incomplete code.

    Wishing you well, done for now in the states..

    Sincerely,

    Thank You!

    Tony

  • this stands out to me

    <list-of-speeds>

    None 

    I wonder if wherever the file/code is that stores the list of speeds is probably blank or corrupt. 

    I know I have installed new images of XG, so I don't think its corruption.

Reply Children
No Data