Important note about SSL VPN compatibility for 20.0 MR1 with EoL SFOS versions and UTM9 OS. Learn more in the release notes.

This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

Interface speed Stuck at 10 Mbps - Half Duplex, Auto-negotiated, Grayed out.

I have never been able to change my Network, Interfaces, Connection, PortA=LAN or PortB=WAN, Interface speed.

The Interface speed is set to Auto negotiate and "Grayed out".

I am running on a VMware® Workstation 16 Pro, with NICs set to bridged mode, the NICs are I350-t-4 and I even went into the physical NIC settings and tried to set the negotiation speed from Auto to 100mb and 1gb, and also checked all the setting in the virtual network settings on the VM as well as the VM/Guest settings on the Guest machine hosting the SFVH/SFOS. SFVH (SFOS 19.0.1 MR-1-Build365).

How do I set the Interface speed above10 Mbps - Half Duplexand and resolve the Auto negotiate being "Grayed out"?


This thread was automatically locked due to age.
Parents Reply Children
  • Both.

    Thanks for the link, That help doc is limited or missing moved content.

    Her is a more complete doc but its v16. Sophos XG Firewall Web Reference and Admin Guide

    on page 103, line 7.

    7. Enter details for the Advanced Settings. Interface Speed Select interface speed for synchronization. Interface speed can also be configured through CLI using "set network interface-speed" command. Speed mismatch between the device and third-party routers and switches can result in errors or collisions on the interface, disconnection, traffic latency, or slow performance. Depending on the model deployed, the following options are available: Auto Negotiation 10 Mbps - Half Duplex 10 Mbps - Full Duplex 100 Mbps - Half Duplex 100 Mbps - Full Duplex 1000 Mbps - Full Duple

    Command Line Interface [CLI]

    • Log in to the CLI using Telnet or SSH. You can also access the CLI from admin > Console in the upper right corner of the Admin Console screen.
    • Choose option 4. Device Console. Execute the following command:
    • console> set network [interface-speed [Port<port name or number > <1000fd | 1000hd | 100fd | 100hd | 10fd | 10hd | auto >] |

    I tried to type: set network interface-speed PortB 1000fd

    But Error "Unknown Parameter '1000fd' comes up.

    If you type set network interface-speed PortB speed ?

    the CLI helper will show a statement <list-of-speeds> None

    If you type set network interface-speed PortB ?

    the CLI helper will show a statement <Speed   Speed.> 

    So I am stuck at <set network interface-speed PortB speed "What goes here">

    I don't know the correct syntax to type for the port speed, I tried 1000fd and 1000full-duplex ect.

    The only thing I can guess is the version change has different syntax, but it is an undocumented change or maybe incomplete code.

    Wishing you well, done for now in the states..


    Thank You!


  • this stands out to me



    I wonder if wherever the file/code is that stores the list of speeds is probably blank or corrupt. 

    I know I have installed new images of XG, so I don't think its corruption.