Non working 2FA setup for Sophos Central


Recently I created a user account to log into Sophos Central. Once I provided the password, the site stated that I need to create a 2FA method. I clicked Next and I was prompted to enter a security code sent to my email and I had to create a 6 digit PIN so that I can use email as one of the 2FA methods. Then I clicked Next and was informed to select only either Mobile App or SMS as the 2FA method.

I selected Mobile App and the page stated that I could use common authenticators such as Google or Sophos Mobile, scan the QR code and type in the OTP displayed in the authenticator.

I tried using Google, Microsoft and also the authenticator I have inside Sophos Intercept X on my device but the page always state that the OTP code is wrong and a new code is now displayed in Google Authenticator.

This is confusing, no matter what authenticator I used, the error message says the OTP is wrong and a new OTP is displayed in Google Authenticator. Does that mean that Sophos Central only supports Google authenticator?

I also cannot find the option to use email as the 2FA even though one of the steps asked me to create a 6 digit PIN so that I can use email as the 2FA.

My colleague logged into his account and tried to disable the MFA requirement on my account but he said that the option is not available for him to do so (a Stop icon appeared on the mouse cursor as he moved the mouse over the link to disable MFA on my account).

What else can I do? Currently, due to all the tries I made, my account has been locked out (the error message said 30 minutes but I have been locked out since last week).

Edited tags
[edited by: Gladys at 9:29 AM (GMT -7) on 23 Aug 2022]